02-21-2017 09:57 PM
39 12
tools
  1. AC Question's Avatar
    Connected to Nexus 6P to PC using cable that came with the phone.

    After connecting, on the PC see dialogue for "Auto Play" for "Nexus 6P". Select "Open Device to view files" but don't see any files - e.g. pictures in "images" that I know should be there.

    From the phone, under "Internal storage and USB", I see breakdown of storage usage but no USB settings.

    On PC, device is showing as Model: 6P, Categories: Portable Media Player. The device driver is from Microsoft and version is 6.1.7601.18738.
    11-08-2015 10:02 AM
  2. anon8380037's Avatar
    11-08-2015 10:53 AM
  3. DLK1's Avatar
    Did you find a solution mine does not even show up as a device in Portable Media Player?

    Edit: OK I got it I do not know why this worked but it did. I went into Developer Option and in the Debugging section right under the option where you enable/disable USB debugging. There is an option for " Revoke USB debugging authorization" doing this "Revoke access to USB debugging from all computers you've previously authorized?". After doing this I reconnected and it showed up in Windows Device Manager and in IE as Nexus 6P. Case solved, thank you for your assistance in this matter.


    Connected to Nexus 6P to PC using cable that came with the phone.

    After connecting, on the PC see dialogue for "Auto Play" for "Nexus 6P". Select "Open Device to view files" but don't see any files - e.g. pictures in "images" that I know should be there.

    From the phone, under "Internal storage and USB", I see breakdown of storage usage but no USB settings.

    On PC, device is showing as Model: 6P, Categories: Portable Media Player. The device driver is from Microsoft and version is 6.1.7601.18738.
    huntnyc likes this.
    11-10-2015 12:37 AM
  4. lipmonger's Avatar
    After dealing with this problem for the past few days on my Nexus 6P, and not wanting to fix it with Developer Options, I figured out the problem:

    My Windows 7 computer was trying to use my old Nexus 4 and Nexus 5 ClockworkMod drivers to access my new Nexus 6P, and it just doesn't work right. To fix this issue you must replace the Nexus drivers on your computer. Do the following:

    1. Connect your Nexus 6P to your computer via a USB port (keep it set on Charging mode).
    2. Click on the USB devices icon in your status bar (near the clock). It's the USB graphic with the green check mark.
    3. Select "Open Devices and Printers".
    4. Even if you don't see your 6P in Windows Explorer, it should be listed here under Unspecified devices (at the bottom of the Devices window).
    5. Right-click on Nexus 6P.
    6. Select Properties.
    7. Go to the Hardware tab and click on the Properties button.
    8. Go to the Driver tab.
    9. Click the Uninstall button.
    10. Click OK on the pop-up window that appears.
    11. Now, on your 6P (which should still be connected to your PC), swipe-down the notification bar and change the USB settings from Charging to "USB for file transfer."
    12. The new drivers will install and you should hear the Windows USB device connection sounds.
    13. The Nexus 6P will now be listed in Windows Explorer, and you can transfer files as you need.

    I hope this helps others out there.

    Cheers!
    DLK1, mik3w, sugra and 8 others like this.
    11-17-2015 01:36 AM
  5. ThomasOtt99's Avatar
    I am new to Android, but I was tell you what worked for me using WINDOWS 7 and a Nexus 6P:

    1. PLUG - USB-C end of the cable into the Nexus 6P;
    2. PLUG - USB-A end of the cable into your computer's USB port (3.0 or 2.0);

    --- You will hear a connection confirmation tone from your computer (or your computer will display a message confirming Nexus 6P driver installation).

    3. CLICK - on "Computer" in Windows 7;

    --- You should see Nexus 6P (Portable Device) icon.

    4. CLICK - on the Nexus 6P icon, and you should see file folders on your Nexus 6P;

    --- If you don't see files folders after clicking on the Nexus 6P icon -- go to next step.

    5. PULL DOWN the "messages' screen on the Nexus 6P from the top of the screen;
    6. LOOK for "USB for charging" message
    7. TOUCH - "USB for charging" message;
    8. SELECT - "File transfers" radio button;
    9. CLICK - on "Nexus 6p" icon on Windows 7;
    10. CLICK - on "Internal storage;"

    --- The file folders on the Nexus 6P should be visible.
    spacez and huntnyc like this.
    11-21-2015 05:35 PM
  6. syspry's Avatar
    I am new to Android, but I was tell you what worked for me using WINDOWS 7 and a Nexus 6P:

    1. PLUG - USB-C end of the cable into the Nexus 6P;
    2. PLUG - USB-A end of the cable into your computer's USB port (3.0 or 2.0);

    --- You will hear a connection confirmation tone from your computer (or your computer will display a message confirming Nexus 6P driver installation).

    3. CLICK - on "Computer" in Windows 7;

    --- You should see Nexus 6P (Portable Device) icon.

    4. CLICK - on the Nexus 6P icon, and you should see file folders on your Nexus 6P;

    --- If you don't see files folders after clicking on the Nexus 6P icon -- go to next step.

    5. PULL DOWN the "messages' screen on the Nexus 6P from the top of the screen;
    6. LOOK for "USB for charging" message
    7. TOUCH - "USB for charging" message;
    8. SELECT - "File transfers" radio button;
    9. CLICK - on "Nexus 6p" icon on Windows 7;
    10. CLICK - on "Internal storage;"

    --- The file folders on the Nexus 6P should be visible.
    The last step was all it took for me
    11-21-2015 07:26 PM
  7. sgorch's Avatar
    LipMonger's method worked for me with Win8.1 with one caveat

    1. Connect your Nexus 6P to your computer via a USB port (keep it set on Charging mode).
    2. Click on the USB devices icon in your status bar (near the clock). It's the USB graphic with the green check mark.
    3. Select "Open Devices and Printers".
    4. Even if you don't see your 6P in Windows Explorer, it should be listed here under Unspecified devices (at the bottom of the Devices window).
    5. Right-click on Nexus 6P.
    6. Select Properties.
    7. Go to the Hardware tab and click on the Properties button.
    8. Go to the Driver tab.
    9. Click the Uninstall button.
    10. Click OK on the pop-up window that appears.
    11. Now, on your 6P (which should still be connected to your PC), swipe-down the notification bar and change the USB settings from Charging to "USB for file transfer."
    12. The new drivers will install and you should hear the Windows USB device connection sounds.
    13. The Nexus 6P will now be listed in Windows Explorer, and you can transfer files as you need.

    I had to poke around a bit between steps 8-9. At first, the "uninstall" button was disabled. Poking a few other buttons/tabs (sadly, I don't remember what they were) got me to another window where the "uninstall" button was enabled. Then I proceeded from there without a hitch.
    lipmonger likes this.
    11-23-2015 10:29 AM
  8. saltiel's Avatar
    I have the same problem. Nexus 6P ONLY shows up in Devices and Printers under Unspecified. BUT if I go to Hardware > Properties > Driver the Uninstall Button is Grayed out. Only Driver Details is clickable. The driver showing is from 8/27/2012. Is there another way to uninstall the driver so I can install new ones?
    11-25-2015 10:04 AM
  9. Go0gle's Avatar
    This happened to me on my N5, all I had to do was acknowledge a prompt on the phone which allowed me to select in what capacity I would like the PC to be able to control my device. I selected something to do with moving/viewing files, and it worked perfectly after that.
    11-25-2015 12:28 PM
  10. mik3w's Avatar
    Thanks Lipmonger. Works for Windows 10.

    I have the same problem. Nexus 6P ONLY shows up in Devices and Printers under Unspecified. BUT if I go to Hardware > Properties > Driver the Uninstall Button is Grayed out. Only Driver Details is clickable. The driver showing is from 8/27/2012. Is there another way to uninstall the driver so I can install new ones?
    After Hardware tab -> Properties button
    General Tab -> Click "Change Settings" Click
    Driver Tab -> Uninstall.
    11-30-2015 03:49 PM
  11. sugra's Avatar
    Thank you so much.

    It worked.
    12-03-2015 03:36 AM
  12. MaxQ5597's Avatar
    Ok this worked for me. I opened Developer Options, scrolled down to "Select USB Configuration" then selected MTP (Media Transfer Protocol)
    From my PC (Surface Pro 3) I opened the file named "Nexus6p" and voila, there was my pictures. I was able to transfer back and forth. Booom!
    01-06-2016 09:17 PM
  13. Alan-Johnstone's Avatar
    Perfect answer, ThomasOtt99

    Thank you
    01-16-2016 04:49 AM
  14. SuprJoust's Avatar
    After dealing with this problem for the past few days on my Nexus 6P, and not wanting to fix it with Developer Options, I figured out the problem:

    My Windows 7 computer was trying to use my old Nexus 4 and Nexus 5 ClockworkMod drivers to access my new Nexus 6P, and it just doesn't work right. To fix this issue you must replace the Nexus drivers on your computer. Do the following:

    1. Connect your Nexus 6P to your computer via a USB port (keep it set on Charging mode).
    2. Click on the USB devices icon in your status bar (near the clock). It's the USB graphic with the green check mark.
    3. Select "Open Devices and Printers".
    4. Even if you don't see your 6P in Windows Explorer, it should be listed here under Unspecified devices (at the bottom of the Devices window).
    5. Right-click on Nexus 6P.
    6. Select Properties.
    7. Go to the Hardware tab and click on the Properties button.
    8. Go to the Driver tab.
    9. Click the Uninstall button.
    10. Click OK on the pop-up window that appears.
    11. Now, on your 6P (which should still be connected to your PC), swipe-down the notification bar and change the USB settings from Charging to "USB for file transfer."
    12. The new drivers will install and you should hear the Windows USB device connection sounds.
    13. The Nexus 6P will now be listed in Windows Explorer, and you can transfer files as you need.

    I hope this helps others out there.

    Cheers!
    This totally fixed it for me!!! Thank you!!!
    01-25-2016 04:59 PM
  15. dmxjago's Avatar
    FYI i notice the same issue where I would plug in the phone via usb to my windows pc and i would double click on the nexus 6p from windows explorer and I could not find any files. The issue for me was that from the notifications bar on the nexus i had to select "file transfer" option bc by default it says "charging". Once you toggle it works you can get all your pictures, music and pretty much any folder/files in the device.
    01-26-2016 11:55 PM
  16. yash b's Avatar
    thank you so much bro .it works my problem resolved cheers champ
    01-27-2016 07:13 AM
  17. Thuy Nguyen3's Avatar
    Your instructions work , many thanks!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    01-28-2016 04:32 AM
  18. cannonpeacelover's Avatar
    mate, you are a legend
    01-28-2016 07:46 PM
  19. mathewrockz's Avatar
    Thanks!!
    02-02-2016 11:17 PM
  20. YaSo's Avatar
    My Nexus 6P does not show in 'Windows Explorer' or in 'Devices and Printers' on my newly built Windows 7 PRO 64bit PC.

    (Though it did on my old Win 7 HOME 64 bit PC)

    I got my 6P just at the end of December 2015. Both the 6P and my 2013 Nexus 7 have Marshmallow 6.01 and would show up in Explorer when connected to any of my old PC's on-board USB 2.0 or add-on card USB 3.0 ports. (and after toggling the notification from 'Charging' to 'File Transfer'.)

    2 weeks ago updated the parts in my PC from a 6 year old motherboard and CPU with a new motherboard and CPU, and installed a fresh copy of Windows 7 PRO OEM, planning on upgrading to Win 10 later. I installed all of the motherbaord's drivers during the Windows install, and updated everything until they reported no new updates were available. The old motherboard, CPU and RAM went to a friend.

    Now when I plug in the 6P or the N7-2013, neither device shows in 'Windows Explorer' or in 'Printers and Devices'. They do show up in Device manager under 'Portable devices', which under Properties they both show as 'This device is working properly'.

    USB 2.0 and 3.0 Flash drives, external USB 2.0 and 3.0 hard drives, a 4th gen iPod Nano, and a Nexus 4 on 5.11 all connect, pop up the Autoplay dialog, and can be accessed in Explorer with no issues.

    -- I tried toggling to all of the options in the notification menu
    -- I tried changing debugging options on and off, and revoking USB debugging authorizations.
    -- I also tried uninstalling and letting Windows reinstall the generic drivers in Device manager.
    -- I also tried the OEM short USB C cable, and two Tech-Mate USB C cables, and different microUSB cables for the N7.
    -- I tried a powered USB 2 hub, a powered USB 3 hub, and even the USB 3.1 port on the back of the new motherboard.
    == Nothing got them to show in 'Explorer' or 'Printers and Devices' when I plug them in.

    I almost gave up until I plugged in my iPod, and when that got recognized, THEN the 6P or the N7 would be finally recognized in Explorer and Autoplay dialogs. My old Nexus 4 or a flash drive would also get Windows 7 pro to see the 6.01 devices.

    Any idea why the Marshmallow devices need another device to trick windows into seeing them? Thanks!

    (Gigabyte HD3P Z170 motherboard, Core i3-6100, 2x 8gb Crucial 2666 DDR4, Crucial 480gb SSD, Asus R9-270 2gb graphics, Windows 7 Pro x64 SP1)
    02-04-2016 07:20 PM
  21. YaSo's Avatar
    Well, I wish I knew what caused this. For two days I couldn't get either the N6P or the N7-13 to come up in Explorer, resorting to copying files to a thumbdrive and using OTG to transfer them to the devices.

    Then it started being recognized today. The only thing I did to the computer was to install Kerbal Space Program through Steam. So I guess I would add 'Install KSP' to the tricks to use to get your devices to work on Windows 7. Heh heh, here's to hoping it stays working.
    02-12-2016 07:38 PM
  22. lospopadosos's Avatar
    Lipmonger, it worked. Thanks!
    It didn't worked trhu USB3 at first but then I reconnected to USB2, MTP driver installed ok and then it worked thru USB3 as well.
    02-17-2016 11:50 AM
  23. Khyati Maloo's Avatar
    Mine is a windows 10, and I am unable to uninstall the drivers as that tab is not clickable. Could you help in that case?
    Thanks!
    03-16-2016 02:09 PM
  24. Rusty Blade's Avatar
    Thank you!! perfect
    03-20-2016 07:01 PM
  25. Shelly Becker's Avatar
    Thank you for the clear explanation! Problem solved.
    05-09-2016 02:27 PM
39 12

Similar Threads

  1. Why I can't sign-in my google account from my android phone?
    By AC Question in forum General Help and How To
    Replies: 1
    Last Post: 11-08-2015, 03:28 PM
  2. Nexus warming up
    By sliyk in forum Nexus 6P
    Replies: 4
    Last Post: 11-08-2015, 11:15 AM
  3. Replies: 0
    Last Post: 11-08-2015, 09:52 AM
  4. Where can I get a touch screen phone with only voice calls/sms?
    By AC Question in forum General Help and How To
    Replies: 1
    Last Post: 11-08-2015, 09:40 AM
  5. If I forget a wi-fi station can I get it back?
    By AC Question in forum Samsung Galaxy S5
    Replies: 1
    Last Post: 11-08-2015, 09:35 AM
LINK TO POST COPIED TO CLIPBOARD