02-22-2016 10:44 AM
26 12
tools
  1. chram893's Avatar
    Since I have had my 6P for the past week, Gmail fails to notify me of any new, incoming emails. The only way I'm able to see if I've got new emails is to manually open the app and see the individual label notifications. I've made sure I've got notifications turned on within the Gmail app, switched it on and off, forced close the Gmail app several times to restart it, turn on and off syncing from the 'Accounts' settings page. I don't know what else to do at this point. Has any experienced any notification issues with the Gmail app since they've switched to the 6P? Any help is greatly appreciated! Thanks!
    threshfire and will1881 like this.
    11-08-2015 11:23 PM
  2. pr627's Avatar
    Open Inbox > click Menu in top left corner > scroll down and click on Settings > click on your email name (xxx@gmail.com) > then make sure Notifications box has check mark and Inbox sound & vibrate is on or off depending what all you want

    also go into Settings > Apps > Gmail > Notifications and then make sure Block all is turned OFF
    threshfire and Salad Bar like this.
    11-09-2015 07:02 AM
  3. chram893's Avatar
    Open Inbox > click Menu in top left corner > scroll down and click on Settings > click on your email name (xxx@gmail.com) > then make sure Notifications box has check mark and Inbox sound & vibrate is on or off depending what all you want

    also go into Settings > Apps > Gmail > Notifications and then make sure Block all is turned OFF
    I appreciate your response and help! As I've mentioned before, I've made sure the notifications settings are turned on within the Gmail app. I did follow your instructions, just to ensure my settings were adjusted correctly. I am coming from a Nexus 5, so I made sure the settings were set the same way on my 6P. Also, I have been sending myself test emails to try to activate gmail notifications. So far, the notifications from my test emails have been very VERY inconsistent with only 1 notification, first test email, coming through and none after that.
    threshfire likes this.
    11-09-2015 12:30 PM
  4. tommymonk's Avatar
    I was in exactly the same situation and could find no one else with an answer.

    After several rounds of reinstalling the app, turning the notification settings off then on and rebooting, it just started working.

    One tip I would give when problem solving this would be to wait for a minute after sending yourself emails to ensure it is definitely not getting a notification.
    threshfire likes this.
    11-09-2015 12:41 PM
  5. chram893's Avatar
    I was in exactly the same situation and could find no one else with an answer.

    After several rounds of reinstalling the app, turning the notification settings off then on and rebooting, it just started working.

    One tip I would give when problem solving this would be to wait for a minute after sending yourself emails to ensure it is definitely not getting a notification.
    How were you able to uninstall the app's updates? I've tried uninstalling them, but the app's info buttons, 'Deactivate' and 'Force Close', are grayed out so I can't select them.
    threshfire likes this.
    11-09-2015 12:56 PM
  6. tommymonk's Avatar
    How were you able to uninstall the app's updates? I've tried uninstalling them, but the app's info buttons, 'Deactivate' and 'Force Close', are grayed out so I can't select them.
    I was able to uninstall back to the base version using the standard "uninstall updates" button
    threshfire likes this.
    11-09-2015 01:50 PM
  7. chram893's Avatar
    I was able to uninstall back to the base version using the standard "uninstall updates" button
    I know what you're referring too. Oddly, in both the App settings and in the Play Store, "Uninstall Updates" is replaced by "Deactivate". I'm not sure what's going on there.
    threshfire likes this.
    11-09-2015 02:50 PM
  8. threshfire's Avatar
    I've noticed this issue too. I made a post on Reddit and found another post on XDA. Sorry! Can't post direct links yet.

    Reddit: /r/Nexus6P/comments/3seyj6/delayed_gmail_syncnotifications/

    XDA: /nexus-6p/help/delayed-push-notifications-t3246147

    In no particular order, I've:
    • Removed my Google account and readded
    • Removed my Gmail account and readded
    • Gone through Gmail settings to make sure that notifications are on, sync is active, managed labels
    • Gone through the Google account to make sure that Gmail sync is on
    • Restarted
    • Uninstalled updates to Gmail from the Play Store
    • Reinstalled updates to Gmail from the Play Store
    • Force Stopped Gmail
    • Cleared data from Gmail
    • Cleared cache from Gmail
    • Removed it from optimized apps
    • Changed my password on computer, then waited for phone to ask to reinput, reinputted


    It's looking to be a Gmail issue. Perhaps something to do with 6.0 support?
    Salad Bar likes this.
    11-12-2015 05:32 PM
  9. threshfire's Avatar
    Was looking around and saw someone posted on the official Nexus forums; if anyone here is still having the issue, please head over and +1/reply so Google can escalate the fix.

    /productforums.google.com/forum/#!topic/nexus/Ayd_1TOemSE
    11-24-2015 04:02 PM
  10. will1881's Avatar
    Was looking around and saw someone posted on the official Nexus forums; if anyone here is still having the issue, please head over and +1/reply so Google can escalate the fix.

    /productforums.google.com/forum/#!topic/nexus/Ayd_1TOemSE
    Have this issue too on the 6P
    12-30-2015 05:15 AM
  11. pr627's Avatar
    Ohh I just saw this post, having same issue and I started new thread
    12-30-2015 04:46 PM
  12. Saturn1217's Avatar
    This is a widespread issue I think (I found a thread on Google product forums with a lot of replies). I turned off gmail battery optimization in settings and gmail notifications seem to be coming in normally for me now.

    Posted via the Android Central App
    12-30-2015 05:47 PM
  13. syspry's Avatar
    No issues here, getting all of mine. Too bad they're bills lol
    12-30-2015 05:50 PM
  14. Carraser23's Avatar
    Switch to inbox its so much better

    Posted via the Android Central App
    12-30-2015 09:55 PM
  15. vhl71's Avatar
    Just bought a new nexus 6P and set it up. I'm using gmail app for all my email accounts and I get notification for all emails other than the gmail. Unless I open the gmail app and do a refresh it doesn't get gmails updated. Is this a bug with the gmail app? I get the same gmail instantly on my BlackBerry.
    12-31-2015 03:34 AM
  16. Andrew Wagner's Avatar
    I'm having the same issue.
    12-31-2015 10:01 AM
  17. kmcochran's Avatar
    I turned off gmail battery optimization in settings and gmail notifications seem to be coming in normally for me now.

    Posted via the Android Central App
    Where are these settings? I can't seem to find them.
    12-31-2015 11:59 AM
  18. ChinChillaz's Avatar
    I'm experiencing the same issues with Gmail push. I am now using the outlook app to get my gmail and it works perfectly. Hopefully Google will come out with a fix for this soon.
    12-31-2015 01:28 PM
  19. Salad Bar's Avatar
    I had the same issue and had to do two of the steps listed in these threads. 1. Remove the Gmail account and re-add it. 2. Ensure the Application Notifications setting is not set to BLOCK.

    Good luck
    01-03-2016 10:08 AM
  20. svenEDGE's Avatar
    This is a widespread issue that Google is aware of. Should be fixed soon.
    01-03-2016 10:22 AM
  21. redduc900's Avatar
    I performed a factory reset, and now notifications are working as they should.
    01-03-2016 11:14 AM
  22. drathos's Avatar
    Where are these settings? I can't seem to find them.
    Settings -> Battery -> Battery Optimization (menu in upper right) -> All Apps -> Gmail -> Don't optimize

    This seems to have partially fixed it for me. Still some delays, but only a few minutes unlike before..
    kmcochran likes this.
    01-14-2016 12:16 PM
  23. anon(847090)'s Avatar
    This issue started showing up for me after the Jan Security update.

    not sure how security update would affect gmail delivery. This is the only issue i have at the moment
    01-14-2016 12:38 PM
  24. kmcochran's Avatar
    Settings -> Battery -> Battery Optimization (menu in upper right) -> All Apps -> Gmail -> Don't optimize

    This seems to have partially fixed it for me. Still some delays, but only a few minutes unlike before..
    Thank you! Now I'm getting my emails!
    01-17-2016 02:02 PM
  25. dmxjago's Avatar
    I don't want to disabled the battery optimization. I just installed the Outlook app which now supports Google accounts with push notifications and i'm receiving all my notifications without any delays so far.

    Scrolling up a bit I just realized that the user "ChinChillaz " is doing the same thing with the Outlook app as I am. I recommend you try it at least until Google fixes the issue so you don't need to mess around with your Dose and battery settings. I want the best possible battery life on my device.
    01-19-2016 12:59 AM
26 12

Similar Threads

  1. Nexus 6P 32GB with Nexus Protect (extras) and Huawei Watch
    By SteveISU in forum Marketplace Archive
    Replies: 11
    Last Post: 02-28-2016, 09:26 AM
  2. Replies: 2
    Last Post: 02-26-2016, 10:12 PM
  3. Replies: 0
    Last Post: 02-26-2016, 10:23 AM
  4. Replies: 1
    Last Post: 02-26-2016, 09:23 AM
  5. Buy the Nexus 6P or the Nexus 6?
    By docle888 in forum Ask a Question
    Replies: 0
    Last Post: 02-25-2016, 08:34 PM
LINK TO POST COPIED TO CLIPBOARD