1. tom_reigate's Avatar
    Hi

    I bought a Nexus 6P from the Google store but it will not connect to my carrier's service.

    I am with The People's Operator in the UK. They sent me a nano SIM to replace my old micro then transferred the service over to the nano.

    I lost the service on the my old phone (micro) but can not connect to the carrier with the 6P and nano.

    The Carrier have looked at their settings and they say they can not understand why the 6P and nano don't connect. They have no experience of 6Ps and wonder if the phone comes locked?

    Can anyone answer this question?
    11-09-2015 02:36 AM
  2. anon(677651)'s Avatar
    Same thing happened to me. Took it to t mobile store they simply restarted the device and it worked right away.
    tom_reigate likes this.
    11-09-2015 02:51 AM
  3. tom_reigate's Avatar
    Tried a reboot and it came back No SIM card - emergency calls only.

    I will ask them to send me a new nano SIM.
    11-09-2015 03:14 AM
  4. tom_reigate's Avatar
    The moment I emailed TPO for a new nano SIM card the service sprung into life. Thanks jackoceanz for the tip.
    11-09-2015 03:25 AM

Similar Threads

  1. Replies: 3
    Last Post: 11-09-2015, 02:12 AM
  2. Marshmallow update messed up my alarm clock. Has this happened to anyone else?
    By AC Question in forum Legacy Android & Other OS's
    Replies: 0
    Last Post: 11-09-2015, 01:53 AM
  3. Replies: 1
    Last Post: 11-09-2015, 01:42 AM
  4. Replies: 1
    Last Post: 11-09-2015, 01:38 AM
  5. Replies: 1
    Last Post: 11-09-2015, 01:34 AM
LINK TO POST COPIED TO CLIPBOARD