1. Geekophelia's Avatar
    I can't send MMS on Nexus 6p (project fi) & found posts about the issue on all carriers. Several mention changing/deleting APNs, but when I go to Cellular network settings, the only option listed is "data roaming". Using Hangouts as default txt app solves the MMS issue, but I HATE Hangouts. So far I tried Textra, GO SMS Pro, Green Banana Messaging, and a couple of others... none fixed the issue, including manually setting port on GoSMS. (Repeat-SMS is working fine) I already tried Safe Mode, pulling and reinserting SIM, factory reset, none of which cured my MMS woes....
    For some people it seems to be a software conflict, but I'm not running SMS Backup, Handcent, or anything they mentioned, plus safe mode didn't work).
    Does anyone have anything OTHER than Hangouts which is working for them to send MMS on the Nexus 6p?
    I can't post a link, but there's an article on THIS site about it.... trouble-sending-mms-through-google-messenger-lollipop-here-are-couple-solutions
    Also, an hour with Project Fi tech support was unproductive, except confirming I can't send MMS on Messenger- tech guy bumped it up the line, I'm waiting on their email (not holding my breath for help from them)

    TL;DR- MMS not working- what app do you use?

    Thanks in advance!


    FIXED------ you have to be signed in to Hangouts for MMS to work (or to use WIFI calling, on my phone, anyway). I hate Hangouts, but I created a junk account and signed in. :P
    11-18-2015 06:59 PM
  2. hyminameisderek's Avatar
    Had the same issue and something that makes no sense to me was the fix. I stumbled across it on a Google forum.

    Check the following:

    Settings
    Apps
    Select the cog at the top right in Apps and then select Default Apps
    Browser setting is the problem. Mine was set to nothing. Change it to Chrome.

    MMS started sending pretty much immediately after I did this.
    Geekophelia likes this.
    11-18-2015 07:24 PM
  3. Geekophelia's Avatar
    Thanks for the reply- Chrome was already set as default browser, but I finally figured it out- 2 days later- while I was trying to fix an entirely different issue!
    11-18-2015 07:58 PM
  4. mogelijk's Avatar
    I had an issue where I couldn't send SMS after taking my GV number to Project Fi. They seem to have fixed it sometime Monday, it was finally working for me on Tuesday -- I didn't have to do anything.

    As for texts, I'm using Messenger and not Hangouts.To change to Messenger (or another app), you need to go into Hangouts, then settings, then select your email address under the settings. Once in, you should find a section for Project Fi settings, underneath will be a check box for "Messages" -- removing the check and Hangouts will no longer be the default.
    11-19-2015 12:47 AM
  5. Mike Larry1's Avatar
    what is the fix?
    02-29-2016 08:30 AM
  6. Mike Larry1's Avatar
    How did you fixed this?
    02-29-2016 08:31 AM

Similar Threads

  1. Replies: 2
    Last Post: 04-16-2016, 09:30 PM
  2. Replies: 0
    Last Post: 11-18-2015, 06:25 PM
  3. Why isn't my 626 htc truing on?
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 11-18-2015, 06:18 PM
  4. Play store Check Your Connection and try again, what do I do?
    By Super MoDeY in forum General Help and How To
    Replies: 0
    Last Post: 11-18-2015, 06:07 PM
  5. Why isn't my email syncing on my Galaxy Tab 3?
    By AC Question in forum Samsung Galaxy Tab 3
    Replies: 1
    Last Post: 11-18-2015, 05:57 PM
LINK TO POST COPIED TO CLIPBOARD