1. crosspatch's Avatar
    My 6P has started doing something really annoying. If I leave home, I continue to have a strong cellular signal, but I have zero mobile data unless I enable and then disable airplane mode.

    When this happens, in the built-in notification drop-down, I'll see a strong mobile signal indicator, but no "LTE," and I truly have no mobile data connection at this point. As soon as I toggle airplane mode, the "LTE" shows up and magically, I have mobile data again.

    I always have cellular data enabled, so it's not that I'm turning it off when I'm using Wi-Fi. I don't even have "Restrict background data" enabled, though I do have that setting enabled for many individual apps (which should have nothing to do with this problem).

    I'm not rooted, so I don't think any apps could be messing with any relevant settings, and I don't think I have any that would anyway.

    Any ideas?
    02-14-2016 01:45 PM
  2. PaulQ's Avatar
    The thing that caught my attention is that you say you have "Restrict Background Data" enabled for individual apps. I've noticed that Marshmallow handles keeping apps in memory differently that OS's in the past. Maybe one of those apps is hanging around in the background and restricting background data like you have told it to do. Have you tried disabling that restriction on all of the apps you have set it on?

    If that's not it, if it were me, I'd go to my carrier's store and swap for a new SIM card. But - maybe others have additional suggestions.
    02-14-2016 02:17 PM
  3. crosspatch's Avatar
    There is a system-wide setting to restrict background data, and per-app settings for the same. My understanding is that per-app restrictions on background data should have no effect outside the app in question, and should also not have an effect on the given app if it is in the foreground (i.e. in use). As I mentioned, I do not use the system-wide setting at all (i.e. it is disabled).

    Also, it's not just background data that is not working. Even apps in the foreground cannot connect. Therefore, unless I am truly misunderstanding something, this issue can't have anything to do with any background data settings (either per-app or system-wide) at all.

    Also, I have rebooted the phone.

    If I can't get this sorted out, I'll open a case with Google, and see what they advise. Hopefully it's not the typical "Wipe the entire phone with a new system image" reply.
    02-14-2016 02:22 PM
  4. hallux's Avatar
    This happens to me from time to time, also happens when going back to WiFi. There is talk that this is a bug that was introduced with the 6.0.1 update.
    02-14-2016 02:50 PM
  5. Kaenon11's Avatar
    Anyone ever get a fix for this?
    This is always happening on my non-rooted HTC 10...

    Very frustrating.
    07-08-2016 03:23 PM
  6. SupermanJon707's Avatar
    My 6P has started doing something really annoying. If I leave home, I continue to have a strong cellular signal, but I have zero mobile data unless I enable and then disable airplane mode.

    When this happens, in the built-in notification drop-down, I'll see a strong mobile signal indicator, but no "LTE," and I truly have no mobile data connection at this point. As soon as I toggle airplane mode, the "LTE" shows up and magically, I have mobile data again.

    I always have cellular data enabled, so it's not that I'm turning it off when I'm using Wi-Fi. I don't even have "Restrict background data" enabled, though I do have that setting enabled for many individual apps (which should have nothing to do with this problem).

    I'm not rooted, so I don't think any apps could be messing with any relevant settings, and I don't think I have any that would anyway.

    Any ideas?
    This is a guide on how to switch your Network settings and make sure it is on "GSM/LTE/HSPA+/CMDA auto"

    http://forum.xda-developers.com/show....php?t=2713752


    Also I would try to go and see if replacing the SIM card with a new one fixes this issue

    Posted via the Android Central App
    07-10-2016 09:30 AM

Similar Threads

  1. Replies: 2
    Last Post: 02-15-2016, 10:55 AM
  2. Has anyone found a way to move game data without voiding the warranty?
    By enfuego360 in forum Samsung Galaxy Note 4
    Replies: 2
    Last Post: 02-15-2016, 09:20 AM
  3. Why don't I have an email connection?
    By Trylon39 in forum LG G4
    Replies: 1
    Last Post: 02-14-2016, 01:48 PM
  4. My mobile data is not working.Can anybody help?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 02-14-2016, 12:27 PM
  5. Samsung Galaxy Trend Lite Auto Airplane Mode Problem
    By Ioana Espinosa in forum Ask a Question
    Replies: 0
    Last Post: 02-14-2016, 12:07 PM
LINK TO POST COPIED TO CLIPBOARD