1. MrDoh's Avatar
    This is a really weird one. I'm using the latest Android M on the Nexus 6P with Project Fi. Both Hangouts and Messenger are set to use Messenger as the default text message app. Well, Hangouts grabs the text messages, even though it says in the settings for both apps that Messenger is the default text message handler. So I disabled the Hangouts app, and Messenger will still not get text messages, I just don't get text messages if Hangouts is disabled. This is really very odd. Doesn't seem to relate to system cache (wiped it) or app cache (wiped it).

    Of course, I want to use Messenger for text messages...

    Any ideas how I can get Messenger to handle text messages instead of Hangouts? I could use Messenger, but I really don't like its look-and-feel.

    Thanks!
    05-19-2016 03:06 AM
  2. puch96's Avatar
    You need to re configure to have messenger app handle your text messages. Did you do this before disabling hangouts?

    Posted via the Android Central App
    05-19-2016 10:41 AM
  3. puch96's Avatar
    Go to apps, then tap the gear on top right for settings, then select default SMS app and make sure messenger is selected.

    Posted via the Android Central App
    05-19-2016 10:46 AM
  4. MrDoh's Avatar
    Thanks, appreciate the input. Yes, I have Messenger set to be the default text message handler in both Messenger and Hangouts. In the settings for each app, where you do that. These settings are ignored. That's the problem, not that I don't know how to set this up.

    This has worked fine previously, I've been able to switch between Hangouts and Messenger for testing with no problems. I can no longer do that, both Messenger and Hangouts are ignoring my settings.

    Thanks. Hoping that someone might have something that will help me.
    05-19-2016 11:09 AM
  5. MrDoh's Avatar
    Never mind, found this somewhere else. There's a third place where us Project Fi folks need to switch the text message handler, down inside Hangouts settings in the settings for the associated email account. This one is way too intricate. I'd be happy with a single setting where I could switch the default text message handler, three separate places to switch it doesn't make me happy at all.

    I am happy to have this set up as I want it, though :-).
    android_user1 likes this.
    05-19-2016 11:27 AM
  6. Trigati's Avatar
    Never mind, found this somewhere else. There's a third place where us Project Fi folks need to switch the text message handler, down inside Hangouts settings in the settings for the associated email account. This one is way too intricate. I'd be happy with a single setting where I could switch the default text message handler, three separate places to switch it doesn't make me happy at all.

    I am happy to have this set up as I want it, though :-).
    Glad you found it. It was a pain for me at first as I wanted to drop Hangouts myself. However, I found that via Fi, I could use Hangouts on my Windows computer to send text messages. As much as I'm not a real hangouts fan, that feature is something I actually like, so I let Fi manage Hangouts (for the moment). I still might end up dropping it.
    05-21-2016 01:39 AM

Similar Threads

  1. Will Allo replace your current messaging app?
    By the tall guy in forum Google Allo
    Replies: 87
    Last Post: 10-06-2016, 11:46 AM
  2. I can only get 3g when i should have LTE
    By Alaynna R in forum Samsung Galaxy S5
    Replies: 7
    Last Post: 05-20-2016, 12:39 AM
  3. Replies: 7
    Last Post: 05-19-2016, 11:00 PM
  4. Why are messages not being sent.
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 05-19-2016, 04:49 AM
  5. Replies: 1
    Last Post: 05-19-2016, 01:23 AM
LINK TO POST COPIED TO CLIPBOARD