1. PaulQ's Avatar
    I know people complain about lag now and then. I never really thought much of it because I only had the occasional lag problem.

    Now, my 6P is lagging BIG TIME. It's even got to the point where occasionally, the three buttons on the bottom of the phone don't respond. I wait a bit and then they work, sometimes executing all my presses quickly in sequence. More often, things just take a few seconds to open or respond.

    I factory reset the phone about 2 weeks ago but the lagging has already started back up.

    If I reboot the phone, it's usually smooth for a few days then it all starts again.

    I'm playing around with my apps to see if it's one of them. I am up to date with the June patch.

    Anyone have any ideas/experience/suggestions that have worked for them? I've actually thought of getting rid of the phone but I really REALLY don't want to. I love the whole Nexus concept.

    Thanks!!
    06-21-2016 03:12 AM
  2. mhinc's Avatar
    I know people complain about lag now and then. I never really thought much of it because I only had the occasional lag problem.

    Now, my 6P is lagging BIG TIME. It's even got to the point where occasionally, the three buttons on the bottom of the phone don't respond. I wait a bit and then they work, sometimes executing all my presses quickly in sequence. More often, things just take a few seconds to open or respond.

    I factory reset the phone about 2 weeks ago but the lagging has already started back up.

    If I reboot the phone, it's usually smooth for a few days then it all starts again.

    I'm playing around with my apps to see if it's one of them. I am up to date with the June patch.

    Anyone have any ideas/experience/suggestions that have worked for them? I've actually thought of getting rid of the phone but I really REALLY don't want to. I love the whole Nexus concept.

    Thanks!!
    When you factory reset to you use a backup to put your apps and such right back on? Or did you leave it clean to test?
    Typically it is an app that causes this, I would take the phone into safe mode and see how it runs. If it's okay is safe mode
    it's most likely an app and then it's just a matter of uninstalling one by one to narrow it down
    06-21-2016 04:36 AM
  3. maxburn's Avatar
    I was plagued with this on the G4 and never fixed it or found the cause. I'd suggest you swap the handset.

    Only further thing I might suggest would be to load a factory image.
    06-21-2016 06:41 AM
  4. dc52ltr's Avatar
    When you factory reset to you use a backup to put your apps and such right back on? Or did you leave it clean to test?
    Typically it is an app that causes this, I would take the phone into safe mode and see how it runs. If it's okay is safe mode
    it's most likely an app and then it's just a matter of uninstalling one by one to narrow it down
    Agreed,its usually a crap app doing this...deffo try safe mode or reinstall your apps one by one until (hopefully ) you find the cause.
    jojoe42 and libra89 like this.
    06-21-2016 08:01 AM
  5. rhea's Avatar
    Then, if you don't find the cause (rogue app/s, factory reset), get a replacement as suggested. Most likely software but could be hardware, too.
    06-21-2016 10:40 AM
  6. PaulQ's Avatar
    When you factory reset to you use a backup to put your apps and such right back on? Or did you leave it clean to test?
    Typically it is an app that causes this, I would take the phone into safe mode and see how it runs. If it's okay is safe mode
    it's most likely an app and then it's just a matter of uninstalling one by one to narrow it down
    Yep, I just let it reinstall the apps. I think you guys are probably right. Since none of you are saying you are experiencing this, I lean toward the app solution. I'll work on it. Thanks for the responses!
    06-21-2016 01:17 PM
  7. dty06's Avatar
    Yep, I just let it reinstall the apps. I think you guys are probably right. Since none of you are saying you are experiencing this, I lean toward the app solution. I'll work on it. Thanks for the responses!
    It could be a hardware issue as well, but software is much more likely. As others have said, it's almost definitely a bad app which is eating resources and eventually hogs them all.
    06-21-2016 02:05 PM
  8. mcostajr's Avatar
    I'm having a similar problem with lag. I currently have my 6P booted in safe mode and when I try to scroll through my music library in Play Music it stutters along and the album artwork takes forever to load. I have similar problem when scrolling to through apps in the Play Store. And the keyboard is always several letters behind. Not sure this is a lag issue, but the screen and navigation buttons at the bottom of the screen are not very responsive. I have to press a bit more firmly than I've had to with previous phones (LG V10 and Samsung Note 5, most recently).

    This is my second 6P in 2 weeks. I've had quality issues with the build. I'm really starting to enjoy the pure Android experience and I love the build of the 6P, but I'm starting to wonder if I should cut my losses and go back to my Note 5 for now and wait to see what the Note 7 is like and what Google has coming later in the year.
    06-21-2016 04:04 PM
  9. bjrosen's Avatar
    Do a factory reset and then don't restore your apps, leave it with just the default apps. If that works fine then start adding your apps back one at a time. I've had the 6P from the beginning and I don't have a problem.
    06-21-2016 05:00 PM
  10. PaulQ's Avatar
    When you factory reset to you use a backup to put your apps and such right back on? Or did you leave it clean to test?
    Typically it is an app that causes this, I would take the phone into safe mode and see how it runs. If it's okay is safe mode
    it's most likely an app and then it's just a matter of uninstalling one by one to narrow it down
    Do any of you guys know of an app that reports the background usage of other apps? I could start with this. Factory reset and adding apps back is going to be a long process.
    06-21-2016 05:18 PM
  11. bjrosen's Avatar
    Try OS Monitor
    06-21-2016 05:45 PM
  12. GSDer's Avatar
    Do any of you guys know of an app that reports the background usage of other apps?
    If you don't have root you could try Wakelock Detector [Light] https://forums.androidcentral.com/e?...token=7TtMarox
    It requires a connection to a PC, ADB, and a specific Chrome extension in order to initialize, and gets reset if you restart the phone, but tracking wakelocks is the best way to go.

    I haven't used it myself, but will give it a shot once I have the necessary setup. I used to use the full version on my Galaxy S3, which was rooted, and this developer seems to know what he's doing.
    06-22-2016 12:40 AM
  13. Dan TheMan86's Avatar
    If you don't have root you could try Wakelock Detector [Light] https://forums.androidcentral.com/e?...token=_9sVsiBk
    It requires a connection to a PC, ADB, and a specific Chrome extension in order to initialize, and gets reset if you restart the phone, but tracking wakelocks is the best way to go.

    I haven't used it myself, but will give it a shot once I have the necessary setup. I used to use the full version on my Galaxy S3, which was rooted, and this developer seems to know what he's doing.
    loooootta dislikes on that app in the store....
    06-22-2016 08:08 AM
  14. Trigati's Avatar
    Definitely something weird going on. As others have said, don't restore from the back up. It'll definitely be more of a pain, but it will let you see exactly what starts causing your phone to slow down as you reinstall apps. And if its laggy without any apps, then that would point to a hardware issue. Also, don't forget to wipe your cache partition after you reformat (it never hurts to give it a wipe when doing deep troubleshooting).
    06-22-2016 08:57 AM
  15. kramer5150's Avatar
    Heres what I would do...
    Factory reset it back its baseline
    Clear cache
    Do not restore it from a laggy backup point, and do not re-install any power/ system management apps not originally included in the OS.
    Delete all pics, movies, and music files from internal memory

    Re-install each app one at a time, paying close attention to how the system behaves before and after each installation. It would also be a good time to evaluate what apps you don't need or use regularly enough to keep. Scrub through the permissions, and deactivate any app permissions that are not needed for it to function. The battery usage feature is usually a good indicator for apps that are not doing what they are supposed to be doing.

    Good Luck!!
    06-22-2016 12:04 PM
  16. GSDer's Avatar
    loooootta dislikes on that app in the store....
    Lots of dislikes, probably because:
    1. People are clueless and don't know how to follow directions
    2. People are too lazy to do the work required
    06-22-2016 06:23 PM
  17. galaxyfive's Avatar

    Anyone have any ideas/experience/suggestions that have worked for them? I've actually thought of getting rid of the phone but I really REALLY don't want to. I love the whole Nexus concept.

    Thanks!!
    Have you considered that some apps running in the background maybe having problems connecting to their mothership and the continuous polling back and forth maybe taxing device resources and causing this issue? Even some of the largest tech co. server farms are not 100% up time.
    06-22-2016 06:48 PM
  18. PaulQ's Avatar
    I really appreciate all of your feedback and suggestions.

    I wanted to try an approach that doesn't involve the factory reset and slow loading one app at a time first. Afterall, I had just done a factory reset less than 2 weeks ago but I did let it reload all the same apps. So...

    • First, I uninstalled the classic problem app: Facebook. I had read about all the complaints in the past but never really experienced them so I left it on. This time, I uninstalled Facebook and Messenger. I now use Swype Pro instead.
      .
    • Next - I took the suggestion to install "OS Monitor" and watched it to see what apps kept popping up using processor time. "App Lock: Fingerprint Password" kept popping up. It was only using a small percentage but I uninstalled it. I love what it does but it's not worth any slowdown to use it.
      .
    • I then set my sites on Norton Mobile Security which was showing up just a bit in OS Monitor. I like its antitheft features but had left some its other features on. I went in and turned off everything except the antitheft features. It dropped off of OS Monitor.
      .
    • I went through my other apps and uninstalled a few others that I don't use much. The only one that might have had an impact was "Smart News" because it preps and notifies on a "news digest" everyday. Never read it anyway.
      .


    I did all this last night. So far, no lag. If the lag comes back in the next day or two, I'll probably have to do the reset and start clean.
    06-23-2016 01:45 AM
  19. RTD212's Avatar
    I know people complain about lag now and then. I never really thought much of it because I only had the occasional lag problem.

    Now, my 6P is lagging BIG TIME. It's even got to the point where occasionally, the three buttons on the bottom of the phone don't respond. I wait a bit and then they work, sometimes executing all my presses quickly in sequence. More often, things just take a few seconds to open or respond.

    I factory reset the phone about 2 weeks ago but the lagging has already started back up.

    If I reboot the phone, it's usually smooth for a few days then it all starts again.

    I'm playing around with my apps to see if it's one of them. I am up to date with the June patch.

    Anyone have any ideas/experience/suggestions that have worked for them? I've actually thought of getting rid of the phone but I really REALLY don't want to. I love the whole Nexus concept.

    Thanks!!
    Same thing with me... It just started about a month ago. Very annoying as this was NEVER an issue with this phone. Now it's a regular thing.

    Posted via the Android Central App
    06-23-2016 05:59 AM
  20. doggy2965's Avatar
    Norton app was a big lag problem for me Uninstalled. No further lag

    Posted via the Android Central App
    06-23-2016 07:17 AM
  21. odd1ne's Avatar
    It might help but if you open up the developer options on your phone there is a tab called running services and that can sometimes be used to see what is running and what shouldn't be running

    Posted via my 6p & the Android Central App
    06-23-2016 08:11 AM
  22. mhinc's Avatar
    Norton app was a big lag problem for me Uninstalled. No further lag

    Posted via the Android Central App
    Have to agree, Norton is a hog, as is most virus programs.
    Honestly, the need for virus protection on your phone is not necessary, I don't care what anyone says. If you are smart, and don't go installing random unsafe APKs you will be fine
    tonyr6 likes this.
    06-23-2016 11:11 PM
  23. LeoRex's Avatar
    loooootta dislikes on that app in the store....
    You see that on some system tools... mostly because people either don't know how to use it or they don't know how to interpret the information. But looking at the reviews, nearly 23K 5 and 4 star reviews vs 3500 1s and 2s.... An overall score of 4.2 with 28K reviews is pretty good.
    06-24-2016 10:15 AM
  24. GSDer's Avatar
    loooootta dislikes on that app in the store....
    As a follow-up, I followed the (rather simple) instructions on how to enable Wakelock Detector Free on my phone and it works as expected.

    This app is one of the best ways to find out what is keeping your device awake when it should be sleeping - it'll allow you to see which apps are waking the CPU or screen, and how often that's happening.
    07-04-2016 12:32 PM

Similar Threads

  1. How do you clear data from IMS SERVICE HELP!?
    By Jesus Delgadillo in forum Samsung Galaxy Note 5
    Replies: 3
    Last Post: 06-22-2016, 07:21 AM
  2. SMemo to OP3?
    By Podaran in forum OnePlus 3 & 3T
    Replies: 1
    Last Post: 06-21-2016, 09:08 AM
  3. Replies: 1
    Last Post: 06-21-2016, 03:18 AM
  4. How is gaming on the OnePlus X?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 06-21-2016, 03:17 AM
  5. Replies: 0
    Last Post: 06-21-2016, 02:23 AM
LINK TO POST COPIED TO CLIPBOARD