12-05-2016 02:43 PM
44 12
tools
  1. uchinan's Avatar
    Been having some issues with Bluetooth since the Nougat update.

    Symptoms-
    1. First connection to my cars stock headunit I lost skip functionality along with the screen metadata information. This included skip controls from my steering wheel.
    2. I deleted both profiles from the headunit and phone and re-paired the devices. I got controls back and metadata, except for elapsed media time.
    3. Next day it was back to no controls or metadata. Deleting and re-paring worked again.

    I never paid much attention to it before, but it looks like it takes a good minute for my phones BT to 'disable' after I turn my car off. And unfortunately I do not have any other cars or devices that I can test the phones BT out on.

    If anyone has any ideas on how to fix this, I am all ears. And thanks in advance.
    08-29-2016 11:54 PM
  2. anon(319128)'s Avatar
    Funny....I didn't think about it, but today in the car, I could only start and stop audio with the play button, I got a chapter number for my audio book, but the progress bar didn't move. I'm sure it worked the other day before the 7.0 upgrade. No problem connecting the bluetooth to the car though.
    08-30-2016 09:36 PM
  3. uchinan's Avatar
    Same, it's connected pretty much every time. Just have no controls other than play and pause. And no media Metadata.
    08-31-2016 05:26 AM
  4. tazz602's Avatar
    I'm having the exact same issue except with my LG headset or any other bluetooth. BT just disables after a minute or two - but then later in the day seems to work and stay on for some reason. Two days in a row.

    I went to the google forum yesterday - they had me boot into safe mode and it stayed on, I booted back normally and it disabled after a minute. They are saying it's a downloaded app causing the issue, but I swear the issue started after getting the google connectivity service update three days ago.

    I need help if anyone figures this out .
    08-31-2016 01:14 PM
  5. GSDer's Avatar
    they had me boot into safe mode and it stayed on, I booted back normally and it disabled after a minute. They are saying it's a downloaded app causing the issue
    I'd have to agree with their assessment based on the information you've provided. Simplest thing to do is a Factory Reset, update all of the Google Apps, disable any other built-in apps (and don't install any others) and then use Bluetooth until you've either proved that it works to your satisfaction or that it doesn't.

    If the former, begin reinstalling your usual apps one at a time and using Bluetooth until the problem crops up again - voila, you've identified the culprit.

    If the latter, get back on the Google forum and tell them what you did to isolate the problem and ask for next steps.
    08-31-2016 02:02 PM
  6. tazz602's Avatar
    Do you have any idea how incredibly time consuming that would be, I work and I use my phone daily, there are now 66 apps that have permission to Bluetooth. Isn't there a log or something I can access to get some information on why BT won't stay enabled and disables itself??
    08-31-2016 02:23 PM
  7. GSDer's Avatar
    Do you have any idea how incredibly time consuming that would be....Isn't there a log or something I can access to get some information on why BT won't stay enabled and disables itself??
    I don't remember saying anything about how easy/hard it would be - I said it would help you to narrow down the problem.

    As for logging, you can go to Settings ->Developer options (obviously that has to be enabled if you don't see it) and turn on 'Enable Bluetooth HCI snoop log'I haven't personally used that feature, so I can't even tell you where to find said log file, what it contains or how difficult it will be to interpret, but perhaps someone on the Google forums or over on XDA can supply that information.

    Edit: you'll find 'btsnoop_hci.log' in the top level directory when you open Explore (or whatever file manager you prefer). I don't happen to have an app that will open log files but I'm sure you can find one.

    Another Edit: after more digging it's unlikely that you'll get any benefit out of this. I couldn't find an Android app that would make any sense out of the log, and the only program (Wireshark - available on Windows) that I saw identified with it requires some in depth communication skills. Sorry.
    08-31-2016 02:49 PM
  8. osubeavs728's Avatar
    Considering that numerous people had Bluetooth issues before the nougat update, I'm starting to think it's just the phone. I was hoping nougat would fix my issues, but looks like it won't.
    Tu Johnson likes this.
    09-01-2016 09:10 AM
  9. NotFromHere's Avatar
    Considering that numerous people had Bluetooth issues before the nougat update, I'm starting to think it's just the phone. I was hoping nougat would fix my issues, but looks like it won't.
    Just wanted to post one response from a Nexus 6p owner (since December) who has had no BT issues. I use BT all the time with this phone. I had no problems with any BT functionality while on Marshmallow, and nothing has changed with Nougat. There must be some phones out there that have hardware issues. I would be in touch directly with Google about it, cuz that would drive me crazy to not have full BT functionality.
    09-01-2016 09:38 AM
  10. MDMcAtee's Avatar
    Just wanted to post one response from a Nexus 6p owner (since December) who has had no BT issues. I use BT all the time with this phone. I had no problems with any BT functionality while on Marshmallow, and nothing has changed with Nougat. There must be some phones out there that have hardware issues. I would be in touch directly with Google about it, cuz that would drive me crazy to not have full BT functionality.
    Same for me.. No issues with MM or Nugat it hooks up fast and stays connected..
    09-01-2016 02:22 PM
  11. dty06's Avatar
    I upgraded from MM to N beta to full release and I've had the same bluetooth devices since the first day I got the phone. I set them up once and that was it. I never had to set them up again and I have full functionality in my car as well as on my headphones.

    For reference, my car is a 2014 corolla LE and my headphones are Sony (not sure which model but they retail for about $90)
    09-01-2016 03:31 PM
  12. angelbones1's Avatar
    Don't know if my issue is related but about a month ago I started having issues with Bluetooth connection in my vehicles. Happened in each one, so I know it wasn't the cars or other bluetooth devices with similar issue. Unlike most of the rest of you on this thread however, I have NOT done the Nougat update. I'm still on 6.0.1 with an August 5th patch update. The only thing that would "fix" it would be if I reset the phone.

    I love my phone and this is really the first issue I've had with it since November of last year. Just odd that even without the N update, like you guys I'm having Bluetooth issues. Think it may be related to any patches or other thoughts?
    09-04-2016 05:09 PM
  13. bjsa1965's Avatar
    Personally, I'm sick of Android Bluetooth issues. I like android but I have not had one device, Nexus or otherwise, that would play well in any of the cars I've owned over the last several years. I own a Nexus 6P and a 2015 Mini Cooper with the JCW package. It has the best audio system available for the Mini Cooper. When using Google Maps with any other audio app, Google Music, Tidal, or Smart Books for audiobooks, you cannot hear voice prompts from Maps. And when it tries, it totally ruins the connection of the other audio app. I have to manually click play again on the Music app and most of the time, it plays but can't be heard. Solution? Open up another audio app, hit play and the connection returns. Until you get another voice prompt from Maps, which again you can't hear, and have to start the process all over to continue listening to music or audiobook. This is insane. And not isolated to this device.

    I can't believe how sloppy the Bluetooth is. Google comes up with some great software tricks but they can't even work out something as basic as Bluetooth. I've had some sort of BT issue with EVERY android device that I've owned. Samsung, LG, Sony, and now Nexus. My girlfriend has a Lumia 950XL that works perfectly on my car unit. Maps, music, everything. The same goes for my company iPhone. It streams perfectly, pausing other audio apps for the navigation prompt and resuming as soon as it's finished.

    If Apple and others can get this right, why can't Google? I'm on Nougat now and there has been ZERO improvement with the BT from Marshmallow, which was on the device when I bought it a few weeks ago. I'm ready to just give up on Android all together. These solutions of factory reset, reinstall each app and test extensively before installing another, blah blah... It's silly to keep beta testing these phones when others, forgive me, "just work" out the box for the basics like Bluetooth, wifi, etc.

    And before the usual, "you're an Apple shill" etc., start berating me, no. I have a Lumia, Nexus and 6S Plus. As a programmer, I'm platform agnostic. I use Linux, Windows, and OSX. This is a real issue. And it's pointless for those of you who's device works perfectly out of the box with no issues, blah blah... Fine. I don't doubt that. But if your device is 100% perfect, you aren't helping by telling me that. You're just unnecessarily defending the device. I already like the device, Or inferring that because you don't have the issue, I don't. Or don't know what I'm doing, which I assure you is not the case. I just want it to work as reliably as my iPhone or Lumia. Is that really a lot to ask from Google?
    Tu Johnson and MichiganAl like this.
    09-06-2016 11:01 AM
  14. terminator y2k's Avatar
    On this same note, I had purchased a UE Megaboom speaker but returned it because while using Pandora, I would change stations but when I would change stations, the sound would stop but it would keep the song playing. So the song was playing but there would be no sound. So after I would change stations and the sound stopped, I would have to pause the station then hit play again and it would work. I tried it with my iPad and it worked okay. But I noticed the iPad handles Pandora a bit different. I was really bummed too bc that speaker sounded really well. So maybe it's a Nexus 6p bug?
    09-06-2016 12:12 PM
  15. GSDer's Avatar
    I've had some sort of BT issue with EVERY android device that I've owned. Samsung, LG, Sony, and now Nexus. My girlfriend has a Lumia 950XL that works perfectly on my car unit. Maps, music, everything. The same goes for my company iPhone....Is that really a lot to ask from Google?
    I've had a similar experience with every Android phone I've had (HTC, Droid, Samsung) and every Bluetooth headset I've tried (multiple Motorola, LG). So I guess the answer is 'yes, it is too much for Google to get right'.
    Fortunately you've identified two other device ecosystems that work well for you - good luck. I have too much invested in Android to switch.
    09-07-2016 07:11 PM
  16. elcustardo's Avatar
    I find the 6P slow to connect to my cars Parrot handsfree (vs my old HTC One M7)
    Also it seems to have a far shorter range with my Sony bluetooth headset. Eg with the HTC I could have the phone in my pocket and be on a call,with the 6P I can suffer break up over bluetooth.
    Today I was seated at a able watching Sky Go. If I turned my head to look behind me I would lose sound over my headphones.
    The HTC would work even if I walked away from it.

    Edit: also when I use the phone in the car and it connected to the Parrot handsfree. It cuts the radio even if I open an app such as Facebook.
    Very annoying.
    09-11-2016 01:54 PM
  17. tazz602's Avatar
    For me - this issues seemed to be the LG Tone and Talk app - I have LG headphones and was using that app to let it read SMS and other notifications to me. The current version doesn't seem stable and it was causing the Bluetooth issue intermittently. I'm stable now, crossing my fingers.
    09-13-2016 08:16 AM
  18. korben78's Avatar
    I've got the same issue with my 6P since the upgrade to N. My 2016 Mazda has problems connecting to the handset sometimes, and when it does i have limited functionality over Bluetooth. The track progress doesn't display correctly. Yet on my Note 7 (returned) and my S7 edge it works fine. My Work phone is an iPhone and that one is fine too. Definitely seems like a 6P issue.
    09-14-2016 02:19 AM
  19. Mattamus Prime's Avatar
    I've got the same issue with my 6P since the upgrade to N. My 2016 Mazda has problems connecting to the handset sometimes, and when it does i have limited functionality over Bluetooth. The track progress doesn't display correctly. Yet on my Note 7 (returned) and my S7 edge it works fine. My Work phone is an iPhone and that one is fine too. Definitely seems like a 6P issue.
    Same here. Also a 2016 Mazda. 6p worked perfectly before the update.

    Now, post Nougat update, it usually works, but the played duration never works anymore. Play/pause and the skip buttons usually work.

    But maybe 25% of the time, the car shows only a play/pause button. The track information, play duration, and skip buttons are all simply gone. If I hit pause while it's like that, then hit play, it will cause the connection to disconnect. Every time.

    It also has a harder time connecting in the first place.

    Only thing that works for me when it's like this is to restart the phone. Then it'll go back to mostly working (minus played duration).
    09-17-2016 02:21 PM
  20. Forest Dane's Avatar
    I've just swapped my car and noticed that BT music works slightly differently on the new one.
    I too had limited functionality. Seems to be related to whether the music app is open or just playing via the widget (if that makes sense). Open the app and all works fine. Just connect and play music and the skip buttons, album art etc don't work.
    Music also takes a while to get started even though I can make a call pretty much instantly.
    New Toyota Auris with touch and go 2.
    09-18-2016 03:25 AM
  21. hallux's Avatar
    I'm having the exact same issue except with my LG headset or any other bluetooth. BT just disables after a minute or two - but then later in the day seems to work and stay on for some reason. Two days in a row.

    I went to the google forum yesterday - they had me boot into safe mode and it stayed on, I booted back normally and it disabled after a minute. They are saying it's a downloaded app causing the issue, but I swear the issue started after getting the google connectivity service update three days ago.

    I need help if anyone figures this out .
    Just wanted to post one response from a Nexus 6p owner (since December) who has had no BT issues. I use BT all the time with this phone. I had no problems with any BT functionality while on Marshmallow, and nothing has changed with Nougat. There must be some phones out there that have hardware issues. I would be in touch directly with Google about it, cuz that would drive me crazy to not have full BT functionality.
    Same for me.. No issues with MM or Nugat it hooks up fast and stays connected..
    I flashed the NRD90U OTA last night using ADB. I had no issues this morning when listening to music through my BT headset (Motorola S-11 Flex HD if it matters) for nearly an hour. Play/pause/skip worked, I didn't lose connection after only a few minutes. On top of that, battery life seems to be unaffected, it's been off charge for ~13 hours and with that hour of music listening I'm only down to 80% (I haven't fiddled with it too much).
    09-18-2016 11:06 AM
  22. PGrey's Avatar
    I'm having the disconnect problem as well, and I have only a small set of apps, having recently moved over from Win Phone (I'm more or less platform agnostic too, although no real iOS stuff).

    Up until I upgraded to 7.0, things were great, my battery didn't drain from leaving Bluetooth on, and my car and other audio connections worked pretty much flawlessly, I don't think it ever disconnected a single time in my first 6 weeks of ownership.
    On 7.0 however, I can't keep my phone running the whole day, unless I turn my BT off completely, when I'm not using it, the drain is maybe 4-5 times normal.

    The worst part though, is that my car disconnects, constantly, when I'm the middle of conversations. The first couple of times, I just thought I had lost cell signal, but then I realized, my caller was still connected (after maybe 3-4 of these, they happen ALL the time), but my BT car display had popped up a quick message saying my 6P had disconnected itself.
    It's dangerous, trying to get it reconnected too, while driving, and I'm pretty sure it's not legal either (we're a hands-free state, which is great by me, but if your hands-free doesn't work, well...).

    I posted in the ProductForums as well, there are quite a few threads, so I added my comments there, and created a thread about my "network settings reset" not actually resetting my settings (okay it resets WiFi, but not Bluetooth or Cell).

    So far, there were a couple of Google posts, and a couple of "expert" posts, but nothing even remotely resembling a suggestion of a fix or similar, other than "factory reset", if "network settings reset" doesn't work.
    It would seem like I shouldn't need to back up everything (and hope that it restores), and factory-reset my 2 month old phone, really, that's the solution, to a s/w issue with Bluetooth?
    MichiganAl likes this.
    09-24-2016 02:32 PM
  23. GSDer's Avatar
    On 7.0 however, I can't keep my phone running the whole day, unless I turn my BT off completely, when I'm not using it, the drain is maybe 4-5 times normal.
    Which 7.0 build are you running - NRD90T or NRD90U?

    If the former, I'd suggest manually loading the latter - it helped with my battery issues; perhaps it'll help with your Bluetooth issues.
    09-24-2016 03:18 PM
  24. PGrey's Avatar
    Which 7.0 build are you running - NRD90T or NRD90U?

    If the former, I'd suggest manually loading the latter - it helped with my battery issues; perhaps it'll help with your Bluetooth issues.
    NRD90U. I pulled the OTA build and used ADB (even though I'm new to Android, I'm NOT at all new to flashing ALL kinds of firmware, I've been a s/w and h/w developer and tech PM most of my time out there...).
    It went fine, and everything looked okay, until I left BT on, and it totally nuked my battery in about 1/2 of a day. Before the update, it was a non-issue.
    Then the issues started where I couldn't get my phone to stay connected to my car (and other) Bluetooth audio devices, which is crazy-frustrating, almost making the phone unusable, by current standards.

    I get that it could be some weird app (maybe, I don't have many installed, yet), but why only in Nougat then, why didn't it show up in MM?

    Truthfully, I'd really like to get back to MM, but ideally without wiping my system, which I don't think is possible, unfortunately. I'd go back, and sit/wait, until some of this falls out.
    I've had Android tablets for a long time, and to-date, updates where nothing but good, but this one, I don't know...

    I really, really hope that someone at Google is on top of this, there are posts in the Google product forums hundreds of "me to's", and those are the people who know how/where to go seek help.
    So far, I've only seen a couple of Google people acknowledge that there's an issue, but that was it, they went silent after that, some time ago.
    Part of me wonders, if the 6P and 5X (and others) are getting the short-end, while they work on finalizing the latest (new Pixel or whatever) devices?
    09-24-2016 04:59 PM
  25. GSDer's Avatar
    It went fine, and everything looked okay, until I left BT on, and it totally nuked my battery in about 1/2 of a day.
    I assume that for most of that half day you had Bluetooth on but weren't connected to a device?

    I'll give it a whack and see what happens.

    Since you're pretty experienced it should be relatively quick to load the final 6.0.1 image and get back to a usable state. Probably better than waiting for Google to come out with a fix.
    09-24-2016 08:28 PM
44 12

Similar Threads

  1. Bluetooth on my Samsung Galaxy grand prime stopped working
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 11-22-2016, 12:34 AM
  2. upgraded my Nexus 5, lost gallery
    By AC Question in forum Ask a Question
    Replies: 3
    Last Post: 08-29-2016, 11:54 PM
  3. upgraded my Nexus 5, lost gallery
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 08-29-2016, 11:43 PM
  4. issues returning defective Note 7 T Mobile
    By solotristan88 in forum Samsung Galaxy Note 7
    Replies: 5
    Last Post: 08-29-2016, 11:33 PM
LINK TO POST COPIED TO CLIPBOARD