10-19-2017 08:56 AM
26 12
tools
  1. rafeevans's Avatar
    After a smooth OTA upgrade, the phone now presents no incoming call screen. When I get a call the phone rings and vibrates but the screen stays dark. Sometimes I can unlock it with a fingerprint, then go to the home screen, then go to the phone icon, then open the on screen keyboard, which shows "Return To Call In Progress" among other options. Tapping that brings up the familiar screen that lets me answer the phone - if I am fast enough. A Google tech told me this is the new protocol but obviously that's bs. What to do?
    10-06-2016 05:59 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! No, that's clearly not how it's supposed to work. Any system apps disabled? Have you already tried a cache partition wipe?
    10-06-2016 02:07 PM
  3. rafeevans's Avatar
    Thanks for the reply. Moments ago a system upgrade came in promising to fix bugs etc. Alas, it didn't fix this disaster. I did clear the cache btw. I guess now I will go thru the brain damage of a full wipe but somehow I doubt something this serious will be fixed by it. I mean seriously, no incoming call screen!?
    10-06-2016 03:17 PM
  4. bjrosen's Avatar
    Do a factory reset
    10-06-2016 03:26 PM
  5. B. Diddy's Avatar
    Before the factory reset, see if this happens in Safe Mode as well: https://support.google.com/nexus/answer/2852139?hl=en
    10-06-2016 03:53 PM
  6. rafeevans's Avatar
    Just tried Safe Mode boot - the Google tech suggested it before the latest update. It didn't solve it then and it didn't just now. Any other ideas? This is a very major bug.
    10-06-2016 04:04 PM
  7. B. Diddy's Avatar
    Ok, then the next step would be a factory reset. If that still doesn't work, then the firmware may have become corrupted, in which case you would have to reinstall the firmware: How to manually update your Nexus | Android Central
    10-06-2016 05:35 PM
  8. rafeevans's Avatar
    I appreciate your suggestions Diddy. Sadly, I am getting a warranty replacement and will spend a couple of hours reconstructing my set up. I am just grateful it's a Nexus so there was nothing like Samsung blaming Google and visa versa.
    B. Diddy likes this.
    10-07-2016 04:17 AM
  9. GSDer's Avatar
    Well, since you're going to have to setup a new device from scratch anyway you might as well try a Factory Reset.

    And reloading the firmware would be good practice even if it doesn't solve your problem.
    10-08-2016 06:41 PM
  10. rafeevans's Avatar
    Yes, I did the factory reset and it did not help. Oh well.
    10-09-2016 07:58 AM
  11. renegad3's Avatar
    do you have a screen protector on the phone?
    10-09-2016 09:02 AM
  12. GSDer's Avatar
    Yes, I did the factory reset and it did not help.
    I'd suggest reloading the firmware if that didn't help.
    10-10-2016 01:21 AM
  13. jhasty's Avatar
    I am having the same problem. Started after Nougat upgrade. Rebooting the phone makes it go away for a while.

    I'm using Fi. I suspect it is related.
    10-12-2016 11:18 PM
  14. Trigati's Avatar
    I am having the same problem. Started after Nougat upgrade. Rebooting the phone makes it go away for a while.

    I'm using Fi. I suspect it is related.
    If you're on Fi, do you have Signal Spy or a similar app installed? If not, install something like it so you can keep track of which network your phone is connected to. You can see if it's trouble with a particular network (TMo, Sprint, or US Cellular), or a different issue. It may be (although I have no clue why) that the phone is unanswerable on certain networks. At least it would help troubleshoot if nothing else.
    10-13-2016 05:30 AM
  15. rafeevans's Avatar
    Reboots didn't help so they sent me a new phone yesterday. Annoyingly, it hadn't been upgraded from 6.0 so it took about 5 install cycles to get it up to Nougat No problems now.
    B. Diddy likes this.
    10-13-2016 05:45 AM
  16. jhasty's Avatar
    The phone app is not coming up on the screen during the call. That makes me think it is a software problem.
    10-13-2016 08:47 PM
  17. elcustardo's Avatar
    have you checked the dialer app is allowed notifications?
    I had the same issue and it was blocked.
    10-14-2016 12:57 PM
  18. stan23's Avatar
    The problem is hardware related. It's the proximity sensor. Glad a replacement phone is working for you.
    10-14-2016 02:06 PM
  19. GSDer's Avatar
    The problem is hardware related. It's the proximity sensor.
    Do you have some evidence to support that? If it was hardware, why did the problem suddenly start when the OP updated to 7.0?
    10-15-2016 07:17 PM
  20. Golfdriver97's Avatar
    It might be the screen protector blocking the proximity sensor, however, I don't think this would have suddenly surfaced.

    I had the same issue with my 5X. An updated version of the screen protector fixed it.
    10-15-2016 07:30 PM
  21. stan23's Avatar
    Do you have some evidence to support that? If it was hardware, why did the problem suddenly start when the OP updated to 7.0?
    Just search online. Lots of folks have this issue right after updating to nougat and no one knows why nougat can affect they sensor. For those folks even when they go back to marshmallow, the issue still exists.

    Only way to solve this is by sending your phone back to Huawei.
    10-15-2016 10:53 PM
  22. GSDer's Avatar
    Just search online. Lots of folks have this issue right after updating to nougat and no one knows why nougat can affect they sensor.
    Funny, I tried this exact search https://www.google.com/search?q=can%...obile&ie=UTF-8 and the only result that was even close was this post. I tried half-a-dozen similar searches and couldn't find any results that had anything to do with Nougat. (Note: there were lots of results that had to do with other phones, and proximity sensors, but none having anything to do with Android 7.)
    10-16-2016 05:08 PM
  23. stan23's Avatar
    Funny, I tried this exact search https://www.google.com/search?q=can%...obile&ie=UTF-8 and the only result that was even close was this post. I tried half-a-dozen similar searches and couldn't find any results that had anything to do with Nougat. (Note: there were lots of results that had to do with other phones, and proximity sensors, but none having anything to do with Android 7.)
    You have to search Nexus 6p proximity sensor issue.
    10-16-2016 05:54 PM
  24. GSDer's Avatar
    You have to search Nexus 6p proximity sensor issue.
    I did a search for 'Nexus 6P proximity sensor' and couldn't find a single link on the first page of results that had anything to do with the update to Nougat; tons of results dealing with faulty screen protector design; cracked screens; dropped phones; faulty sensors - nothing attributable to Android 7.
    10-16-2016 10:17 PM
  25. danedwards's Avatar
    I have been having the same problem off and on during factory resets of my phone while trying out various Nougat roms for my Moto X 2014. This time it was LineageOS 14.1. Exact same syptoms. I found that under the phone app settings the phone app was not set as the application for phone actions. No app was. From settings/apps/phone I clicked the phone action (which was blank) A window popped up and asked which app to use for phone actions. The only choice was phone. This took me back to the phone settings, and it now said phone where before it was blank. All is good now.
    GSDer likes this.
    01-27-2017 09:08 AM
26 12

Similar Threads

  1. How can I boot my archos platinum 55 into recovery mode?
    By AC Question in forum Ask a Question
    Replies: 6
    Last Post: 10-07-2016, 11:47 AM
  2. Can't get my smiley faces on my Sony Xperia Z3 tablet.
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 10-06-2016, 10:21 AM
  3. Replies: 2
    Last Post: 10-06-2016, 10:20 AM
  4. How can I change the IP on my archos platinum 55?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 10-06-2016, 06:28 AM
  5. my screen is all white on my zte f555 how can i fix it
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 10-06-2016, 05:12 AM
LINK TO POST COPIED TO CLIPBOARD