1. ptonantryloc's Avatar
    Starting today, when I try to Scan a document with Google Drive on my Nexus 6P (Android version 7.0, Security Patch level October 5, 2016, Kernel version 3.10.73-g875b816, Build number NBD90X, i.e., all the latest available to me) via Drive -> + -> Scan, I get an "Error while trying to connect to camera" message. I've rebooted the phone several times and have cleared Drive's cache. If I'm lucky, it looks like I can get one scanning session out of Drive before having to reboot the phone again. After that, it's back to the error message.

    I've also gone through all my apps and looked at their permissions. The apps I have that use the camera are:

    - Barcode Scanner
    - Camera
    - Drive
    - Google Play Services
    - OneNote
    - Street View
    - Translate
    - USAA

    I've tested each of those apps (except the Google Play Services app since I don't have direct access to it) and all of them except for Drive can use the camera without trouble. From that, I assume the camera, itself, is fine. I also assume that some other app isn't grabbing the camera and locking everything out (otherwise those other apps would also fail). My final assumption is that this has been caused by the latest Drive update of 27 October 2016 (v 2.4.382.19.40) since I no trouble with this before today.

    Is anyone else seeing this? Any suggestions?
    10-30-2016 04:42 PM
  2. GSDer's Avatar
    I just tried it, with the same version of Drive that you listed, and it worked fine (after I gave it permission to take pictures and record video). However I'm currently on 7.1.1 (NPF10C).

    Have you tried clearing the permissions for Drive to see if that makes a difference?
    10-30-2016 07:20 PM
  3. ptonantryloc's Avatar
    I turned off all of Drive's permissions, rebooted the phone, turned them all back on, and rebooted again. It's possible that fixed it. I hit the Scan button 3 times and got a camera feed each time. I'll let it sit for a bit and try some more later. Thanks.

    EDIT: It's still working. So, it looks like resetting Drive's permissions worked.
    10-30-2016 08:56 PM
  4. B. Diddy's Avatar
    It's also possible that one of those 3rd party apps (like Barcode Scanner) is glitching and not letting other apps use the camera. The next time this happens, try uninstalling it.
    10-31-2016 12:06 AM

Similar Threads

  1. Screenshot with Google on Tap
    By IMANUT46 in forum Samsung Galaxy S5
    Replies: 5
    Last Post: 11-05-2016, 06:21 AM
  2. Replies: 3
    Last Post: 10-31-2016, 12:57 AM
  3. One thing I need to know before I buy this phone...
    By Mikey88Chaos in forum LG V20
    Replies: 14
    Last Post: 10-30-2016, 08:02 PM
  4. Replies: 2
    Last Post: 10-30-2016, 07:01 PM
  5. Google Live Case Designs
    By RayMabry in forum Nexus 6P Accessories
    Replies: 0
    Last Post: 10-30-2016, 03:25 PM
LINK TO POST COPIED TO CLIPBOARD