1. King Mustard's Avatar
    My dad has a Nexus 6P.

    When he connects it to my Windows 10 PC or his own Windows 10 laptop, nothing appears in Computer (any USB mode on the phone).

    Device Manager shows a yellow exclamation mark next to the device.

    Trying to reinstall shows that an error occurs whilst installing 'MTP Device' (service installation section in INF invalid).

    I have tried installing the standard Android USB drivers, no luck.

    I've tried with and without USB debugging mode enabled.

    Any ideas?
    03-08-2017 01:52 PM
  2. B. Diddy's Avatar
    Have you tried different cables? If that doesn't help, it's possible something is wrong with the phone's microUSB port. Make sure it's clear of debris. If it is, and it still doesn't work, the port might have to be replaced.
    03-08-2017 05:05 PM
  3. PGrey's Avatar
    If you click on the exclamation too, you can get an error code, and generally some corresponding error text.
    While some of these are pretty generic (such as "failed to install"), some are very specific, such as letting you know that an intermediary driver failed to install, etc.

    I'm with B.Diddy though, my bets' on the cable, or a driver that's stale, but has bad inf data (which can sometimes block installing a new one).
    If the driver is the problem, the code is often fairly useful.
    B. Diddy likes this.
    03-08-2017 07:33 PM

Similar Threads

  1. No more rotating pictures on lockscreen with Nougat?
    By MKairys in forum Samsung Galaxy S7
    Replies: 3
    Last Post: 04-20-2017, 11:44 AM
  2. Replies: 1
    Last Post: 03-08-2017, 01:55 PM
  3. Replies: 1
    Last Post: 03-08-2017, 01:55 PM
  4. Replies: 3
    Last Post: 03-08-2017, 01:53 PM
  5. Replies: 1
    Last Post: 03-08-2017, 01:27 PM
LINK TO POST COPIED TO CLIPBOARD