1. poit57's Avatar
    My parents recently got two new Nokia 6.1 phones to use with AT&T service. On day 2, my mom received an MMS message with a photo that would not download. We also noticed that group MMS messages wouldn't download. After checking the APN settings, and even deleting them and manually re-adding the settings, the MMS messages still would not download.

    Since mobile data is required for MMS messages, I turned off Wi-Fi to test whether her internet connection was even working. We verified that it was working, and suddenly the failed MMS messages went through. I turned Wi-Fi back on and thought everything was working correctly for a few days.

    I was then informed that both parents were having issues sending and receiving messages. After further troubleshooting, MMS messages with picture/video attachments go through as expected when Wi-Fi is turned on. The problem now is that group text MMS messages will not work with Wi-Fi. In order to send and received those group messages, the Wi-Fi has to be toggled off long enough for the message to go through, and then we can toggle Wi-Fi back on.

    Is this a common problem with these phones, or is something really strange happening with the Wi-Fi connection?
    08-31-2018 04:55 PM
  2. Rukbat's Avatar
    MMS goes via cellular data, not via wifi. Not being able to use wifi is just normal, nothing wrong.
    08-31-2018 07:39 PM
  3. itic's Avatar
    I had the same issue. But never knew it was caused by cellular and wifi being enabled @ the sametime.
    09-01-2018 11:38 AM
  4. poit57's Avatar
    MMS goes via cellular data, not via wifi. Not being able to use wifi is just normal, nothing wrong.
    I know that MMS uses cellular data, but in 10 years of using smart phones, I've never experienced a phone that could not send and receive MMS while Wi-Fi was connected. Is this unique to Nokia's Android phones? No Windows phones or iPhone has ever had this problem. I have limited experience with Android, but my Sony Xperia and my brother's Moto don't have this issue either.

    I also think it's curious that photo and video MMS is being treated by the phone differently than group text MMS messages. The photos and videos are going through successfully with Wi-Fi connected.
    09-04-2018 08:33 AM
  5. Jim Smith14's Avatar
    This is not unique to Nokia, my Samsung S6 did this as well.
    09-05-2018 09:28 AM
  6. poit57's Avatar
    I wonder if this might resolve this behavior, but I won't have a chance to test it until I visit my parents tomorrow night.

    I found this forum from nearly 4 years ago discussing a similar issue with a Samsung Galaxy S4 running Lollipop on T-Mobile's network. About 3 months later, another user with a Nexus 5 running Marshmallow discovered the following about when MMS would and would not work.

    •MMS works when phone is connected to LTE and network APN set to IPv4
    •MMS works when phone is connected to LTE and network APN set to IPv6
    •MMS works when phone is connected to WiFi and network APN set to IPv4
    •MMS fails when phone is connected to WiFi and network APN set to IPv6

    I'll test my parents' phones tomorrow to see if switching the APN to use only IPv4 allows the MMS to send and receive while on Wi-Fi. The default setting for AT&T's APN is set to IPv4/IPv6.
    09-05-2018 01:58 PM
  7. poit57's Avatar
    Switching the APN settings to use only IPv4 seems to have helped my dad's phone. All MMS messages come through while connected to Wi-Fi. The only symptoms he's experiencing now are that it takes his phone longer than normal to send and receive MMS messages when on Wi-Fi. We tested by sending some group messages, and he seems to receive those messages about a minute later than the other people in the group who are also using AT&T service.

    My mom's phone continutes to exhibit the same problems no matter what we change the APN settings to. When on Wi-Fi, her phone will show that MMS messages are stuck in the sending or receiving status until Wi-Fi is toggled off. At that point, the messages go through immediately.

    I tried resetting all network settings, but that didn't help. I was going to try a factory reset on the phone, but the last SMS backup was done 9 days ago whereas all other backups show they were done either last night or tonight. I couldn't find any option to manually trigger a backup, so I am not really sure why the SMS backup is not running, but I don't want to reset the phone until I make sure everything is backed up.
    09-06-2018 10:13 PM

Similar Threads

  1. Replies: 1
    Last Post: 10-24-2018, 05:50 AM
  2. I'm About to Upgrade to the Note 9
    By monicakm in forum Samsung Galaxy S9 & S9+
    Replies: 35
    Last Post: 09-03-2018, 01:11 AM
  3. Skin to Cover the Pink
    By recDNA in forum Samsung Galaxy Note 9 Cases & Accessories
    Replies: 6
    Last Post: 08-31-2018, 05:45 PM
  4. Can't send pictures via Bluetooth from LG9100 to new LG K4 (2017)
    By dmehus in forum General Help and How To
    Replies: 1
    Last Post: 08-31-2018, 04:06 PM
  5. How to allow my kid to use a normal UI on the Kindle Fire HD 8?
    By Android Central Question in forum Ask a Question
    Replies: 0
    Last Post: 08-31-2018, 02:18 PM
LINK TO POST COPIED TO CLIPBOARD