1. moody's Avatar
    I just got my first OnePlus 6 device. It came with Pie and Oxygen 9.0.2.i have a Bluetooth earbud that auto connects no problem. But Bluetooth auto connect in my car doesn't work. In fact I have to go through a "ritual" of toggle on/off BT, connect in car and phone settings to get it to connect.

    I spent an hour on the phone w/ OP the other night and their response ended with "must be a bug in the OS. Sorry."

    My Sony Xperia XA1 Ultra auto connects just fine (Oreo 8.0) so I know it isn't my car

    Anyone else having this problem?
    12-08-2018 11:19 AM
  2. ironass's Avatar
    I just got my first OnePlus 6 device. It came with Pie and Oxygen 9.0.2.i have a Bluetooth earbud that auto connects no problem. But Bluetooth auto connect in my car doesn't work. In fact I have to go through a "ritual" of toggle on/off BT, connect in car and phone settings to get it to connect.

    I spent an hour on the phone w/ OP the other night and their response ended with "must be a bug in the OS. Sorry."

    My Sony Xperia XA1 Ultra auto connects just fine (Oreo 8.0) so I know it isn't my car

    Anyone else having this problem?
    If you enable, "Developer options", by going to Settings > About phone > Build number... tap on this quickly, about 7 or 8 times to enable, "Developer options"

    Now go to Settings > System > Developer options and you should find a lot more Bluetooth connectivity options if you scroll down.
    12-08-2018 11:47 AM
  3. moody's Avatar
    I actually did enable developers options and found a lot of BT options. But I didn't know what any of them meant so I turned dev mode back off.

    Any suggestion what specific to look for?
    12-08-2018 09:04 PM
  4. ironass's Avatar
    I actually did enable developers options and found a lot of BT options. But I didn't know what any of them meant so I turned dev mode back off.

    Any suggestion what specific to look for?
    It depends on your vehicle and the bluetooth equipment in it. Since your Sony Xperia XA1 connects OK, you could just emulate the settings in Developer options on that and see if it works.
    12-08-2018 09:31 PM
  5. rrspikes's Avatar
    Do you have a watch connected via BT?

    If so, turn off phone calls in it's BT settings.

    Delete both the phone and radio BT pairings.

    Reboot your 6 and then repair it to the cars radio.
    12-09-2018 06:21 AM
  6. moody's Avatar
    It depends on your vehicle and the bluetooth equipment in it. Since your Sony Xperia XA1 connects OK, you could just emulate the settings in Developer options on that and see if it works.
    I did try this. It didn't work though ☹️
    12-09-2018 09:32 PM
  7. moody's Avatar
    Do you have a watch connected via BT?

    If so, turn off phone calls in it's BT settings.

    Delete both the phone and radio BT pairings.

    Reboot your 6 and then repair it to the cars radio.
    I do not have a watch. I have removed my car and re-paired it a couple of times, including confirming my car as a "trusted device"

    But now I got bigger issues anyway... Turns out there was a software update for my car system so I installed it today and now no device will connect 🤦🏼*♀️ I will have to call Ford tomorrow 😡
    12-09-2018 09:35 PM
  8. moody's Avatar
    Happy to report my bluetooth issue with my car has been resolved!! Turns out there was an update for Ford Sync, so I got that done and my phone connected, and reconnected automatically when I tested it. Hope it stays that way!
    ironass and jchapman01 like this.
    12-10-2018 08:09 PM
  9. isdaako's Avatar
    I've got a couple of Fords, a 2016 and a 2017. My OP6 has connected to both easily since I got it.

    What year vehicle do you have that required an update to Sync?

    BTW... glad you got the problem solved.
    12-12-2018 07:38 AM
  10. jchapman01's Avatar
    Happy to report my bluetooth issue with my car has been resolved!! Turns out there was an update for Ford Sync, so I got that done and my phone connected, and reconnected automatically when I tested it. Hope it stays that way!
    Hey Moody, happy you got your issue fixed!

    I seem to have the opposite issue. My phone will auto connect to my Amazon Echo Dot every time I walk in the room or come home from work (basically every time I leave and reenter BT range) and I don't want it to. My previous phone would only connect when I asked Alexa to connect and that's actually what I prefer.

    Anyone know of a way to stop that from happening?
    12-12-2018 09:30 AM

Similar Threads

  1. Car manufacturer issue or Google issue?
    By digitalterry in forum Android Auto
    Replies: 4
    Last Post: 12-10-2018, 12:39 PM
  2. Smart Boost on OnePlus 6T
    By ironass in forum OnePlus 6 & 6T
    Replies: 7
    Last Post: 12-08-2018, 02:07 PM
  3. Can i get help wiht this issue regarding windows 10?
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 12-08-2018, 11:47 AM
  4. Internal connectivity issues.
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 12-07-2018, 05:56 PM
  5. Replies: 1
    Last Post: 12-07-2018, 03:28 PM
LINK TO POST COPIED TO CLIPBOARD