Use code Android10 andsave 10% on your first Upsie warranty
  1. Mcnaught01's Avatar
    Hi, This is Mcnaught. I recently encrypted my oppo find 5 mini phone to prevent any unauthorised access to my personal data in case it gets stolen. This encryption process took around 30 mins after which it rebooted. Now this is where my problem begins. It is asking me to enter decrypt password for which i need keyboard which is not showing up. The cursor inside password box is blinking but no matter how much you tap, password box won't show up. There is emergency phone icon below which when clicked gives me access to dialpad. I tried dialing my p/w & then copy that p/w into decrypt password box but then i have no keyboard to hit enter. I even tried doing factory reset by holding power button & volume down button but it doesn't work as phone is encrypted. I just don't know what to do & tried searching for any similar issue on web but found none. So i request anyone who could help me out of this predicament at the earliest. I have attached a picture of the screen m getting for reference. I thank everyone in advance for their time & consideration.
    Attached Thumbnails Keyboard not opening to decrypt oppo phone-1513935087292894885811.jpg  
    12-22-2017 03:37 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! Try connecting a basic USB keyboard via OTG adapter.
    Mcnaught01 likes this.
    12-22-2017 11:45 PM
  3. Mcnaught01's Avatar
    Hi, Thanks for your reply but unfortunately it didn't work as phone is stuck on boot screen. Even my pc failed to detect my phone. Having no other option left i approached Oppo service centre. Fortunately my phone was not rooted. They some how got my phone factory reset. Now my android is running on jellybean & lost my kitkat update. I tried updating but it says i already have latest version. I don't know how to get back to kitkat because many of my apps are not supported by jellybean.
    12-23-2017 11:34 AM
  4. B. Diddy's Avatar
    Did they manage to factory reset it in front of you, or did they have the phone for a few days? A factory reset shouldn't revert the phone back to a previous Android version, so it's possible they actually replaced the motherboard. Do you still have all of your apps and data on the phone?
    12-23-2017 06:02 PM
  5. Mcnaught01's Avatar
    God, I never thought of it. They have a separate room reserved for technicians.All this was done behind closed doors. Before that they made me sign a form which stated that Oppo in no way will be responsible for any data loss or even if phone goes dead. Having no other option left, I gave my approval. It took them just 10-15 mins to get my phone back on & as was expected i lost all my data & apps. And yes when I purchased this phone it came with jellybean version which got upgraded to kitKat after a year. Now I am wondering how to get back to KitKat because it keep saying I already have latest version. I think I should approach Oppo again & demand kit Kat update.
    12-24-2017 12:47 AM
  6. B. Diddy's Avatar
    There's a download here, but I'm not sure if it's the correct firmware for your exact model, and which Android version it is: https://www.oppo.com/in/downloads/
    Mcnaught01 likes this.
    12-24-2017 01:33 AM
  7. Mcnaught01's Avatar
    Mine is 4.2.2 , kernel version is 3.4.5-S11686, Build no R827_11_160914. Thanks & I'll also check the link you posted.
    12-24-2017 02:14 AM
  8. Mcnaught01's Avatar
    Thanks for posting that link. Good thing I was able to update my Android UI which is ColorOS to R827_11_ 160330.

    But my Android version still remains unchanged which is 4.2.2
    12-24-2017 02:47 AM
  9. B. Diddy's Avatar
    Sorry, I'm not sure what to try next. Do you remember if the KitKat update had previously been pushed to the phone automatically, or did you have to download it from a website and install it yourself? Did you get the phone directly from a carrier, or unlocked from an independent store?
    12-25-2017 12:48 PM
  10. Mcnaught01's Avatar
    Seriously I don't remember how it got upgraded to kitkat version as this phone is around 3-4 years old. But I am pretty sure this kitkat update was pushed into my phone coz if I had to do it manually I most probably would have rooted my phone to get the necessary update. I never wanted wanted to fidget with this phone coz of sensitive data I always carry in it & that's the reason why I got it encrypted in the first place. But anyways you been a great help from the beginning. I really appreciate your time & efforts. I will get back to oppo service center once they are back from Xmas off.
    B. Diddy likes this.
    12-26-2017 12:23 AM
  11. Mcnaught01's Avatar
    Hi, I just wanted to let you know that oppo service center got my phone version upgraded to kitkat. Thanks once again for all your support.
    B. Diddy likes this.
    12-31-2017 09:32 AM
  12. B. Diddy's Avatar
    That's great! I wonder why you weren't able to do the update yourself?
    12-31-2017 12:30 PM
  13. Mcnaught01's Avatar
    Me too, coz I am not that technically challenged. I remember flashing a custom rom In my previous HTC phone.
    So I am pretty much aware of all the android stuff. I assume that Oppo people have some tools to upgrade the phone with or without root.
    But as of now I'll just eat the mangoes and not count the trees.
    B. Diddy likes this.
    01-01-2018 11:07 AM

Similar Threads

  1. Replies: 6
    Last Post: 12-26-2017, 03:11 AM
  2. my phone fell down and wont turn on
    By Android Central Question in forum Ask a Question
    Replies: 3
    Last Post: 12-22-2017, 04:52 PM
  3. How to move Polandball can into space game data from android to PC ?
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 12-22-2017, 05:30 AM
  4. Replies: 1
    Last Post: 12-22-2017, 03:33 AM
  5. Notification tiles say unlock to see sensitive, how do I stop this?
    By Manojmangalassery in forum Ask a Question
    Replies: 1
    Last Post: 12-22-2017, 01:42 AM
LINK TO POST COPIED TO CLIPBOARD