07-05-2012 12:33 AM
8,044 ... 297298299300301 ...
tools
  1. sammyz's Avatar
    That caught me off guard, I never used Github for developing purposes. I just ported the rom using Windows, and edited using apps, and APKtool.
    How did you port it? And I would like to test.
    06-26-2012 02:33 PM
  2. henrikb's Avatar
    Try a new cable/ battery. Does it charge with another rom?

    Edit: oh never mind it does work with another rom
    Sent from my LG-LS670 using Android Central Forums
    I've updated my Original Post #7384, where I've report on additional "cannot power off" issues and done more troubleshooting, including trying with different cables and the Harmonia 2.08 ROM.

    /Thanks
    06-26-2012 02:49 PM
  3. henrikb's Avatar
    First, I'd install the new Cannibal Open Touch Recovery. Xionia is known to not wipe some partitions well. I bet you have something left over conflicting with Quattrimus.
    http://forums.androidcentral.com/opt...24-2012-a.html

    Then wipe /system, cache, data a couple times, then flash Quattrimus twice in a row, then gapps twice in a row, both before reboot. Also, clear cache and dalvik again befor first boot.
    I've updated my Original Post #7384, where I've report on additional "cannot power off" issues and done more troubleshooting, including trying with the Cannibal Open Touch v1.2 Recovery with and without multiple "full wipes".

    /Thanks
    06-26-2012 02:50 PM
  4. cooldudezach's Avatar
    I waited 20 minutes. Lol. It was due the LCD density. Had to change it to 128. It's booted now, would you like to test?
    I too, would love to test.
    06-26-2012 02:50 PM
  5. nichobrooks's Avatar
    @TDM

    I've been using Cold as Ice alpha 15F, and wanted to report the BT turning off issue is gone, I can turn it on, talk, call, hangup. and then I turn BT off and no reboot.

    Maybe you want to look into it

    Thanks for doing an amazing job!
    06-26-2012 02:56 PM
  6. ThatGuyLurkin's Avatar
    How did you port it? And I would like to test.
    Doing what I always do. o-o

    I learned from Gannon. I'm gonna make a thread in about an hour when I work out some minor bugs.


    Major help needed here!

    Rom is unrooted! How can I pre root it?
    topdawg661 likes this.
    06-26-2012 03:40 PM
  7. inyourface09's Avatar
    Doing what I always do. o-o

    I learned from Gannon. I'm gonna make a thread in about an hour when I work out some minor bugs.


    Major help needed here!

    Rom is unrooted! How can I pre root it?
    Great to hear I honestly can't wait to test it be sure to post a link

    Sent from my LG-VM670 using Android Central Forums
    06-26-2012 03:47 PM
  8. Ryuk6666's Avatar
    Doing what I always do. o-o

    I learned from Gannon. I'm gonna make a thread in about an hour when I work out some minor bugs.


    Major help needed here!

    Rom is unrooted! How can I pre root it?
    Ask tdm, I think the same thing happened to him with aosp.. I believe he fixed it, so he should know....
    Also can't wait to try it out

    G-T-R & Quattrimus CM9 Nuff' said.
    (Also, sent from my LG-VM670 using Tapatalk 2.)
    jnow2 likes this.
    06-26-2012 04:22 PM
  9. sellers86's Avatar
    Doing what I always do. o-o

    I learned from Gannon. I'm gonna make a thread in about an hour when I work out some minor bugs.


    Major help needed here!

    Rom is unrooted! How can I pre root it?
    You can also link to a flashable superuser zip

    Sent from my LG-VM670 using Tapatalk
    06-26-2012 04:26 PM
  10. sellers86's Avatar
    I misremembered the way I make those images on my own computers. If you are in a Linux environment, you should be able to open it with tar, as it's probably a tar archive with gzip, bzip2, or xz compression. Maybe Android is different in this regard than what I use, though.
    Use dsixda kitchen

    Sent from my LG-VM670 using Tapatalk
    06-26-2012 04:29 PM
  11. ThatGuyLurkin's Avatar
    You can also link to a flashable superuser zip

    Sent from my LG-VM670 using Tapatalk
    I know there was one in this thread somewhere. I'm gonna try one that I know, then I'm gonna search for that one.
    06-26-2012 04:32 PM
  12. firecrotch666's Avatar
    Hey TDM, just a question... would you ever consider porting Android 4.1 Jelly Bean when the source code comes out?
    06-26-2012 04:44 PM
  13. tcrider84's Avatar
    hm, i didn't have a problem last night but now I'm having this issue compiling. I had to re-set up my cm9 repo on my work machine today. I've already applied the libaudio patch:

    https://github.com/Blackhive/android...ardware_legacy

    Code:
    target thumb C++: audio.primary.thunderc <= device/lge/thunderc-common/libaudio/audio_hw_hal.cpp
    device/lge/thunderc-common/libaudio/audio_hw_hal.cpp: In function 'int android_audio_legacy::qcom_adev_open(const hw_module_t*, const char*, hw_device_t**)':
    device/lge/thunderc-common/libaudio/audio_hw_hal.cpp:573: error: 'struct audio_hw_device' has no member named 'set_fm_volume'
    make: *** [out/target/product/VM670/obj/SHARED_LIBRARIES/audio.primary.thunderc_intermediates/audio_hw_hal.o] Error 1
    06-26-2012 04:47 PM
  14. Shryvone12's Avatar
    Ok guys. I got Paranoid Android booted! The whole Tablet UI and everything is there!

    Bugs so far: 2 Setting options don't work. Task bar isn't at the bottom due to Paranoid Setting being broken. Keyboard is wonky, gonna fix. MMS, I don't really know, need testers.

    Screenshots: Click to view quoted image
    Click to view quoted image
    Click to view quoted image
    Click to view quoted image
    Click to view quoted image
    Click to view quoted image


    Even the browser!
    Click to view quoted image
    Ha Ill be a tester
    06-26-2012 05:04 PM
  15. Octahedron's Avatar
    Ok guys. I got Paranoid Android booted! The whole Tablet UI and everything is there!

    Bugs so far: 2 Setting options don't work. Task bar isn't at the bottom due to Paranoid Setting being broken. Keyboard is wonky, gonna fix. MMS, I don't really know, need testers.

    Screenshots: Click to view quoted image
    Click to view quoted image
    Click to view quoted image
    Click to view quoted image
    Click to view quoted image
    Click to view quoted image


    Even the browser!
    Click to view quoted image
    I'd love to test. I'll see what I can help with.

    Sent from my LG-VM670 using Android Central Forums
    06-26-2012 05:40 PM
  16. sellers86's Avatar
    hm, i didn't have a problem last night but now I'm having this issue compiling. I had to re-set up my cm9 repo on my work machine today. I've already applied the libaudio patch:

    https://github.com/Blackhive/android...ardware_legacy

    Code:
    target thumb C++: audio.primary.thunderc <= device/lge/thunderc-common/libaudio/audio_hw_hal.cpp
    device/lge/thunderc-common/libaudio/audio_hw_hal.cpp: In function 'int android_audio_legacy::qcom_adev_open(const hw_module_t*, const char*, hw_device_t**)':
    device/lge/thunderc-common/libaudio/audio_hw_hal.cpp:573: error: 'struct audio_hw_device' has no member named 'set_fm_volume'
    make: *** [out/target/product/VM670/obj/SHARED_LIBRARIES/audio.primary.thunderc_intermediates/audio_hw_hal.o] Error 1
    you can either remove the FM_RADIO lines in the BoardConfigCommon.mk in thunderc-common or revert the hardware/libhardware commit e37a70c63c1d307a877ec37cb83c388bffdb25ac (thank tdm for finding the source) to fix. please post these questions in the building thread though, to reduce clutter
    pbailey212 and tdm like this.
    06-26-2012 06:14 PM
  17. tdm's Avatar
    Fyi, been setting up the new build box the last couple days and I'm going out of town for a few days on a mini vacation, so I wont be around until next monday. Just wanted everyone to know so you don't think I went awol.
    06-26-2012 06:52 PM
  18. inyourface09's Avatar
    Turns out hotspots are not working on any ics roms at the moment, and my search goes on
    06-26-2012 06:53 PM
  19. topdawg661's Avatar
    Fyi, been setting up the new build box the last couple days and I'm going out of town for a few days on a mini vacation, so I wont be around until next monday. Just wanted everyone to know so you don't think I went awol.
    U deserve it!(:

    Sent from my VM670 using Tapatalk 2
    andrewnelson23 likes this.
    06-26-2012 06:57 PM
  20. tdm's Avatar
    you can either remove the FM_RADIO lines in the BoardConfig.mk or revert the hardware/libhardware commit e37a70c63c1d307a877ec37cb83c388bffdb25ac (thank tdm for finding the source) to fix. please post these questions in the building thread though, to reduce clutter
    Note thats BoardConfigCommon.mk in thunderc-common.
    06-26-2012 06:58 PM
  21. sellers86's Avatar
    Note thats BoardConfigCommon.mk in thunderc-common.
    ill change now.
    06-26-2012 07:03 PM
  22. tcrider84's Avatar
    you can either remove the FM_RADIO lines in the BoardConfigCommon.mk in thunderc-common or revert the hardware/libhardware commit e37a70c63c1d307a877ec37cb83c388bffdb25ac (thank tdm for finding the source) to fix. please post these questions in the building thread though, to reduce clutter
    my apologies. i made some modifications in an attempt to fix wifi hotspot to BoardConfigCommon.mk so that might be the cause of it. Thanks, I'll keep the building thread in mind next time
    inyourface09 likes this.
    06-26-2012 07:08 PM
  23. sellers86's Avatar
    my apologies. i made some modifications in an attempt to fix wifi hotspot to BoardConfigCommon.mk so that might be the cause of it. Thanks, I'll keep the building thread in mind next time
    i ran into the error also, the cause was a commit made by CM.
    06-26-2012 07:09 PM
  24. tcrider84's Avatar
    i ran into the error also, the cause was a commit made by CM.
    could I get a link to the building thread? still kind've new here. looked around but i'm pretty blind irl so that's probably why I can't find it lol.

    also seeing that commit, i wonder if changing defined(FM_RADIO) to defined(HAVE_FM_RADIO) as it's called in audio_hw_hal.cpp would make it work correctly as it's intended to.
    06-26-2012 07:29 PM
  25. sellers86's Avatar
    could I get a link to the building thread? still kind've new here. looked around but i'm pretty blind irl so that's probably why I can't find it lol.

    also seeing that commit, i wonder if changing defined(FM_RADIO) to defined(HAVE_FM_RADIO) as it's called in audio_hw_hal.cpp would make it work correctly as it's intended to.
    doesnt matter, we havent ever been able to get fm to work. ill get a link to the thread. hold on

    LINK: http://forums.androidcentral.com/opt...r-own-rom.html
    06-26-2012 08:03 PM
8,044 ... 297298299300301 ...
LINK TO POST COPIED TO CLIPBOARD