07-05-2012 01:33 AM
8,044 ... 4142434445 ...
tools
  1. neocrypter's Avatar
    Billy Crystal as Miracle Max in the 1987 Rob Reiner classic The Princess Bride. One of my all time favorite movies to quote.

    Sent from the BACKside of Tapatalk
    mine too

    Sent from my VM670 using Tapatalk
    03-10-2012 04:08 AM
  2. frogpot's Avatar
    Mk,..
    mmmmm
    03-10-2012 10:56 AM
  3. Zakman's Avatar
    Take your time man No rush. Super excited for this tho! you have camera and hardware accl working? FFFFFFFF YES!
    03-10-2012 01:03 PM
  4. anthonycr's Avatar
    I played with the hardware accel all day and still couldn't get it to work. My first try was actually the best -- at least things didn't crash -- but it was pretty much unusable.

    I think I'm going to have to back off on that and go back to software rendering for now so I can make progress on other things. I'll definitely have an update on Monday, but without camera or hardware accel. This will give me time to sync with current CM and work on other things.
    03-10-2012 01:16 PM
  5. grosskum's Avatar
    im guessing no but will the update checker work to get alpha 7 or not when it comes out?
    03-10-2012 01:55 PM
  6. anthonycr's Avatar
    im guessing no but will the update checker work to get alpha 7 or not when it comes out?
    Update checker?? There's an update checker for backside... not for this.
    03-10-2012 02:09 PM
  7. tdm's Avatar
    Take your time man No rush. Super excited for this tho! you have camera and hardware accl working? FFFFFFFF YES!
    No, not yet. This is a brief overview of where I'm at and what I have planned for Monday:

    I have hardware acceleration almost working but it's still flaky enough that it's pretty much unusable. Things don't appear or disappear at the right time, screen transitions sometimes don't complete, that sort of thing. But I did play with it enough to see that the basics work and angry birds was playable. So it's promising, but not there yet. I tried all day yesterday to fix it but was unsuccessful. So I'm going to put it down for now and look at other things.

    I have the camera far enough along that the app fires up but I haven't actually gotten any pics yet. Somehow the actual video data isn't being passed out of the hardware. So again, promising, but not there yet. I'm much more hopeful about being able to fix this because I deal with these sorts of issues (Linux kernel driver issues) all the time at work.

    I got the xt_qtaguid module into the kernel. This enables network stats functionality and populates the data usage graphs (system settings -> data usage). Not that us VM users care, but it's a nice touch.

    MMS is getting farther with the xt_qtaguid module but it's still not turning on 3G while on WiFi. So I need to look into this further. Shouldn't be a huge deal to fix but will probably take a day or two of debugging.

    I synced up with the CM9 tree about 2/29 I think. Several issues are fixed, including the numeric battery indicator. I'll probably sync up again on Monday before I do a final alpha7 build.

    I'm going to put back a couple of the gapps packages that I had previously removed. I personally like GenieWidget (news & weather) and there's been a request for CalendarGoogle.
    03-10-2012 02:11 PM
  8. terthii's Avatar
    No, not yet. This is a brief overview of where I'm at and what I have planned for Monday:

    I have hardware acceleration almost working but it's still flaky enough that it's pretty much unusable. Things don't appear or disappear at the right time, screen transitions sometimes don't complete, that sort of thing. But I did play with it enough to see that the basics work and angry birds was playable. So it's promising, but not there yet. I tried all day yesterday to fix it but was unsuccessful. So I'm going to put it down for now and look at other things.
    This is probably a stupid question...but can someone explain to me exactly what hardware acceleration does? From my understanding, it has to do with video, games, and maybe music? Does it have something to do with the video card?
    03-10-2012 02:27 PM
  9. LeoLawliet's Avatar
    No, not yet. This is a brief overview of where I'm at and what I have planned for Monday:

    I have hardware acceleration almost working but it's still flaky enough that it's pretty much unusable. Things don't appear or disappear at the right time, screen transitions sometimes don't complete, that sort of thing. But I did play with it enough to see that the basics work and angry birds was playable. So it's promising, but not there yet. I tried all day yesterday to fix it but was unsuccessful. So I'm going to put it down for now and look at other things.

    I have the camera far enough along that the app fires up but I haven't actually gotten any pics yet. Somehow the actual video data isn't being passed out of the hardware. So again, promising, but not there yet. I'm much more hopeful about being able to fix this because I deal with these sorts of issues (Linux kernel driver issues) all the time at work.

    I got the xt_qtaguid module into the kernel. This enables network stats functionality and populates the data usage graphs (system settings -> data usage). Not that us VM users care, but it's a nice touch.

    MMS is getting farther with the xt_qtaguid module but it's still not turning on 3G while on WiFi. So I need to look into this further. Shouldn't be a huge deal to fix but will probably take a day or two of debugging.

    I synced up with the CM9 tree about 2/29 I think. Several issues are fixed, including the numeric battery indicator. I'll probably sync up again on Monday before I do a final alpha7 build.

    I'm going to put back a couple of the gapps packages that I had previously removed. I personally like GenieWidget (news & weather) and there's been a request for CalendarGoogle.
    Please keep GenieWidget for future updates, that's one of the only stock Widgets I use at all. Thanks for the update, as usual I'm gonna play the waiting game and browse around for different roms in the meantime

    Sent from my LG-VM701 Gelato 11-28 via Tapatalk
    03-10-2012 03:10 PM
  10. Ilovefarts's Avatar
    Thanks for your hard work on this everyone!
    03-10-2012 03:25 PM
  11. patfanortiz_010304's Avatar
    If anyone is having trouble with the wifi not working even when connected to a network or when connectiing to a different network I found a simple yet not so convenient solution . For some reason this from isn't writing the right code inside the wpa_supplicant.config file so using root explorer go to ur phones parent folder go to data then to misc then to wifi n inside that folder u will find the .config file long press it then select open as text editor then set all numerical figures to 0 (0=enabled, 1=disabled) also erase the old network you were con.ected to and if it shows disabled unr3rneath the current network ur on erase that too. Then save it will make a .bakfile of the old .config file so don't worry about messing up. Also before u do this dissconect from the network turn wifi off then after editing turn wifi on then reboot phone . Upon reboot it will work.
    Ilovefarts likes this.
    03-10-2012 04:46 PM
  12. tdm's Avatar
    This is probably a stupid question...but can someone explain to me exactly what hardware acceleration does? From my understanding, it has to do with video, games, and maybe music? Does it have something to do with the video card?
    Well, in general terms, hardware acceleration means that the CPU is offloading work to another chip. This could be scientific computations done by a special processor, SSL encryption/decryption done by an add-in card, etc.

    In our case, we are using the term to mean video acceleration. Specifically hardware assisted OpenGL rendering. I'm not personally familiar with all the details -- heck, I never even looked at the OpenGL API. But I imagine that does cool effects like alpha blending, screen fading and transititions, rotations, and more.
    mustafu and terthii like this.
    03-10-2012 05:20 PM
  13. reaper420's Avatar
    If anyone is having trouble with the wifi not working even when connected to a network or when connectiing to a different network I found a simple yet not so convenient solution . For some reason this from isn't writing the right code inside the wpa_supplicant.config file so using root explorer go to ur phones parent folder go to data then to misc then to wifi n inside that folder u will find the .config file long press it then select open as text editor then set all numerical figures to 0 (0=enabled, 1=disabled) also erase the old network you were con.ected to and if it shows disabled unr3rneath the current network ur on erase that too. Then save it will make a .bakfile of the old .config file so don't worry about messing up. Also before u do this dissconect from the network turn wifi off then after editing turn wifi on then reboot phone . Upon reboot it will work.
    Thanks for the info, also did you happen to figure out what file you changed to get the video working?

    Sent from my LG-VM670 using Tapatalk
    03-10-2012 05:22 PM
  14. frogpot's Avatar
    This is my first post on here and im useing it to say thanks to you good sir would have bin months befor i got even close to this far getting ics on my ov and thanks to every one who has a hand in helping move this forward
    03-10-2012 05:38 PM
  15. docliquid's Avatar
    Can't wait to try this out, keep up the good work
    03-10-2012 05:43 PM
  16. a5pe4's Avatar
    I'm going to put back a couple of the gapps packages that I had previously removed. I personally like GenieWidget (news & weather) and there's been a request for CalendarGoogle.
    I would like to have google talk included in gapps as well! Very useful app. Especially since it connects all Android users.

    Sent from my LG-VM670 using Tapatalk
    03-10-2012 06:25 PM
  17. patfanortiz_010304's Avatar
    Thanks for the info, also did you happen to figure out what file you changed to get the video working?

    Sent from my LG-VM670 using Tapatalk
    Oh yeah lemme start lpoking , if u have an idea where it'd be located lemme know haha I'm pretty sure its in etc also
    reaper420 likes this.
    03-10-2012 07:57 PM
  18. Samuelg900's Avatar
    Update checker?? There's an update checker for backside... not for this.
    He is taking about the system updates in the about phone in the settings
    03-10-2012 08:42 PM
  19. Rayz321's Avatar
    Wow thank you so much for this You got me addicted to ICS even if it's not fully functional.
    Great job I hope you keepup the work
    03-10-2012 10:15 PM
  20. reaper420's Avatar
    Oh yeah lemme start lpoking , if u have an idea where it'd be located lemme know haha I'm pretty sure its in etc also
    I've been looking like crazy,I can't figure it out

    Sent from my LG-VM670 using Tapatalk
    03-10-2012 11:19 PM
  21. terthii's Avatar
    Well, in general terms, hardware acceleration means that the CPU is offloading work to another chip. This could be scientific computations done by a special processor, SSL encryption/decryption done by an add-in card, etc.

    In our case, we are using the term to mean video acceleration. Specifically hardware assisted OpenGL rendering. I'm not personally familiar with all the details -- heck, I never even looked at the OpenGL API. But I imagine that does cool effects like alpha blending, screen fading and transititions, rotations, and more.
    Ah, ok. I get it now, thanks!
    03-10-2012 11:34 PM
  22. brotherswing's Avatar
    That is a very succinct explanation, well said (written?)

    Sent from the BACKside of Tapatalk
    03-11-2012 12:33 AM
  23. firecrotch666's Avatar

    Just the ROM in action.
    Anyways, when hardware acceleration is fixed, will that fix the no Youtube/video issues?
    drm1992 likes this.
    03-11-2012 12:43 AM
  24. cammykool's Avatar
    has anyone noticed 3G wont lock on and WI-FI wont show how many bars its getting? just curious
    03-11-2012 05:26 AM
  25. anthonycr's Avatar
    has anyone noticed 3G wont lock on and WI-FI wont show how many bars its getting? just curious
    I have, the fact that 3g keeps going in and out is the biggest reason that battery is draining so fast. I turned off data the other day and got my phone through a 14 hour day... when with spotty 3g enabled in quattrimus I'd kill my battery after around four hours.
    03-11-2012 07:54 AM
8,044 ... 4142434445 ...
LINK TO POST COPIED TO CLIPBOARD