01-17-2013 12:07 AM
1,060 ... 3132333435 ...
tools
  1. thewraith420's Avatar
    Ok so I know enough to make my own build of iho but how do I build bobz kernel into it?

    Sent from my LG-VM670 using Tapatalk 2
    04-20-2012 03:13 AM
  2. thewraith420's Avatar
    Ok so I know enough to make my own build of iho but how do I build bobz kernel into it?

    Sent from my LG-VM670 using Tapatalk 2
    Anyone?

    Sent from my LS670 using Tapatalk 2
    04-21-2012 09:33 PM
  3. tvall's Avatar
    Ok so I know enough to make my own build of iho but how do I build bobz kernel into it?

    Sent from my LG-VM670 using Tapatalk 2
    the zImage and modules go in device/lge/thunderc_model/files/kernel if i remember correctly
    04-21-2012 09:38 PM
  4. rukin5197's Avatar
    Hey guys I'm going to need some help. In my ROM the animations are dreadfully slow. It's ridiculous and not usable by any means. Where are the files needed for animations? Preferably in the build directory.
    04-22-2012 12:18 AM
  5. anthonycr's Avatar
    Hey guys I'm going to need some help. In my ROM the animations are dreadfully slow. It's ridiculous and not usable by any means. Where are the files needed for animations? Preferably in the build directory.
    You should probably specify which of your roms you are talking about there's so many!

    Sent from my VM670 using Tapatalk 2
    04-22-2012 12:23 AM
  6. EarthnFire78's Avatar
    After realizing what I have doing wrong with BacksideUpdter.apk finally got it working, there is one small problem. What was the working around for Root Browser, as it seems to have problems?

    Code:
    E: in sdcard cannot mount /mnt/sdcard/download/
    04-22-2012 04:43 AM
  7. rukin5197's Avatar
    Another question. How do I pull in changes that aren't from my or my person that I synced from (In this case, AOSP). Like, I want to pull in this commit https://github.com/androidmeda/cm_de...c0c5a4bb6a3c99
    But I don't necessarily know how to do it.
    04-22-2012 07:24 PM
  8. BobZhome's Avatar
    Another question. How do I pull in changes that aren't from my or my person that I synced from (In this case, AOSP). Like, I want to pull in this commit https://github.com/androidmeda/cm_de...c0c5a4bb6a3c99
    But I don't necessarily know how to do it.
    You do 'remote add' and then cherry-pick the commit... but for that commit I would manually add.... you don't want all of it.

    Sent from my LG-VM670 using Tapatalk 2
    rukin5197 likes this.
    04-23-2012 04:38 PM
  9. JerryScript's Avatar
    After realizing what I have doing wrong with BacksideUpdter.apk finally got it working, there is one small problem. What was the working around for Root Browser, as it seems to have problems?

    Code:
    E: in sdcard cannot mount /mnt/sdcard/download/
    No workaround yet, I'm using the generic android file pick intent, with it's default return key/value pairs. If Root Browser doesn't support those, it won't work. The CM7 default OI File Manager, and Root Explorer both work fine, haven't tested others yet.

    I'll have to do a file path check to be sure mnt isn't used in the returned string.
    04-23-2012 06:03 PM
  10. cole2kb's Avatar
    Can anyone shed some light on this?

    From http://github.com/CyanogenMod/android_developmentiB/s
    * [new branch] donut -> github/donut
    * [new branch] eclair -> github/eclair
    * [new branch] froyo -> github/froyo| 350 KiB/s
    * [new branch] froyo-stable -> github/froyo-stable
    * [new branch] gb-release-7.2 -> github/gb-release-7.2
    * [new branch] gingerbread -> github/gingerbread
    * [new branch] gingerbread-release -> github/gingerbread-release
    * [new branch] ics -> github/ics
    * [new tag] cm-7.1.0 -> cm-7.1.0
    From http://github.com/CyanogenMod/android_development
    * [new tag] cm-7.0.0 -> cm-7.0.0
    * [new tag] cm-7.0.1 -> cm-7.0.1
    * [new tag] cm-7.0.2.1 -> cm-7.0.2.1
    * [new tag] cm-7.0.3 -> cm-7.0.3
    error: RPC failed; result=18, HTTP code = 200B | 152 KiB/s
    fatal: The remote end hung up unexpectedly
    fatal: early EOF
    fatal: index-pack failed
    warning: http unexpectedly said: '0000'
    error: Cannot fetch inferiorhumanorgans/android_device_lge_thunderc_common

    error: Exited sync due to fetch errors
    04-24-2012 02:53 PM
  11. sellers86's Avatar
    Can anyone shed some light on this?
    Lower your -j value. I use -j2

    Sent from my LG-VM670 using Tapatalk
    cole2kb likes this.
    04-24-2012 11:16 PM
  12. cole2kb's Avatar
    Thanks. Just tried it, and here's what happens now, lol.

    chris@chris-Dimension-4600i:~$ cd ~/android/system/
    chris@chris-Dimension-4600i:~/android/system$ repo init -u git://github.com/inferiorhumanorgans/android.git -b gingerbread

    Your Name [cole2kb]:
    Your Email [cole2kb@gmail.com]:

    Your identity is: cole2kb <cole2kb@gmail.com>
    is this correct [y/n]? y

    repo initialized in /home/chris
    chris@chris-Dimension-4600i:~/android/system$ repo sync -j2
    Fetching projects: 1% (3/209) fatal: Not a git repository: '/home/chris/.repo/projects/bootable/diskinstaller.git'
    error: Cannot fetch CyanogenMod/android_bootable_diskinstaller
    Fetching projects: 2% (5/209)
    error: Exited sync due to fetch errors
    chris@chris-Dimension-4600i:~/android/system$ repo sync -j1
    Fetching projects: 1% (3/208) fatal: Not a git repository: '/home/chris/.repo/projects/bootable/diskinstaller.git'
    error: Cannot fetch CyanogenMod/android_bootable_diskinstaller
    chris@chris-Dimension-4600i:~/android/system$
    EDIT -- okay, so, I had to use "sudu su" to get this to work properly, i tried deleting the .repo folder and starting over, to no avail. So, running the commands after using 'sudo su' seems to be running fine, so I'm okay with doing this under the root account, just have to remember that when working on this.

    edit 2 -- UGH. repo sync -j1 gave me this:
    error: RPC failed; result=18, HTTP code = 200iB | 74 KiB/s
    fatal: The remote end hung up unexpectedly
    fatal: early EOFs: 40% (24399/60988), 5.28 MiB | 99 KiB/s
    fatal: index-pack failed
    warning: http unexpectedly said: '0000'
    error: Cannot fetch CyanogenMod/android_development
    I'm chalking it up to a spotty internet connection? Only thing I can think of. This seems useless to try any more, unless someone can give me another suggestion. I appreciate the help.
    04-25-2012 12:36 AM
  13. sellers86's Avatar
    Thanks. Just tried it, and here's what happens now, lol.



    EDIT -- okay, so, I had to use "sudu su" to get this to work properly, i tried deleting the .repo folder and starting over, to no avail. So, running the commands after using 'sudo su' seems to be running fine, so I'm okay with doing this under the root account, just have to remember that when working on this.

    edit 2 -- UGH. repo sync -j1 gave me this:


    I'm chalking it up to a spotty internet connection? Only thing I can think of. This seems useless to try any more, unless someone can give me another suggestion. I appreciate the help.
    thats what it sounds like to me. I have the same problem everytime I try to build at my friends house because of a bad wifi signal. Not sure what to tell you to do about that
    04-25-2012 09:10 AM
  14. cole2kb's Avatar
    It's my DSL line, I'm sure of it. My Wi-Fi signal is perfect, my router is right next to my computer. (I'd just go wired but this model computer is notorious for their Ethernet ports not working, including mine.) Oh well, just keep trying I guess.
    04-25-2012 09:50 AM
  15. tdm's Avatar
    Wouldn't it be easier to just get a login to LeslieAnn's build server?
    04-25-2012 11:26 AM
  16. cole2kb's Avatar
    Easier, maybe, I didn't ask but it ended up coming up due to a miscommunication and she isn't willing to give me one, which is fine, I understand why and agree with her, and I have my own reasons. 99% chance I will never actually contribute to the community, I'm just learning right now, and this place is cluttered to hell already with too many ROMs, we don't need any more devs.
    04-25-2012 11:32 AM
  17. tvall's Avatar
    Easier, maybe, I didn't ask but it ended up coming up due to a miscommunication and she isn't willing to give me one, which is fine, I understand why and agree with her.
    I still have a box I'm willing to let people use if you're interested. Its not nearly as nice as the build server, but its good enough for learning and experimenting (my roms were built on it before leslieann gave me a login on the build server (thank you!))
    04-25-2012 11:36 AM
  18. cole2kb's Avatar
    I still have a box I'm willing to let people use if you're interested.
    I appreciate the offer, but I just don't think I'd feel right about you doing the work to set it up just so I can play around and probably never do anything substantial or helpful for the community. It's nothing more than a personal learning exercise for the time being.
    04-25-2012 11:51 AM
  19. tvall's Avatar
    I appreciate the offer, but I just don't think I'd feel right about you doing the work to set it up just so I can play around and probably never do anything substantial or helpful for the community. It's nothing more than a personal learning exercise for the time being.
    It's already set up. All I'd have to do is type "sudo adduser whatever" then pm you the info. No work for me.
    04-25-2012 11:55 AM
  20. cole2kb's Avatar
    It's already set up. All I'd have to do is type "sudo adduser whatever" then pm you the info. No work for me.
    Well, if you're cool with it and it isn't any trouble for you, that would be cool. I'd just need to set up an SSH client on my end, right? Any recommendations?
    04-25-2012 12:03 PM
  21. tvall's Avatar
    and this place is cluttered to hell already with too many ROMs, we don't need any more devs.
    There is no such thing as "too many devs"! I think we could use more.
    LeslieAnn and clodfelterac like this.
    04-25-2012 12:05 PM
  22. tvall's Avatar
    Well, if you're cool with it and it isn't any trouble for you, that would be cool. I'd just need to set up an SSH client on my end, right? Any recommendations?
    Pm'ed you to avoid cluttering this thread any more than I already have
    cole2kb likes this.
    04-25-2012 12:12 PM
  23. thewraith420's Avatar
    Hmm so the iho repo won't sync for me and Jerry's syncs and builds fine but builds roms that 3g doesn't work.. Anyone know a fix?

    Sent from my LG-VM670 using Tapatalk 2
    04-25-2012 02:42 PM
  24. JerryScript's Avatar
    3G should work fine on builds from my repo, what does logcat show?

    As for IHO, if you can't sync, try again later. Network issues at either end can cause errors syncing (unless you have a specific error message beyond http).
    04-25-2012 02:47 PM
  25. thewraith420's Avatar
    okay in that case.... all i've done is swap out the zimage and kernel modules i'm trying to build it with drews hydrokernel. i know they work on backside because i've used his flashable zip and am useing it on my own phone.
    04-25-2012 05:47 PM
1,060 ... 3132333435 ...
LINK TO POST COPIED TO CLIPBOARD