09-22-2015 01:20 PM
6,009 ... 154155156157158 ...
tools
  1. cr42ydude's Avatar
    jerry can u please double check on the wifi thing. maybe do a reflash or make sure u uploaded the right one.. im having the same wifi problem... reflashed many times. TY
    01-19-2012 03:32 AM
  2. JerryScript's Avatar
    OK, using the latest build which I had previously downloaded via wifi on the same build (loaded right after I built it), I redownloaded the ROM and GreenMachineTheme zips from the links posted here.

    I then checked the md5sum of the downloads on the phone using terminal.

    I then booted into recovery and wiped cache, and under advanced wiped dalvik cache.

    I then flashed the BACKside zip file, and then the GreenMachineTheme zip file.

    I then rebooted, and waited patiently for my phone to fully initialize
    (I always wait 5 minutes on first boot before touching the phone to let it fully load up )

    While waiting, I saw the wifi icon engage (turned white then green) before the phone went to sleep during first boot up.
    (took about 7 seconds)

    I then unlocked the phone, swiped the screens around a bit to be sure there was no lag left, used the Power Control widget to turn wifi off, counted to 10 slowly and turned it back on. It reconnected to wifi in about 10 seconds.

    I then opened my browser and loaded up several webpages, opened the Market, streamed some music via TuneIn Radio, watched a YouTube video, and checked scores on Score Mobile.

    There have been no changes to wifi in the code for a couple of months. My only conclusion is that the ROM's wifi is fine. Sorry to say, but it may take a complete wipe/format/reinstall-restore to fix whatever issues you may be having.
    01-19-2012 05:27 AM
  3. Eollie's Avatar
    What recovery are you guys using that are having issues with wifi?
    01-19-2012 05:37 AM
  4. CuriousNoob's Avatar
    I use the one found in the All in one Recovery Thread over at AndroidForums.

    Sent from my LG-VM670 using Tapatalk
    01-19-2012 06:16 AM
  5. CuriousNoob's Avatar
    @Jerry, I tried to redownload again. I downloaded from my computer about 20 minutes ago, put it on my phones. Wipe Boot,Cache,System,Data manually, followed by the Factory Reset, then Dalvik Cache wipe. After that, I flashed DebugFormatALL.zip to make sure I wiped. Flashed the Rom, Gapps, and the Wifi turns off if I highlight another selection and doesn't scan for a network. :/
    01-19-2012 06:48 AM
  6. kwknott's Avatar
    Jerry,

    I'm having the same issue with your new build. When I turn on Wifi it just turns itself back off after about 5 - 10 seconds and while it's on it doesn't show any networks. I have performed full wipes (boot, cache, data, system, dalvik cache) and reflashed the rom a few times. Even downloaded the rom again and verified the md5sum. I even tried switching from Xionia recovery to IHO just to be sure it wasn't a recovery issue.
    01-19-2012 07:04 AM
  7. JerryScript's Avatar
    I don't know what to tell you guys. I have downloaded the ROM from the links posted here three times now, wiped and reflashed, and each time my WiFi has worked fine. I'm posting this from my phone over WiFi now.

    If you are not using the recommended recovery, please try with it. There have been no changes to WiFi in the code for a while now.
    01-19-2012 07:12 AM
  8. mm60's Avatar
    For all of you having problems with the latest build, have you tried going back to the earlier build? If that works, it would rule out a problem with the recovery (I am guessing). Has anyone else got the latest build working?
    01-19-2012 07:20 AM
  9. JerryScript's Avatar
    Hmmm, there is a single file I can think of that is different, and it could in some way interact with wifi.

    Try using a root file explorer and delete /sbin/ftmpower

    It's a stock binary I've been experimenting with while working on the power-off-charging. I forgot to remove it before building. I never got anything out of it during testing, so I kinda doubt its the issue. bit it's worth trying to delete.

    I've still got it on my phone, and after 4 downloads over my phone's wifi, and wiping only cache and dalvik cache, then reflashing the newly downloaded zip, my wifi still connects within 15 seconds of the screen turning on at first boot, and never takes more than 15 seconds to connect when turned on and off. I'm in a room at the opposite end of the house from my router, and it's downstairs, I'm upstairs, and the faux chimney and stairwell are between us as well.

    I'm sorry I can't reproduce the issue you are reporting, I'm definitely trying. If deleting ftmpower doesn't help, and you have issues with wifi, you may want to revert to a previous build.

    I gotta get some sleep!
    01-19-2012 07:36 AM
  10. notown's Avatar
    not sure if something was changed to the Wi-Fi but it does seem longer to connect and not as stable idk
    01-19-2012 07:39 AM
  11. anthonycr's Avatar
    My recovery is clockworkmod 3.0.2.1 and I'm running the latest build by Jerry, and wifi is fine. In fact I'm posting this using wifi. Hope that helps
    JerryScript likes this.
    01-19-2012 07:52 AM
  12. Glenar's Avatar
    My recovery is clockworkmod 3.0.2.1 and I'm running the latest build by Jerry, and wifi is fine. In fact I'm posting this using wifi. Hope that helps
    Ditto on above (except using wifi to post this bit). All works great.
    JerryScript likes this.
    01-19-2012 07:56 AM
  13. notown's Avatar
    yeah Wi-Fi works for me.. just not the same.
    JerryScript likes this.
    01-19-2012 07:59 AM
  14. kwknott's Avatar
    I deleted the /sbin/ftmpower file and still no go on wifi. Didn't have previous build on my sdcard so flashed over to bob's rom just to make sure my phone wasn't going nuts on me and wifi worked fine. Flashed back to backside and issue came back. Other than that everything else is working great. Don't use wifi at work so I'll just wait and flash last build when I get home if I don't get it working. Thanks Jerry for some idea's and for some great Rom's and all the other Dev's too!
    01-19-2012 08:04 AM
  15. a5pe4's Avatar
    Has anyone with the wifi problem flashed back to an older build? If so is your wifi working on that build?
    01-19-2012 09:07 AM
  16. kwknott's Avatar
    Jerry,

    After a few more wipes and reflashes I got my wifi working on your new build. I flashed back to your last build and wifi worked so I fully wiped phone and flashed new build just to check again. No wifi. Fully wiped and flashed back to last build and checked wifi again and it worked. Just for heck of it left wifi on, cleared just cache and dalvik cache and upgraded to new build and wifi continued working. Not sure if it was just coincidence or not but it worked by just upgrading rom instead of full wipe.
    01-19-2012 09:15 AM
  17. JerryScript's Avatar
    Have any of you checked the md5sum of your download to be sure it wasn't corrupt?
    01-19-2012 09:41 AM
  18. kwknott's Avatar
    Have any of you checked the md5sum of your download to be sure it wasn't corrupt?
    yes
    01-19-2012 09:45 AM
  19. JerryScript's Avatar
    Anyone with WiFi issues, please post the recovery you are using
    01-19-2012 09:57 AM
  20. ajones23's Avatar
    I use the IHO 4.0.1.4.3 recovery. Ran a backup,flashed new build over it,now it works. Which recovery do you use.
    01-19-2012 10:53 AM
  21. JerryScript's Avatar
    I of course use the IHO recovery that I recommend in my first post.
    VM670NH_recovery.img
    01-19-2012 11:03 AM
  22. ajones23's Avatar
    Ok, Jerry,from now on i will use it. Because you dont have any problems or issues, Thanks.
    01-19-2012 11:11 AM
  23. ajones23's Avatar
    Oh, just like to say,like the splash screen. Had a flash back with the VM image,as always jerry great work. All my OVs work faster and smoother.
    JerryScript likes this.
    01-19-2012 11:17 AM
  24. norwoodsteel's Avatar
    this may have nothing to do with it but i noticed these type problems back when i used to to do "wipe data/factory reset" with every wipe.
    when i started wiping as Jerry recommended WIFI and other problems seemed to disappear.
    some recoveries will even change your sd/ext [ext2 to ext3] if you use the "wipe data/factory reset"

    my 1-18 build WIFI is rock solid [been on and off for 12 hrs]
    JerryScript likes this.
    01-19-2012 11:33 AM
  25. a5pe4's Avatar
    Seems a bit strange that so many people have had trouble with the Wifi. Mine has been fine using cwmod 3.0.2.4
    01-19-2012 02:03 PM
6,009 ... 154155156157158 ...
LINK TO POST COPIED TO CLIPBOARD