09-22-2015 01:20 PM
6,009 ... 2122232425 ...
tools
  1. Whyzor's Avatar
    For reference, I haven't had any problems with this ROM (except the documented higher GPS battery drain, a reboot fixes that). I'm running without a theme, default ondemand 245-600 CPU. No FCs, wifi issues (tried 2 routers, open & WPA-secured, SSID broadcast & hidden), good battery drain (<1%/hour idle). I turn off all eye candy & fancy CM features, except the notification power widget, percent batt status, & status bar brightness control. Using Zeam launcher (light-weight), installed all apps internally (105 MB free still, so I don't clog up my phone with a lot of crap). I run with BT, wifi, GPS, 3G data all off except when I need them, sync manually.

    Originally coming from stock ROM, I rooted using Gingerbreak 1.20, installed CWM 3.2.0.1 using ROM Manager, then in CWM, factory reset, wiped cache, dalvik-cache 3 times, formated all except /sdcard. Flashed ROM & gapps.zip. Reinstalled all apps from market (didn't restore anything). Reflashed 2 upgraded builds since by just wiping cache & dalvik-cache.

    Here are all the bloatware that are safe to remove from this ROM after flashing as tested by myself.

    rm /system/media/bootanimation.zip
    rm /system/media/audio/ui/camera_click.ogg
    rm /system/app/Androidian.apk
    rm /system/app/Calculator.apk
    rm /system/app/CarHomeGoogle.apk
    rm /system/app/CMStats.apk
    rm /system/app/CMWallpapers.apk
    rm /system/app/Cyanbread.apk
    rm /system/app/DSPManager.apk
    rm /system/app/Email.apk
    rm /system/app/FM.apk
    rm /system/app/GenieWidget.apk
    rm /system/app/Gmail.apk
    rm /system/app/GoogleFeedback.apk
    rm /system/app/GooglePartnerSetup.apk
    rm /system/app/LatinImeTutorial.apk
    rm /system/app/LiveWallpapers.apk
    rm /system/app/LiveWallpapersPicker.apk
    rm /system/app/MagicSmokeWallpapers.apk
    rm /system/app/OneTimeInitializer.apk
    rm /system/app/Protips.apk
    rm /system/app/ThemeChooser.apk
    rm /system/app/ThemeManager.apk
    rm /system/app/Pacman.apk
    rm /system/app/CMUpdateNotify.apk
    rm /system/app/Development.apk
    rm /system/app/VisualizationWallpapers.apk
    08-02-2011 11:31 PM
  2. ravenroost's Avatar
    type "su" first and then the rest


    su
    mount -o remount,rw -t yaffs2 /dev/block/mtdblock5 /system
    cat /sdcard/flash_image > /system/bin/flash_image
    chmod 755 /system/bin/flash_image
    mv /system/etc/install-recovery.sh /system/etc/install-recovery.sh.bak
    mount -o remount,ro -t yaffs2 /dev/block/mtdblock5 /system
    flash_image recovery /sdcard/recovery.img
    I'm still getting error messages, like "cannot create /system/bin/flash_image: read only system" , etc.
    08-02-2011 11:52 PM
  3. JerryScript's Avatar
    I'm still getting error messages, like "cannot create /system/bin/flash_image: read only system" , etc.
    You probably don't have a space in the right place. Replace the following red underlines with spaces (not the black ones!!!):

    su
    mount_-o_remount,rw_-t_yaffs2_/dev/block/mtdblock5_/system
    cat_/sdcard/flash_image_>_/system/bin/flash_image
    chmod_755_/system/bin/flash_image
    mv_/system/etc/install-recovery.sh_/system/etc/install-recovery.sh.bak
    mount_-o_remount,ro_-t_yaffs2_/dev/block/mtdblock5_/system
    flash_image_recovery_/sdcard/recovery.img

    And of course, be sure your recovery is named recovery.img or change the name in the last line of the code.
    ravenroost likes this.
    08-03-2011 12:44 AM
  4. ravenroost's Avatar
    You probably don't have a space in the right place. Replace the following red underlines with spaces (not the black ones!!!):

    su
    mount_-o_remount,rw_-t_yaffs2_/dev/block/mtdblock5_/system
    cat_/sdcard/flash_image_>_/system/bin/flash_image
    chmod_755_/system/bin/flash_image
    mv_/system/etc/install-recovery.sh_/system/etc/install-recovery.sh.bak
    mount_-o_remount,ro_-t_yaffs2_/dev/block/mtdblock5_/system
    flash_image_recovery_/sdcard/recovery.img

    And of course, be sure your recovery is named recovery.img or change the name in the last line of the code.
    I give up. I tried every way possible to flash another recovery. I get errors every time. I am very careful too. There is something on my phone blocking me or something. Thanks for trying to help though. I do appreciate it. And now all of a sudden I can now install your 7/30 rom. I could not do it before with this CWM version. Go figure.
    08-03-2011 01:14 AM
  5. blarf's Avatar
    I give up. I tried every way possible to flash another recovery. I get errors every time. I am very careful too. There is something on my phone blocking me or something. Thanks for trying to help though. I do appreciate it. And now all of a sudden I can now install your 7/30 rom. I could not do it before with this CWM version. Go figure.
    If you're using the other 3.0.2.8, use this one:

    http://forums.androidcentral.com/opt...ml#post1153466
    08-03-2011 01:17 AM
  6. ravenroost's Avatar
    the eaiest way is to flash a recovery... [Tool] Flashable Zip Recoveries - xda-developers
    just flash from the recovery u have now .. no need to wipe.
    I tried this method and it didn't work. But thanks just the same. I really don't know what I am doing wrong that it cannot flash another recovery.
    08-03-2011 01:21 AM
  7. joshgee's Avatar
    I'm gonna try this one out. Thanks for the rom!

    EDIT:

    Holy ****! This ROM is beautiful! The boot animation is sick as ****... totally caught me off guard.
    JerryScript likes this.
    08-03-2011 01:42 AM
  8. JerryScript's Avatar
    I give up. I tried every way possible to flash another recovery. I get errors every time. I am very careful too. There is something on my phone blocking me or something. Thanks for trying to help though. I do appreciate it. And now all of a sudden I can now install your 7/30 rom. I could not do it before with this CWM version. Go figure.
    Once you have the ROM installed, and your phone boots up, you can open Terminal and type the following:

    su
    flash_image recovery /sdcard/NAME_OF_RECOVERY.img
    exit

    Kinda backwards getting the ROM first, but it is called BACKside after all!
    08-03-2011 02:19 AM
  9. cr42ydude's Avatar
    I tried this method and it didn't work. But thanks just the same. I really don't know what I am doing wrong that it cannot flash another recovery.
    are u sure ur rooted? tell me how u rooted your device or do u wanna try and do it all over??? just unroot the device and follow this video really easy .. if u wanna know how to unroot then search the forums.
    08-03-2011 02:33 AM
  10. israelsalinas14's Avatar
    Ok im on froyo right now and want to flash this rom. Which recovery is recommended? The newest clockworkmod or xionia?
    08-03-2011 03:16 AM
  11. asadullah's Avatar
    Ok im on froyo right now and want to flash this rom. Which recovery is recommended? The newest clockworkmod or xionia?
    I use clockworkmod that I got from the app and have only had the problems that are listed on the issue tracker. I also wipe system, dalvik and everything before each install.

    Also tested out bluetooth stereo today in my truck works great.
    08-03-2011 03:31 AM
  12. crpeck's Avatar
    Let me see if this is correct:

    On termnal emulator, when I open it up it says:

    $ export PATH=/data/local/bin.$PATH
    $

    Then should I type the commands?
    mount -o remount,rw -t yaffs2 /dev/block/mtdblock5 /system ENTER
    cat /sdcard/flash_image > /system/bin/flash_image ENTER
    chmod 755 /system/bin/flash_image ENTER
    .... and so forth?
    Am I missing any steps?


    [HL]Note:[/HL] If this is going off topic too much, should I start another thread or go pm route?
    The 'export PATH=/data/local/bin.$PATH' looks incorrect to me. This set's the PATH to /data/local/bin.$PATH (see the '.' before $PATH?). My guess is that it should be:
    export PATH=/data/local/bin:$PATH
    which will prepend /data/local/bin to the current PATH setting. Although I don't know what's put in /data/local/bin that needs to be executed?
    ravenroost likes this.
    08-03-2011 06:13 AM
  13. Eollie's Avatar
    I'm still getting error messages, like "cannot create /system/bin/flash_image: read only system" , etc.
    Im going to hate myself for this, however try this and see if using this tool allows you to get the recovery installed.

    BUT FOR THE LOVE OF GOD READ THE THREAD AND ASK BEFORE YOU JUST JUMP IN WILLY NILLY AND ARE HAVING MORE ISSUES.

    http://forums.androidcentral.com/opt...-features.html
    08-03-2011 06:59 AM
  14. rockneo's Avatar
    I may or may not need a reflash but the new market force closes

    Sent from my Optimus V
    08-03-2011 09:45 AM
  15. itsrayray's Avatar
    i havent had any problems other than the random facebook app stuff. all other works great so far.
    wifi works just amazing. all games/apps i have tried work perfect.
    email app sometimes cant find net connection but a simple refresh will solve it.

    i have it overclocked at

    100% to 30% bat - 787 max 245 min
    30% to 15% bat - 600 max 122 min
    15% to dead bat - 480 max 122 min

    screen off - 320 max 122 min
    charging 600 max 122 min
    temp up to 43c (as this is the most i saw my stock phone go) - 480max 122min

    so far everything works verrry fast, and everything i have tried on it works.
    i havent had the problems everyone else has had, maybe i'm lucky, orrrr it's not my time yet. lol.
    08-03-2011 10:21 AM
  16. rockneo's Avatar
    i havent had any problems other than the random facebook app stuff. all other works great so far.
    wifi works just amazing. all games/apps i have tried work perfect.
    email app sometimes cant find net connection but a simple refresh will solve it.

    i have it overclocked at

    100% to 30% bat - 787 max 245 min
    30% to 15% bat - 600 max 122 min
    15% to dead bat - 480 max 122 min

    screen off - 320 max 122 min
    charging 600 max 122 min
    temp up to 43c (as this is the most i saw my stock phone go) - 480max 122min

    so far everything works verrry fast, and everything i have tried on it works.
    i havent had the problems everyone else has had, maybe i'm lucky, orrrr it's not my time yet. lol.
    Just so you know underclocking past 480 kills your battery more so you're doing more harm then good

    Sent from my Optimus V
    08-03-2011 10:55 AM
  17. itsrayray's Avatar
    Just so you know underclocking past 480 kills your battery more so you're doing more harm then good

    Sent from my Optimus V
    so with screen off i should place it up to 480 right? i went to sleep around 12ish woke up 10 and it used around 7% normally it would pull close to 20% if not more overnight.
    08-03-2011 11:01 AM
  18. rockneo's Avatar
    so with screen off i should place it up to 480 right? i went to sleep around 12ish woke up 10 and it used around 7% normally it would pull close to 20% if not more overnight.
    Yes 480, 122 makes the phone work harder

    Sent from my Optimus V
    08-03-2011 12:05 PM
  19. Eollie's Avatar
    so with screen off i should place it up to 480 right? i went to sleep around 12ish woke up 10 and it used around 7% normally it would pull close to 20% if not more overnight.
    mmarz did a comparison and found the Optimus phones work better clocked no lower then 480. Being as our processor is kinda old and not super duper it requires a bit more to not act like a 18 wheeler climbing the rockies when coming out of sleep.
    arhtard likes this.
    08-03-2011 12:10 PM
  20. itsrayray's Avatar
    it requires a bit more to not act like a 18 wheeler climbing the rockies when coming out of sleep.
    Hahaha. Ok thanx guys!


    Sent from my LG-VM670 using Tapatalk
    08-03-2011 12:14 PM
  21. ravenroost's Avatar
    The 'export PATH=/data/local/bin.$PATH' looks incorrect to me. This set's the PATH to /data/local/bin.$PATH (see the '.' before $PATH?). My guess is that it should be:
    export PATH=/data/local/bin:$PATH
    which will prepend /data/local/bin to the current PATH setting. Although I don't know what's put in /data/local/bin that needs to be executed?
    Thanks to everyone that tried to help me last night. After sleeping on it, this morning I decided to unroot my phone and start back at square one.

    I downloaded all new files and put them in a folder. And it worked. I can now finally flash other recoveries - current have RA=thunderc-1.1.0-GNM - the same one xda-developers had on the site I used as reference.

    I used this as a reference:
    HOW TO: Root Optimus V (Virgin Mobile) - xda-developers

    Again. Thanks to all for your patience and help. I made need it again.
    08-03-2011 12:32 PM
  22. joshgee's Avatar
    I really love this ROM. Any idea on a fix for GrooVe IP?
    08-03-2011 12:37 PM
  23. yogi4's Avatar
    I just donated. JerryScript... see Blarf for your beer.
    08-03-2011 12:56 PM
  24. justinh's Avatar
    jerry just a quick note on bugs..i dont know if this has been a problem or reported or not..but i just flashed your newest build and wiped cache multiple times and i cant receive or send both pictures or video..i installed kemikalette's package and everything works fine
    JerryScript likes this.
    08-03-2011 01:20 PM
  25. mrg666's Avatar
    Thank you all. I just installed BACKside IHO and completed reconfiguration. It is working great, very professional work. It is not much but enjoy your beers!
    08-03-2011 01:23 PM
6,009 ... 2122232425 ...
LINK TO POST COPIED TO CLIPBOARD