02-02-2017 06:54 AM
266 ... 45678 ...
tools
  1. bigsupersquid's Avatar
    on the mac, in your terminal, if you type
    ls
    does it list adb?
    and, if the camera button reboots while you're in recovery, the recovery is working, just can't display on screen.
    10-18-2011 12:19 PM
  2. rannug's Avatar
    no this is what came up.


    Last login: Tue Oct 18 12:57:33 on ttys000
    host-173-230-5-59:~ feldhckygurl$ ls
    Desktop Library Music Sites
    Documents License.pdf Pictures hwuuid.txt
    Downloads Movies Public results.html
    host-173-230-5-59:~ feldhckygurl$

















    im assuming i need to move something somewhere?
    10-18-2011 12:28 PM
  3. bigsupersquid's Avatar
    you need to
    cd <path>
    to whereever adb is located on your Mac, replace <path> with the actual path.
    I don't have a working mac to walk through this on, so you'll need patience.
    maybe you can open the terminal right in the platform-tools folder, that's easier than finding and typing the path if you can open terminal in the right spot.
    edit;
    you could also copy adb to ~ feldhckygurl and run it from there, if it doesn't need other files to run.
    10-18-2011 12:35 PM
  4. 613M0's Avatar
    Hello I'm having problems flashing roms, anybody who can help I rooted my LG optimus V with Gingerbreak but every time I either try to flash a diff. ROM or do a nandroid backup on ROM Manager it shows a "bricked screen" but when I take the battery out & restart the phone it goes back to normal (obviously still rooted). I've tried flashing many diff ROM's and nothing or repetition of ^^^^. On top of that I can't even change the boot animation with root apps that claim to do such things (ROM Toolbox by Jrummy16) amongst other dev's. So yeah anybody have an Idea why? or what can I do to fix this? I'm not so tech savvy so if possible chronological order fixes would be helpful. If you need specific info like (I'm guessing: script, file info, etc) email and I'll respond thanks.
    10-19-2011 05:30 PM
  5. rannug's Avatar
    okay i got my hands on an sd card reader, and i put the recovery on there but its still blank. is there a specific recovery? i removed the rom but it still wont work just boot loop
    10-20-2011 01:12 PM
  6. bigsupersquid's Avatar
    okay i got my hands on an sd card reader, and i put the recovery on there but its still blank. is there a specific recovery? i removed the rom but it still wont work just boot loop
    you can use any recovery from the first post.
    Which one depends on which ROM you want to install.
    Use the newest IHO recovery for an IHO ROM, maybe use Xionia if you're interested in installing older ROMs like maybe Bumblebee with Picasticks kernel flashed over it...
    When you say put the recovery on there, you mean the card, or successfully flashed it into the phone with adb?
    Did you get ADB working in the terminal? You'll need it.
    Sorry about the delay, family tends to be a bit distracting.
    10-24-2011 04:14 PM
  7. BLoux89's Avatar
    omg this is all foreign language to me. is there any way you can put this into lamens terms for me so i can follow the necessary steps to be able to use my phone again??
    10-25-2011 02:54 PM
  8. bigsupersquid's Avatar
    sorry, can't simplify it much. it'd take a while to chop it down further.
    you still have a working rom or are you just lg logo and black screen? with a working rom you can use terminal emulator to flash a recovery from the first post. relatively easy.
    if your rom and recovery are both blacked out you'll have to use adb or android screencast to reflash the recovery. not as easy.
    10-25-2011 03:14 PM
  9. BLoux89's Avatar
    i dont believe any roms are working at this point. i was going to update to Android 2.3.4 and i installed the 'gapps' rom first. then i went to restore my phone to factory default settings and it rebooted, went black, and stayed black. i dont know how to get into recovery mode, i cant sync the SD card to my computer from my phone (need the micro SD adapter), and the screen wont go past the LG logo.

    do you have AIM so we could chat for a couple mins? if so PM me your username?
    10-25-2011 03:22 PM
  10. bigsupersquid's Avatar
    if you did the factory reset, you'll have to use adb through the cable to fix it.
    I don't IM on any channels, not even irc, I'm afraid. No remote desktops either.
    Best I can offer is a pointer to the instructions or a direct quote from them:
    Have you accidentally caused your phone to go into an infinite boot loop into your recovery using LG's factory reset?
    This should fix it.
    try these commands with adb:

    Code:
    adb shell strings /dev/mtd/mtd8
    adb shell flash_eraseall /dev/mtd/mtd8
    If nothing I said makes sense, read through this guide to learn about adb (through the root guide) and flashing recoveries.
    if you get that accomplished, you'll need to install the xionia recovery from the first post through adb, and then you'll be well on your way to a working phone.
    10-25-2011 03:45 PM
  11. BLoux89's Avatar
    well the data cable that connects via USB is not an option bc its not being read as an attached device by my computer. i have sdk and am TRYING to go abouts getting ADB but im running in circles. this is frustrating :-(
    10-25-2011 03:56 PM
  12. bigsupersquid's Avatar
    you're probably using m$ windoze, then?
    it's known to have issues with the drivers for the OV. I've had different pc's with windoze just stop recognizing my ov when it hadn't been attached for a while.
    try uninstalling the lg drivers in device manager (you'll have to show nonpresent devices if nothing lg is visible) or 'add remove programs' maybe.
    after that, unplug the phone and then reinstall the lg drivers, then try again.
    10-25-2011 04:06 PM
  13. BLoux89's Avatar
    well i went to my device manager and looked at every single driver and there's NO LG drivers in there at all, even after checking the option to show nonpresent devices. i dont believe its windows thats at fault here. i hear the notification when the device is plugged in via USB, but it makes a different sound than normal now. just a couple hours ago i was using it fine. i have no idea what to do here
    10-25-2011 04:31 PM
  14. bigsupersquid's Avatar
    if it's making a connection noise, it should show up as something in device manager. probably mass storage, if you don't see lg devices.
    try plugging it in with device manager open and see what pops up.
    if you can't find a device to remove, unplug the phone, and go to control panel>add and remove programs and try to uninstall the lg drivers from there.
    if you can't find it there either, try reinstalling the lg drivers without removing anything. then plug in the phone and see if it's recognized.
    10-25-2011 04:50 PM
  15. BLoux89's Avatar
    wow it worked... what do i do from here?
    10-25-2011 05:06 PM
  16. BLoux89's Avatar
    every drivers installed successfully except "LGE Android Platform USB Modem"... that one failed. :-/
    KijoShuuen likes this.
    10-25-2011 05:20 PM
  17. bigsupersquid's Avatar
    maybe unplug and replug your phone to see if it catches the driver it missed.
    what it really needs is the android debug bridge driver (adb) and it probably got that.
    try opening a command line shell at the platform-tools folder of your android sdk so you can use adb.
    then, copy a recovery.img to that folder... currently I'd advise the xionia recovery since you got bootlooped.
    you can then type the following in the command line:
    Code:
    adb shell strings /dev/mtd/mtd8
    adb shell flash_eraseall /dev/mtd/mtd8
    adb reboot recovery
    let it reboot, then try to install the xionia recovery with the following:
    Code:
    adb shell mount /dev/block/mmcblk0p1 /sdcard
    adb push xionia_cwma_125186.img /sdcard/
    adb shell
    flash_image recovery /sdcard/xionia_cwma_125186.img
    exit
    if you don't get any errors, then type
    Code:
    adb reboot recovery
    and you should be able to flash a newer rom through the recovery like normal, without needing to mess with adb after that.
    10-25-2011 05:41 PM
  18. BLoux89's Avatar
    is there any way to install ADB without using an android device? im still at a huge crossroads here...
    10-25-2011 05:43 PM
  19. bigsupersquid's Avatar
    if you mean do you have to use the sdk... not if you google up a standalone adb zip file compilation, but you said earlier you had the sdk, so it's easiest to use that.
    you need to open a MS-DOS prompt to use adb, and it needs the directory changed to the sdk's platform-tools folder to run it, unless you know how to set your PATH variable to add the platform-tools folder to the system path. adb's not an installable, just a file to run.
    10-25-2011 05:48 PM
  20. BLoux89's Avatar
    what is a command line shell? currently i just installed the sdk platform tools and google usb driver package (revision 4) through SDK. i dont know what to do from here...
    10-25-2011 05:49 PM
  21. BLoux89's Avatar
    i already have sdk on here and i changed the path to the directory of the sdk folder as well. i tried to insert a couple commands on the command prompt earlier and it said 'device not found'
    10-25-2011 05:51 PM
  22. bigsupersquid's Avatar
    under start menu>accessories>system tools>ms-dos prompt.
    you then have to type
    Code:
    cd \path\to\sdk\platform-tools
    where \path\to\sdk\platform-tools is what shows up in the address bar of windows explorer when you open the sdk's platform-tools folder in explorer.
    after that, copy the recovery to that folder, and use the adb commands I listed a few posts back.
    10-25-2011 05:52 PM
  23. bigsupersquid's Avatar
    i already have sdk on here and i changed the path to the directory of the sdk folder as well. i tried to insert a couple commands on the command prompt earlier and it said 'device not found'
    ugh, device not found means adb isn't seeing the phone.
    try rebooting the computer, then plugging in the phone again, and try adb again after that.
    10-25-2011 05:53 PM
  24. BLoux89's Avatar
    im trying and it doesnt seem to be working... the drivers are all there so idk wtf the problem is
    10-25-2011 06:22 PM
  25. BLoux89's Avatar
    and also ive tried all of those command prompts youve given me and its still not working. every other command i type in gives me an error. the only things that shows a noticable reaction is when i do the reboot recovery... the phone restarts, shows the LG logo, then goes blank again.

    does ANYONE else have any input so this poor guy doesnt have to be the only one with this burden on his shoulders?
    10-25-2011 06:32 PM
266 ... 45678 ...
LINK TO POST COPIED TO CLIPBOARD