1. demoport's Avatar
    The auto-rotating of the screen is very slow when the phone is on for a while, but when the phone is restarted it works perfectly fine. I also noticed that games that depend on the accelerometer act very sluggishly when the phone is on for a while, but works perfectly smooth and fine when the phone is restarted. Is there anyway to fix this issue?

    PS I am not overclocking, I tried overclocking and that doesnt help so i went back to the normal settings, using IHO CM7, I also tried different roms/kernels and it didn't help.
    09-25-2011 03:12 AM
  2. watskyhotsky's Avatar
    its a bug with the rom, so far nothing we can do will fix it.

    however, I toggle rotation on and off and it helps "reset" it somehow. not sure, but it helps it work.

    you can overclock, it really helps overall in everything you do in the rom, as long as your min is 480 and max is between 750 and 806. its a noticable boost in everything you do on the phone
    09-25-2011 05:06 AM
  3. demoport's Avatar
    Solved! There is something about both ADW Launcher and LauncherPro that affect the accelerometer on the LG Optimus V so, I installed Go Launcher EX from the market, Uninstalled LauncherPro using Titanium Backup, and restarted the phone. Ever since then the auto-rotation problem is gone and my accelerometer games like Doodle Jump have been running smoothly ever since.

    I remembered last night that on the stock firmware before I rooted the phone, this problem never existed. So, after many Rom/Kernel installs and overclocking tweaks and software installations, I realized its not a Rom/Kernel problem or a hardware problem, it was the Launcher used by the custom rom.

    So, in conclusion, replace your LauncherPro or ADW Launcher with Go Launcher EX and you will see a huge difference in performance and no more sluggish auto-rotation.

    Right now I am using CM7 IHO by BobZhome (Gingerbread) Build 09192011 with the Go Launcher EX with the Honeycomb theme and this problem completely disappeared.

    Hope you guys find this helpful! This problem irritated me for the longest time.
    09-25-2011 10:45 AM
  4. cole2kb's Avatar
    I use Go Launcher EX and still have the slow rotation problem. I'm on the BACKside IHO though.
    09-25-2011 06:04 PM
  5. Ticojpunk's Avatar
    I'm pretty sure the ONLY fix for this is rebooting once a day or so. Anything else is coincidence or in some cases, placebo.

    Sent via VM670
    09-25-2011 06:25 PM
  6. JerryScript's Avatar
    I use Go Launcher EX and still have the slow rotation problem. I'm on the BACKside IHO though.
    Did you uninstall ADW like the poster mentioned? Just curious if this is a working fix.
    09-25-2011 09:22 PM
  7. watskyhotsky's Avatar
    I am using go launcher and its the same exact problem. its not solved at all.

    nothing else installed either.

    you sure your not seeing a placebo effect? some dev, SOMEWHERE would have figured out it was launcher pro or ADW while developing these GB roms.
    09-25-2011 09:36 PM
  8. economichitman's Avatar
    I installed go launcher, uninstalled adw through titanium backup and rebooted. The difference is obvious. Running backside iho 9/19 build. Its not a placebo effect, because even after a fresh reboot this rom had sluggish rotation across all apps.
    09-25-2011 09:42 PM
  9. LeslieAnn's Avatar
    Just changing launchers may be resetting the accelerometer.
    Change back and see if it's suddenly fixed" or give it a few days.

    I'm betting it's just refreshing whatever is the cause.
    09-25-2011 11:24 PM
  10. watskyhotsky's Avatar
    I installed go launcher, uninstalled adw through titanium backup and rebooted. The difference is obvious. Running backside iho 9/19 build. Its not a placebo effect, because even after a fresh reboot this rom had sluggish rotation across all apps.
    im running the SAME rom and my rotation is fast with launcher pro until my phones been on longer than 24 hours. thats when it starts slowing.
    09-25-2011 11:32 PM
  11. economichitman's Avatar
    im running the SAME rom and my rotation is fast with launcher pro until my phones been on longer than 24 hours. thats when it starts slowing.
    On older iho builds I would experience that, but with the 9/19 build its constant from fresh install. Its probably the first thing I noticed, after using bumblebee for a while.

    Did you do a full wipe and then install the 9/19, or upgrade?

    Bobzhome said he was going to integrate a fix for the accelerometer into his next build, idk if he did because kernel.org is still down.

    http://forums.androidcentral.com/opt...ml#post1232653
    09-26-2011 12:14 AM
  12. watskyhotsky's Avatar
    On older iho builds I would experience that, but with the 9/19 build its constant from fresh install. Its probably the first thing I noticed, after using bumblebee for a while.

    Did you do a full wipe and then install the 9/19, or upgrade?

    Bobzhome said he was going to integrate a fix for the accelerometer into his next build, idk if he did because kernel.org is still down.

    http://forums.androidcentral.com/opt...ml#post1232653
    i never upgrade. always full wipe and install.
    09-26-2011 03:11 PM
  13. cole2kb's Avatar
    I did remove ADW and still have the slow rotation a day later. Oh well. Minor annoyance.
    09-26-2011 03:55 PM
  14. demoport's Avatar
    I've been using Go Launcher EX with BobZhome's current build 092611 and the accelerometer hasn't slowed down since then. You guys should give this another try. In the changelog for the 09/26 build there is an accelerometer improvement and its very noticeable.
    09-28-2011 08:45 AM
  15. clodfelterac's Avatar
    sooooo, a reboot-a-day keeps the slo-ro's away eh?... lol
    03-16-2012 04:33 AM
  16. EarthnFire78's Avatar
    One of the things I noticed about Launchers is if it set to rotates then it slows things down. I use the Zeam Launcher, and it is not set to rotate and I have no problems with games or apps that rotate; but the Launcher its self does not.
    03-16-2012 10:32 AM
  17. Liquidplacidity's Avatar
    In case anyone is wondering, there's a memory leak in CM7 that causes the ROM to slow down over time. The reason rebooting fixes it is because it resets it and changing launchers also resets it. It's an error in the CM7 code so it's across all ROM's that use CM7 source. I have the the Motorola Triumph with CM7 and I always experience the same thing. It's just something the devs never worked out. I guess they're too busy with CM9 to even bother looking for it? I'm not sure why it hasn't fixed yet, but nobody has been able to find out where it's coming from.
    03-19-2012 03:22 PM
  18. Tejer's Avatar
    In case anyone is wondering, there's a memory leak in CM7 that causes the ROM to slow down over time. The reason rebooting fixes it is because it resets it and changing launchers also resets it. It's an error in the CM7 code so it's across all ROM's that use CM7 source. I have the the Motorola Triumph with CM7 and I always experience the same thing. It's just something the devs never worked out. I guess they're too busy with CM9 to even bother looking for it? I'm not sure why it hasn't fixed yet, but nobody has been able to find out where it's coming from.
    Just curious, where did you get that information from? I havent heard that from any of the devs that build the ROMS or from CM7.
    03-19-2012 03:42 PM
  19. flapjack.fiasco's Avatar
    Yeah, that seems a bit too speculative. If it's happening as frequently as it seems to be, a memory leak would have been tracked down by now.

    Sent from my LG-VM670 using Tapatalk
    03-19-2012 06:50 PM
LINK TO POST COPIED TO CLIPBOARD