03-01-2012 09:14 AM
339 ... 121314
tools
  1. thekraven's Avatar
    02-24-2012 06:38 PM
  2. JerryScript's Avatar
    Got MMS working!

    Changes:

    packages/apps/Mms/src/com/android/mms/transaction/Transaction.java
    (used tdm's changes posted in his alpha thread, thanks tdm!)

    packages/apps/Telephony/cdma/CdmaSMSDispatcher.java
    (replace with mantera's crib of IHO, I replaced the file rather than pull in the changes)

    packages/apps/Mms/res/xml/mms_config.xml
    (edit to reflect IHO's device folder copy, but don't use the IHO copy, it gives a start tag error when I tried)

    apns-conf.xml change Virgin Mobile US mcc=311 and mnc=490
    (same as in IHO's, I thought it was pulled into CM, but I guess it didn't make it into CM9)

    The issue is getting these changes to stick. The current build setup doesn't always take changes from the device and vendor folders. I'm having to make the changes directly to the trees. This has been true so far for changes to languages, locations, and now mms_config.xml. Going to have to do some investigating.

    Edit: I am still have issues most of the time, but I'm pretty sure it's 3g related.
    cmerlyn, bdfull3r, Jsadik and 3 others like this.
    02-25-2012 05:14 AM
  3. JerryScript's Avatar
    Offline-charging works on ICS!

    tdm's check for last_ksmg to enable offline-charging appears to work with only slight modification for ICS. The new init.c uses a different variable type for battchg_pause, and it sets a new "charger" tail, so the last_kmsg check needs to be modified appropriately.

    Rather than muck with the existing init.c code, I added a new variable for our device named thunderc_reboot. I set it with the same last_kmsg code block we use for gb, and I check it beside the existing battchg_pause checks, one to skip loading the file system, the other to set the charger tail. I'm not sure if it would just be better to change the battchg_pause value?

    I did switch to the VM670 chargerlogo binary and images as well.

    Thanks again tdm now I can charge at nite after testing my latest ics builds without having to worry about flashing back to gb in case of crashes during charging!

    Edit: Tested the following-
    Plugged In
    power off = offline charging
    reboot = reboot
    reboot recovery = reboot recovery
    reboot from recovery = reboot to offline-charging (buggy, but acceptable)
    crash = reboot

    Not plugged in
    power off = power off
    reboot = reboot
    reboot recovery = reboot recovery
    crash = reboot

    Powered off press power button, boots up
    Powered off, plug in, boots to offline-charging
    Offline-charging, long press power button, boots up

    Crash tested by overclocking to max.
    02-27-2012 10:21 AM
  4. drewwalton19216801's Avatar
    Nice one Jerry!
    Jsadik, notown and JerryScript like this.
    02-27-2012 12:36 PM
  5. theexile1's Avatar
    has any one finished a kernal for our v???
    02-28-2012 12:36 PM
  6. mjs2011's Avatar
    has any one finished a kernal for our v???
    If they had, don't you think they would have said something already?

    Sent from my VM670 using Tapatalk
    02-28-2012 12:39 PM
  7. theexile1's Avatar
    idk maby they were waiting it was just a question lol
    02-28-2012 12:41 PM
  8. rukin5197's Avatar
    I don't want to sound dumb here but is there a .35 kernel in these forums? I need it to get Sense booted on our phones and I just can't find one..
    02-28-2012 07:46 PM
  9. JerryScript's Avatar
    We have always used the Froyo kernel, even with Gingerbread on IHO.

    I'm pretty sure tdm is going to have a new kernel ready next week.
    02-29-2012 12:36 AM
  10. drezliok's Avatar
    We have always used the Froyo kernel, even with Gingerbread on IHO.

    I'm pretty sure tdm is going to have a new kernel ready next week.
    With a proper kernel and such large developer push ICS could be better than the current IHO.

    I am so happy I got this phone over the Sanyo incognito I almost bought a month before the V was out.
    02-29-2012 12:53 AM
  11. rukin5197's Avatar
    Anybody know the base address of the Optimus V? Messing with the kernel... lol
    edit: nevermind, found it
    02-29-2012 08:51 PM
  12. JerryScript's Avatar
    Was busy with Gingerbread the past couple of days, but I did manage to get adb and voice commands working. Was mainly a matter of filling out the missing parts to init.thunderc.rc and init.rc (thanks for the pointers thekraven, but please clean up those commits, sheesh ).

    Now that I have adb, things should be a lot easier to debug.

    Anyone tried Bob's new kernel yet? I'm going to test it tomorrow, will report issues/bugs here.

    BTW- did I mention THANK YOU LESLIEANN FOR ALLOWING ME TO USE YOUR BUILD SERVER!!!
    03-01-2012 06:04 AM
  13. sellers86's Avatar
    Was busy with Gingerbread the past couple of days, but I did manage to get adb and voice commands working. Was mainly a matter of filling out the missing parts to init.thunderc.rc and init.rc (thanks for the pointers thekraven, but please clean up those commits, sheesh ).

    Now that I have adb, things should be a lot easier to debug.

    Anyone tried Bob's new kernel yet? I'm going to test it tomorrow, will report issues/bugs here.

    BTW- did I mention THANK YOU LESLIEANN FOR ALLOWING ME TO USE YOUR BUILD SERVER!!!
    Bob has a new kernal? Is it froyo or ics? Ill check it out
    03-01-2012 07:42 AM
  14. thekraven's Avatar
    I fixed the wifi signal bars, now it shows blue.

    Starts with the wpa_supplicant v8 changes here for the wifi bits in the BoardConfig.mk
    https://github.com/thekraven/android...65943d97b77878


    Here are the changes to wpa_supplicant v6 and wlan0 changes.

    https://github.com/thekraven/android...bdd680cf0722e8

    Code:
    -WPA_SUPPLICANT_VERSION := VER_0_5_X
    +WPA_SUPPLICANT_VERSION := VER_0_6_X
    +#next line only needed for v_0_8_X
    +#BOARD_WPA_SUPPLICANT_PRIVATE_LIB := lib_driver_cmd_wext
    WIFI_DRIVER_MODULE_PATH := "/system/lib/modules/wireless.ko" 
    -WIFI_DRIVER_MODULE_ARG := "firmware_path=/system/etc/wl/rtecdc.bin 
    nvram_path=/system/etc/wl/nvram.txt" 
    -WIFI_DRIVER_MODULE_NAME := wireless 
    -WIFI_DRIVER_FW_STA_PATH := "/system/etc/wl/rtecdc.bin" 
    -WIFI_DRIVER_FW_AP_PATH := "/system/etc/wl/rtecdc_apsta.bin" 
    +WIFI_DRIVER_MODULE_ARG := "iface_name=wlan 
    firmware_path=/system/etc/wl/rtecdc.bin nvram_path=/system/etc/wl/nvram.txt" 
    +WIFI_DRIVER_MODULE_NAME := "wireless" 
    +WIFI_DRIVER_FW_PATH_STA := "/system/etc/wl/rtecdc.bin" 
    +WIFI_DRIVER_FW_PATH_AP := "/system/etc/wl/rtecdc_apsta.bin" 
    WIFI_DRIVER_HAS_LGE_SOFTAP:=true
    03-01-2012 09:14 AM
339 ... 121314
LINK TO POST COPIED TO CLIPBOARD