1. I3ig Al's Avatar
    So I did Gingerbreak on a stock OV, then installed Ti Backup Pro and proceeded to start removing the bloatware on the Stock ROM so I would have a cleaned up nandroid to fall back on. Poking around the options I found this thing that would integrate the dalvik cache files of system apps with the ROM. I did it just to see.... it didn't seem to make any difference so I tried to revert it. Ti Backup said it was going to reboot the phone and now it just hangs at the silver Android boot animation.

    I tried to do a factory reset to fix it but that did nothing, and I fear made things worse. When I try to pass ADB Shell while in recovery I get the error "- exec '/system/bin/sh' failed: No such file or directory (2) -"

    I have attempted Fastboot type things but either its not working or I don't know how to do it. Fastboot Devices does nothing.

    I don't have a custom recovery installed, I can't get it to boot and I can't get ADB shell. I really hope I am not screwed but I don't know what to try next.

    Anyone got a suggestion?
    01-30-2012 08:13 PM
  2. anthonycr's Avatar
    How did you factory reset the phone when you don't have a recovery and couldn't boot past the logo?

    [Edit] Btw, thank you for providing a lot of information and not just saying "I think its broken." That makes it easier for people to figure out the solution. Also it says in your profile that you are using harmonia 2.03..... but you say you don't have a recovery, I'm assuming you meant to flash harmonia as soon as you could?

    This happened to me in the summer, but I had a recovery installed and resetting it in recovery fixed everything. But you don't have recovery...
    01-30-2012 08:40 PM
  3. thdrake56's Avatar
    I had the same exact thing happen to me, the only thing that worked was Fastboot, eventually
    01-30-2012 08:48 PM
  4. I3ig Al's Avatar
    thanks for the quick response guys.

    I do have Harmonia 2.03 on a different phone, this is a new one I was trying to setup. I do have a recovery installed, the stock recovery that comes with the phone. unfortunately I made the mistake of messing with System files before installing the IHO recovery.

    I did a factory reset with the stock recovery.


    I have found that if I leave the phone looping the silver Android logo and then attempt ADB, I can get shell but I am blocked at su.

    here is the log from a fresh prompt:

    Code:
    C:\Program Files\Android\android-sdk\platform-tools>adb devices
    List of devices attached
    A10000199E1752  device
    
    
    C:\Program Files\Android\android-sdk\platform-tools>adb shell
    $ su
    su
    [1]   Segmentation fault      su
    $ su
    su
    [1] + Stopped (signal)        su
    $ su
    su
    [2]   Segmentation fault      su
    [1]   Segmentation fault      su
    $
    I am still not exactly sure how Fastboot works, but I do see a fastboot.exe in the SDK folder.

    [Guide][TOOL] How to root fastboot style. Fastest easiest way around - Android Forums

    I read over this thread on AndroidForums, and it says that USB Debugging must be enabled. I factory reset so I'm sure its disabled and I can't get back in to enable it....
    01-30-2012 09:03 PM
LINK TO POST COPIED TO CLIPBOARD