03-30-2012 07:25 AM
91 1234
tools
  1. tdm's Avatar
    Since there is now root to the Virgin Moblie Update I decided to install it to see if I could regain my data. After installing it I still do not have data and my SW Version is LS670ZV8??? Does anyone have any other ideas, or should I just bite the bullet and by an new phone?
    Can't you just install the new vM radio over the Sprint one now? Using Bobs recovery this time of course...
    03-25-2012 12:08 PM
  2. Dannemand's Avatar
    I agree, but I would have thought after installing the virgin update it would have fixed that
    I'm confused: are you talking about the security patch for our phones or something related to the boys and girls and babies discussion ;-)
    LeslieAnn and tdm like this.
    03-25-2012 03:04 PM
  3. grnsnake's Avatar
    Can't you just install the new vM radio over the Sprint one now? Using Bobs recovery this time of course...
    After using KDZ and the ZV8 cab file that asdullah suggested, the first thing that I did was try to install the VM radio via Bob's recovery, but it did not take. I then called VM and had them reset my data, but that did not work. When Jerry got the VM update rooted I installed the update via Bob's recovery and all of the update was installed except the radio portion???? Is there any way someone could pull the radio into a cab file that I could use KDZ to install like the file I used to get my phone from being a paper weight? That is the only thing that I can think of at this time to get my phone back. I also know people have used some method to bring phones from other carriers to VM, but I do not know how that works.
    03-25-2012 06:33 PM
  4. grnsnake's Avatar
    I'm confused: are you talking about the security patch for our phones or something related to the boys and girls and babies discussion ;-)
    I think a Virgin update is a little late for the ones on the baby discussion
    Dannemand likes this.
    03-25-2012 06:46 PM
  5. emmanuelmac's Avatar
    After using touch recovery to install the updated radio and bricking my phone, I was able to get it back to operating with the help of asadullah. The only thing that I am missing now is mobile data. I can cut it on, but I never get the 3G symbol and in phone status it says connecting for a while then disconnected. I have tried installing Harmonia and using the activate.apk, but it does not help. I am currently running IHO Backside with Bob's recovery. Any help would be appreciated.
    How did you unbrick... I tried all kinds of key combination LG Optimus V Tips & Tricks Button Combos - LG Cell Phones Blog None of them work... My phone's battery is dead and I can't charge.
    03-25-2012 07:03 PM
  6. grnsnake's Avatar
    It has been a couple of days, but I believe the combination of holding the volume down, camera button, and the search button then plugging in the usb is what got me to the point of being able to communicate with the phone through KDZ. I then used KDZ to install firmware that allowed me to boot my phone. I then rerooted, installed a custom recovery and IHO.
    03-25-2012 07:19 PM
  7. emmanuelmac's Avatar
    It has been a couple of days, but I believe the combination of holding the volume down, camera button, and the search button then plugging in the usb is what got me to the point of being able to communicate with the phone through KDZ. I then used KDZ to install firmware that allowed me to boot my phone. I then rerooted, installed a custom recovery and IHO.

    What firmware version did you use. I have used VM670ZV9_02.S9_02.P61007.cab and VM670ZV5_07.S5_07.P61007.cab changed . cab to .kdz but both say

    22:53:16 : Launching SW update
    22:53:16 : Unpacking KDZ
    22:53:18 : KDZ file extraced
    22:53:18 : Extract file error
    22:53:20 : ===FINISHED===
    03-25-2012 10:54 PM
  8. grnsnake's Avatar
    I used ZV8 from a link asdullah gave on either page 15 or 16 on the original VM radio post. After downloading the cab file I renamed it .kdz. I ran KDZ and it created a cab file of the same name and gave me the extract error that you are getting. I then deleted the .kdz file then renamed the .cab file back to .kdz. Confused yet? That is the only way that I could get it to work. Hopefully you have read through this thread and realize that even if you unbrick your phone, it is still not going to be back to normal. Hopefully we(meaning someone on this board smarter than I) will get this corrected soon. If not it will be off to Target to get a new phone.
    03-25-2012 11:03 PM
  9. tdm's Avatar
    I used ZV8 from a link asdullah gave on either page 15 or 16 on the original VM radio post. After downloading the cab file I renamed it .kdz. I ran KDZ and it created a cab file of the same name and gave me the extract error that you are getting. I then deleted the .kdz file then renamed the .cab file back to .kdz. Confused yet? That is the only way that I could get it to work. Hopefully you have read through this thread and realize that even if you unbrick your phone, it is still not going to be back to normal. Hopefully we(meaning someone on this board smarter than I) will get this corrected soon. If not it will be off to Target to get a new phone.
    You've come so far, it's a shame to toss the phone for lack of a native VM radio. But it's always a personal choice how much your time is worth.

    If you do give up on this one and get a new one, I'm sure myself or one of the other IHO devs would love to get a chance to revive it.

    I'm not going to play with radios on my phone because I use it for developing ROMs. But I'd really like to have a spare so I could test things like this without fear of losing anything.
    03-25-2012 11:46 PM
  10. SgtPropain's Avatar
    Ok, from what I have gathered is that you have your recovery and rom installed; everything works but data. Your hardware didnt change, nor did the software. The only thing that changed was the driver for the radio. I had this issue before, installed a new rom boom no radio. My issue was caused by a corrupted prl file. Every time I reboot my selected network would default to "Unknown" or "GSM CDMA Only". In order to get data..I think I'm right with this, you must be connecting to a CDMA/Evo/PCS tower. I went into *#*#4636#*#* and changed it to CDMA auto PRL; rebooted into recovery, QPST a fresh prl & reboot, walla I had data again.

    This might be a totally different issue, but I hope it helps you or at least someone.
    03-26-2012 12:00 AM
  11. Liimon's Avatar
    Grnsnake I am in exactly the same situation as you. I was able to restore everything but the VM radio. I hope someone comes up with a solution. Everything is working except Data service. To the previous poster: I updated my PRL to a new one but I still can't get a data connection. Thanks for the suggestion though.
    03-26-2012 10:53 AM
  12. tdm's Avatar
    After using KDZ and the ZV8 cab file that asdullah suggested, the first thing that I did was try to install the VM radio via Bob's recovery, but it did not take.
    What do you mean it "did not take"?

    You used the radio update that LeslieAnn posted?

    And did it fail in any visible way or did it appear to succeed but your 3G is still broken?

    Unfortunately, access to the radio partition is locked so it cannot be read (or presumably written) without some proprietary mechanism. So until/unless someone figures that out, we are pretty limited.

    It's been a long time since I ran IHO but I recall it doesn't show the baseband version properly and I pulled up some screenshots on google that seem to agree. I think only the stock firmware shows this properly. So you can revert to stock (either old or new) to show your baseband and verify what's installed.

    And the only known way to update it is to use the VM updater binary that they are using. If I had a spare phone, I'd play with the updater binary to see if I could figure out how it worked. But I can't risk my main phone.
    03-26-2012 11:49 AM
  13. grnsnake's Avatar
    After trying everything I could find I found this thread http://forums.androidcentral.com/opt...ntly-work.html and it basically says that VM keeps a needed dll file out of the cab files it lets you download so currently we will never be able to regain data usage.
    03-26-2012 01:14 PM
  14. tdm's Avatar
    After trying everything I could find I found this thread http://forums.androidcentral.com/opt...ntly-work.html and it basically says that VM keeps a needed dll file out of the cab files it lets you download so currently we will never be able to regain data usage.
    Not using KDZ perhaps. But we've got a radio updater and a radio image. So it's possible that if someone had a fair amount of know-how, a spare phone, and an afternoon to play around, the radio could be updated via recovery.

    JerryScript has a donor phone but I don't know if he's willing and able to tackle this. Blarf and I probably could.
    03-26-2012 01:36 PM
  15. JerryScript's Avatar
    Have you tried flashing the VM Security Update again? It contains everything to flash the VM radio, and it can be rooted now. Just be sure to use BobZhome's recovery!
    03-27-2012 01:25 PM
  16. thewraith420's Avatar
    Have you tried flashing the VM Security Update again? It contains everything to flash the VM radio, and it can be rooted now. Just be sure to use BobZhome's recovery!
    +1

    Sent from my LG-VM670 using Tapatalk
    03-27-2012 01:44 PM
  17. grnsnake's Avatar
    I did try reflashing the update via Bob's recovery, but it did not change the radio. I even tried flashing the entire VM update, but I still had no luck. I finally just broke down and bought a new phone.
    03-27-2012 02:10 PM
  18. JerryScript's Avatar
    How do you know it didn't change the radio?
    03-27-2012 02:29 PM
  19. thewraith420's Avatar
    After you flashed the whole update did you try the activate app?

    Sent from my LG-VM670 using Tapatalk
    03-27-2012 02:36 PM
  20. Dannemand's Avatar
    I did try reflashing the update via Bob's recovery, but it did not change the radio. I even tried flashing the entire VM update, but I still had no luck. I finally just broke down and bought a new phone.
    Sorry to hear that. Please consider donating your bricked phone to tdm. I'm sure he can use it to do even more good for this community - on top of all he's already done.
    03-27-2012 03:03 PM
  21. grnsnake's Avatar
    How do you know it didn't change the radio?
    I still had no data after flashing just the radio update that Leslie Ann posted and trying to use the activate apk in Harmonia. I then flashed the entire update package from VM and tried to use the activate apk and still had no data. I then looked at the phone information and the SW version said LS670ZV8 which is the firmware that I force flashed with KDZ.
    03-27-2012 09:00 PM
  22. grnsnake's Avatar
    Sorry to hear that. Please consider donating your bricked phone to tdm. I'm sure he can use it to do even more good for this community - on top of all he's already done.
    Already planned that. Just haven't had time to send it out yet, but hopefully I will get to do it tomorrow.
    LeslieAnn and Dannemand like this.
    03-27-2012 09:01 PM
  23. emmanuelmac's Avatar
    I still had no data after flashing just the radio update that Leslie Ann posted and trying to use the activate apk in Harmonia. I then flashed the entire update package from VM and tried to use the activate apk and still had no data. I then looked at the phone information and the SW version said LS670ZV8 which is the firmware that I force flashed with KDZ.
    Mine said LS670ZV8 even after installing VM update. I re-rooted and downloaded the VM update onto my SD. On IHO recovery, I wipe cache, factory reset, dalvik cache and boot, cache, data, and system. [To get to recovery, I had to substitute the option key for the Home key. Instead of Home+Vol down+Power. It is Option+Vol down+Power. They are switched]. Then I applied the the update from SD. After that it changed to VM670ZV9. I did the activate app it restarted the phone. But the the 3G symbol never shows. I can't confirm data since I don't have service today. The recovery went back to stock.

    Could the Switched home and option button be causing the problem?
    jccjr1982 likes this.
    03-27-2012 10:55 PM
  24. JerryScript's Avatar
    Mine said LS670ZV8 even after installing VM update. I re-rooted and downloaded the VM update onto my SD. On IHO recovery, I wipe cache, factory reset, dalvik cache and boot, cache, data, and system. [To get to recovery, I had to substitute the option key for the Home key. Instead of Home+Vol down+Power. It is Option+Vol down+Power. They are switched]. Then I applied the the update from SD. After that it changed to VM670ZV9. I did the activate app it restarted the phone. But the the 3G symbol never shows. I can't confirm data since I don't have service today. The recovery went back to stock.

    Could the Switched home and option button be causing the problem?
    No, the switched buttons have no effect.

    Right after installing the VM Security Update, you should run the root expoit provided by jcase and myself. It's not about rooting at this point, but about preventing your recovery from being overwritten.

    After applying the root exploit, I would then attempt to flash the radio again for good measure, then attempt to use the activate app before you install another ROM, do it from the VM security update's ROM.
    03-27-2012 11:52 PM
  25. LeslieAnn's Avatar
    Mine said LS670ZV8 even after installing VM update. I re-rooted and downloaded the VM update onto my SD. On IHO recovery, I wipe cache, factory reset, dalvik cache and boot, cache, data, and system. [To get to recovery, I had to substitute the option key for the Home key. Instead of Home+Vol down+Power. It is Option+Vol down+Power. They are switched]. Then I applied the the update from SD. After that it changed to VM670ZV9. I did the activate app it restarted the phone. But the the 3G symbol never shows. I can't confirm data since I don't have service today. The recovery went back to stock.

    Could the Switched home and option button be causing the problem?
    What shows in the "about" window is controlled by the rom, not the radio.
    03-28-2012 12:36 AM
91 1234
LINK TO POST COPIED TO CLIPBOARD