1. nutmeg07's Avatar
    Alright guys, so I've been having this problem a while and it's getting irritating.

    I use a Harmonia rom, but I've had some odd problems with it, especially when it comes to apps. Recently I re-flashed the rom (I did a complete wipe - wiped cache, wiped dalvik cache, wiped data/factory reset) and as usual, everything starts off fine.

    I get through re-installing most of my apps, either via the market or titanium backup. But always, at some point, suddenly my apps will no longer install.

    When I try to download them from the market, the app download icon will flicker then disappear. When I try to restore the app with titanium backup, it will say "application not installed". Even if I put the app package on my SD card manually and then try to install, I'll get "application not installed" or "invalid package error". This won't be with one particular app, but several.

    Even stranger, when I initially installed all my regular apps, I rebooted at one point and saw that two or three no longer existed. Couldn't re-install them, and on my home screen the blank application icons (you click and it says "application not installed" ). I went about my day, rebooted at some point, and suddenly those apps that previously had blank icons and wouldn't run were existing, operating fine, and there were instead new apps that disappeared and no longer would run.

    So what's up with this folks? I did a complete wipe. A while back I even tried reformatting my SD card - no luck. Is this just an unstable ROM?

    Also, my phone will just reboot for no apparent reason on it's own from time to time.

    This is really frustrating...I just want to play Draw Something and get my Dictionary.com Word of the Day widget working again

    Advice? Ideas? Thoughts?
    04-10-2012 04:49 PM
  2. anthonycr's Avatar
    Did you by any chance flash the new radio update?

    Sent from my VM670 using Tapatalk 2
    04-10-2012 05:25 PM
  3. EarthnFire78's Avatar
    The "invalid package error" is because your Delvik-Cache is full, try moving the Cache to your sdcard, or partition the sdcard and move the Cashe/Delvik-Cache to the partition and maybe you /data/app folder as well.
    04-10-2012 05:49 PM
  4. curtis1973's Avatar
    ive had errors similar to these,like apps disappearing from my app drawer even though manage apps shows them,reboot and their back. ill wipe my dalvik as well. im on iho and experiencing some of these issues,also from time to time i have to delete Google play and go back to market because i get errors downloading an app. usually deleting play and allowing it to re-update all over resolves itself.
    04-10-2012 07:34 PM
  5. nutmeg07's Avatar
    Did not flash new radio update.

    Ok EarthnFire, I'll try that - once I do the partition can I just drag the cache to my sdcard or do I need to do something special with ADB and such? (yeah...I'm kind of a newb)
    04-10-2012 08:05 PM
  6. EarthnFire78's Avatar
    There are few ways that can be done. The two best was are data2sd to a2sdx scripts.
    04-10-2012 09:24 PM
  7. nutmeg07's Avatar
    Still no success.

    I think I did what you suggested EathnFire - I flashed this and this.

    The first one seemed to flash alright, but no changed to my inability to download.
    The second one didn't flash right, but possibly because I had done the first already?
    04-12-2012 11:18 AM
  8. EarthnFire78's Avatar
    If your partition is an ext4 the a2sdx script is the better choice, that is the one that I use in my ROM: but it only works for Gingerbread IHO ROMS and 2nd partition must be ext4.
    Raul720 likes this.
    04-12-2012 11:25 AM
  9. Badboytoast's Avatar
    To me it looks like your not flash correctly and some of data is messing with hormonia, this us step by step how I flash hopes this helps!!
    1:reboot into recovery
    2:wipe data/factory reset
    3:wipe cache
    4:wipe delivic cache
    5:format,boot,cache,data,system
    6:install hormonia(zip) "gapps if need"
    7:reboot and enjoy
    04-12-2012 11:35 AM
  10. EarthnFire78's Avatar
    See if this helps.

    ad2sdx_install.
    04-12-2012 12:06 PM
  11. Badboytoast's Avatar
    See if this helps.

    ad2sdx_install.
    Do u just flash in recovery,
    04-12-2012 12:25 PM
  12. EarthnFire78's Avatar
    Do u just flash in recovery,
    Yup, it well refromat your Cache so reboot well take a little longer.
    04-12-2012 12:47 PM
  13. Sean OGorman's Avatar
    To me it looks like your not flash correctly and some of data is messing with hormonia, this us step by step how I flash hopes this helps!!
    1:reboot into recovery
    2:wipe data/factory reset
    3:wipe cache
    4:wipe delivic cache
    5:format,boot,cache,data,system
    6:install hormonia(zip) "gapps if need"
    7:reboot and enjoy
    lol, hormonia. I want *that* ROM.
    04-12-2012 01:12 PM
  14. Badboytoast's Avatar
    04-12-2012 02:01 PM
  15. nutmeg07's Avatar
    Hey guys, so problem is similar but has changed. Flashed Harmonia 2.

    I can install apps....to a point. After I download several (like a big chunk of apps), I run into problems.

    Google Play store will say: insufficient space on device (with PLENTY of space)
    Titanium Backup says : Application Not Installed
    If I try installing straight from my SD card after downloading app and sending it to phone, I get "Package file invalid"

    What is the deal!? I've wiped cache, dalvik, cleared market data. Cleared SD card and did a complete wipe.

    Don't know what else to do.
    04-17-2012 09:12 PM
  16. Nate456's Avatar
    Try moving the dalvic cache to the SD card I did that a while back and it solved the problem for me.

    Sent from my LG-VM670 using Tapatalk
    04-17-2012 09:41 PM
  17. EarthnFire78's Avatar
    How many system apps do you have? The reason I ask, is that there is a script that moves that merges system - Delvik-Cache and data - Delvik-Cache into the Cache Partition. Remember the Cashe is in a separate partition.
    04-18-2012 12:13 AM
  18. nutmeg07's Avatar
    How do I move dalvik cache to SD card Nate? Use Astro?

    EathnFire, I'm not sure so many system apps I have. Is there a way to find out? Apps2SD shows 8 apps on my phone internal memory, but I don't think that's what you mean..
    04-18-2012 08:58 AM
  19. Nate456's Avatar
    - Using a root file manager like Root Explorer or ES File Explorer, move the following file to your sdcard:
    /system/etc/init.d/01mvdalvik
    - From the homescreen, press the menu key and select Manage Applications, then select the All tab
    - Scroll down to the Market app, and click on it, then clear market data and cache, MUST DO BOTH
    - Reboot into recovery, then wipe cache, and under advanced wipe dalvik cache
    - Reboot, and then sign back into the Market, and you should now be able to download again
    (note- this lowers the amount of internal storage, but so long as you move most apps to the sdcard, it shouldn't be an issue)
    04-18-2012 11:18 AM
  20. nutmeg07's Avatar
    That was it! Thanks a ton!
    04-18-2012 06:41 PM
LINK TO POST COPIED TO CLIPBOARD