05-19-2014 06:41 AM
67 123
  1. BuggerZ's Avatar
    Yea no go on nv write for the read only.
    Ok in DFS when u got it to write were u in recovery mode or regular boot with ##PORT#?
    Regular boot into the OS using COM3.
    06-14-2012 03:42 PM
  2. daftande's Avatar
    So I am finally having some success with CDMA Workshop.
    However in CDMA workshop it only wants an 8 digit ESN.
    I think this is the HEX version of the ESN, is this correct?

    Sadly my MEID is still zeroes.
    06-14-2012 04:08 PM
  3. AndyOpie150's Avatar
    Thanks to all these people:

    And the Devs of these Utility Programs:
    LGNPST (Used the one with the General_v1.2_Lab_version)

    My stone cold brick of over a year is now a functioning Pocket PC again (No Data because it isn't activated) with an ESN, MEID, and the proper PRL.
    I can now use the market to download apps instead of having to pull them off of one of the other good V's (purchased a used one last month as a spare) and installing them using ADB

    Thanks again to all who helped in this project.
    PS: Using DFS version and following assadulah's hint in his AAA code video I was able to write my MEID to the phone and have it stick. It didn't look like it did right at first because it wasn't showing in the settings. Went back to LGNPST to try again and it showed my MEID insted of all zero's. Rebooted phone and there it was in the settings.

    NOTE: I couldn't get my V into emergency mode the normal way (BACK+VOLUME DOWN+POWER while inserting USB cable).
    I had to use a battery that was totally drained and a battery that was fully charged.
    With the battery that is totally drained I carefully inserted the USB cable into the phones port just enough to keep it from falling out but not enough to apply any power. Then I had to do this: hold BACK+CAMERA+VOLUME DOWN then push POWER while inserting the USB cable at the same time (took some practice to get right). Then while still connected to PC I swapped batteries.
    So for those that think they have a hard brick, try ^ this. It worked for my brick.
    I'm beginning to think there is no such thing as a hard brick with the Optimus V .
    08-11-2012 09:41 PM
  4. grip66's Avatar
    Ok. Hoping for a reply since this thread seems like it's gone silent for a while. Tried the unbrick. Finished step 4 "Open LGNPST.exe as administrator, and select the bin in step 2-D" and phone rebooted fine. No more bootloop. Unfortunately, no screen either. I can see that the backlight for the screen is on but there is nothing being displayed. I can now get into recovery mode and I've tried recovery flash with two different images using adb. The recovery seems to go smoothly but again, no screen display. I know the phone boots up ok because I get this nice jingle followed by crickets a couple of seconds after I power on. Any help would be appreciated. At least it isn't bricked anymore but a display is a must have....
    02-19-2013 06:59 PM
  5. AndyOpie150's Avatar
    I'm going to need mor info.
    What have you done since the actual Emergency mode flashing of the .bin file? Be as specific as possible so I can determine what happened, and thus, what corrective action needs to be performed.

    Sent from my LG-VM670 using Android Central Forums
    02-19-2013 10:02 PM
  6. grip66's Avatar
    Well, I've been playing. Here's what I've done so far:

    1. Did the unbrick until step 4.
    2. Used adb and flash_image to flash recovery images. Boots up but no display still.
    Have tried these images:
    3. Found Androidscreencast and can now see what's on the screen.
    That's really good news because the phone is working fine except the display.
    The really bad news is that everything is in Japanese and I can't read a damn thing.

    So, If there's anything else you need to know, let me know. I can pretty much do anything I want to the phone now. I was checking out the file system. I used to do Unix admin work years ago so this isn't that alien to me.
    Thanks for helping me out. I really appreciate it. Oh. btw. One of the links on the unbrick post is broken. It's the OV9 update one. I couldn't find it anywhere either.

    Thanks again.

    EDIT: Ok. Played some more and got english now. Great. I can read everything. Should I do a Factory Data Reset from the Privacy settings? I read this could be bad so I haven't touched it.
    02-19-2013 10:53 PM
  7. upconvert's Avatar
    Should I do a Factory Data Reset from the Privacy settings? I read this could be bad so I haven't touched it.
    No, don't do that. Try a newer recovery, like zen garden or cot2.1. They should work with your newer screen.

    Sent from my LG-VM670 using Android Central Forums
    02-20-2013 10:30 AM
  8. grip66's Avatar
    Will try it tonight and let you know how it turns out. Thanks.
    02-20-2013 10:40 AM
  9. thewraith420's Avatar
    The strange part is the vm670nh recovery supports both screens

    Tapatalk'n it from my Cold As Ice VM670 running LS670ZVJ firmware
    02-20-2013 12:29 PM
  10. AndyOpie150's Avatar
    Strange indeed, unless their having problems with the actual ROM having the wrong kernel.
    I think once a ROM for the V is flashed, at least they should be able to see everything fine when booted into ROM.
    The recovery is a mystery, unless the screen drivers are borked, then neither one will be seen unless with Droid@Screen or ScreenCast.

    Sent from my LG-VM670 using Android Central Forums
    02-20-2013 02:33 PM
  11. grip66's Avatar
    Is there a way I can check the version of the kernel? Where would I look for the drivers? I have complete access to the file system so I can poke around. I'll look at my working VM670 and compare things. Would it be safe moving files from my working phone to the other?
    02-20-2013 05:05 PM
  12. AndyOpie150's Avatar
    No. Different ROM's mean the files are going to be slightly different and would cause a boot loop.
    Check under "about phone" in the settings.
    I think the screen drivers are software, but don't know anything past that.
    If you can see the recovery menu thru Screen Cast try and install the MiRaGe ROM and Gapps (assuming you have rooted the phone).

    Sent from my LG-VM670 using Android Central Forums
    02-20-2013 05:34 PM
  13. AndyOpie150's Avatar
    NOTE: This Guide worked flawless for me because I followed all the steps to the letter and didn't stop at step 4.

    Sent from my LG-VM670 using Android Central Forums
    02-20-2013 05:38 PM
  14. grip66's Avatar
    Ok. So I'm home now and playing some more. I've found a couple of things that may explain what the problem is. First, I can't seem to get the phone into recovery mode. When I do and get it on Screencast, it's just the normal screen for the phone. No menu comes up. I'll try again but it looks like I can't get there.

    Second, I was looking at the info on the phone and found this:
    Model Number = LS670 (not VM670)
    Android version = 2.2
    Baseband version = LS670MV8_6038.
    Kernel version = lge@androidbuild #2
    Build number = FRF91
    SW Version = LS670ZV8

    Did someone use a Sprint ROM on this? The phone is a Virgin Mobile phone and the model number on the back say VM670. I do have a Software Update and Firmware update option on the menu.
    Let me know if this helps.
    Thanks again for the help.
    02-20-2013 07:46 PM
  15. AndyOpie150's Avatar
    Did you read thru the guide a few times before flashing?
    The only way to fix a stone cold bricked V is to flash the S firmware. Then you root with the S root tool and install the Xionia recovery. Once that's done you need to flash a Froyo ROM to finish the rest on how to get the Data restored (the link I left you to the AAA code tutorial).

    You need to read the guide over a couple of times, Redue, follow and complete all steps.

    Sent from my LG-VM670 using Android Central Forums
    02-20-2013 08:35 PM
  16. grip66's Avatar
    First off, yes, I did read the guide several times and check things along the way. I did follow the instructions as given, in order until after step 4. Now this is making some sense. I used the LS670ZV8_23.bin file when doing step 4 so that is why my versions look they way they do. I now understand that the bin file I used is the S firmware. I have used optiauto-sfx.exe to root after the fact so that's done. Like I said earlier, "Under "Resources" Download the Official OV9 Update.zip" link is broken. I can't find the update file anywhere so I can't do step 6 anyway. I would appreciate it if someone could send me a new link. I also can't do step 7 because I can't seem to get the pone into recovery mode or see the screen. I'm also going to assume that step 8 is done from the recovery menu which I can't see. I'll play with it some more and see what I can come up with.
    02-20-2013 10:22 PM
  17. thewraith420's Avatar
    Well if you flashed a bin you've already wiped your esn, meid, aaa, ha, and aaa. Sooo... If I can find a host that will allow me to upload a file over 200mb I have the zv5 bin you could flash. It will put you back to complete stock recovery and all. Then your new project will be restoring service to it

    Tapatalk'n it from my Cold As Ice VM670 running LS670ZVJ firmware
    02-21-2013 12:20 AM
  18. AndyOpie150's Avatar
    Ok. Now where getting some where. I like information. The more the better.
    Here is the link to the ZV9 update: http://forums.androidcentral.com/ext...252Fupdate.zip
    Once downloaded follow the rest of the steps.

    PS: Sorry I didn't see where you posted about the busted link.
    In the future, try not to attempt any guide of any kind without making sure all download links work.
    If any are, don't do anything until you can get them fixed (bring to the attention of guide author) or find an alternative download site.

    Can you see the recovery menu in Screen cast?
    Remember to flash the ZV9 update once in the custom recovery, and once in the new stock recovery.

    When done, if everything looks good, I'll link you to the the best root guide for the ZV9 update.

    Sent from my LG-VM670 using Android Central Forums
    grip66 likes this.
    02-21-2013 01:06 AM
  19. grip66's Avatar
    Thanks again for everyone's help. I'm sure I would have used the phone for batting practice by now if you guys weren't helping me.

    Well, I've tried a couple of times to get into the recovery menu and it seems like it just won't get there. It boots up normally with the home-up volume- power key combination. My good VM670 goes in no problem. I did notice that the phone I'm working on keeps booting into usb debugging mode. Could this keep me from getting into the recovery menu? If I turn it off, how do I turn it back on? Is there another way to force the update without the recovery menu? Sorry for all the questions.

    btw. For anyone wanting to play with Screencast, you have to do a shell root before you start it for it to work. I used SuperOneClick to do this and it works great.

    EDIT: One more thing with Screencast. The screen will go black with a blinking cursor at the top left corner. That's because your phone went into screen saver mode. Just hit a key on the phone and you're back. Screencast is a little slow on response some times too so give it several seconds to update.

    Also, thanks a bunch AndyOpie150 for the link and all the help.

    EDIT AGAIN: AARRGH!! Ok. Got into recovery. Reread the first post and now realize that the S ROM key combinations are different than the stock ROM ones. I can now see the screen in Screencast too. I'm going to try to finish the unbrick and let you know how it goes. Sorry about missing the key combination difference.
    02-21-2013 10:11 AM
  20. grip66's Avatar
    One more thing. Step 8.
    8) Reset data and cache then toggle sig verification before flashing update.zip

    Should I assume the reset data means selecting "wipe data/factory reset" on the recovery menu?
    Should I assume the reset cache means selecting "wipe cache partition" on the recovery menu?
    Should I also select "Wipe Dalvik cache" from the "Advanced and Debugging Options" on the recovery menu?
    One last thing. I'm not sure what toggle sig verification means. This is the first time I've really looked at a recovery menu so I apologize for the stupid question. I'm still a bit green at this.

    Thanks everyone.
    02-21-2013 10:51 AM
  21. upconvert's Avatar
    Yes, format/wipe boot, data, system, dalvik cache, sd-ext (if you have one, but you probably don't). You should do this whenever you are installing a new rom. You can get away with just cache and dalvik if you are updating a rom. Usually the factory reset option wipes cache, data, and sd-ext, but it depends on the specific recovery. There should be a separate menu that lets you format each partition individually.
    02-21-2013 11:19 AM
  22. grip66's Avatar
    Hey upconvert. Is that a Yocco's logo you've got there? It took me a little while but I recognized it. You must be from my neck of the woods. Thanks for the info.
    upconvert likes this.
    02-21-2013 11:23 AM
  23. grip66's Avatar
    Awesome! Update went without a hitch. I now have a display and a working phone. Now to reenter all of those codes and regen the AAA code. Do I need to root this at this point? I intend on updating it with BobZhome's ICS ROM.
    02-21-2013 11:48 AM
  24. AndyOpie150's Avatar
    I don't think you need to be rooted.
    Just in case it doesn't work unrooted here is the ZV9 update Root Guide: http://androidforums.com/optimus-v-a...0-rooting.html
    The "Windows version" download works (just tried it) .

    Sent from my LG-VM670 using Android Central Forums
    grip66 likes this.
    02-21-2013 01:14 PM
  25. upconvert's Avatar
    Hey upconvert. Is that a Yocco's logo you've got there? It took me a little while but I recognized it. You must be from my neck of the woods. Thanks for the info.
    Originally from Reading. I miss yocco's more than anything. I want to get the logo tattooed on my arm. Glad you made progress.

    Sent from my GT-P7310 using Android Central Forums
    02-21-2013 07:45 PM
67 123