1. dbacon84's Avatar
    I am running Harmonia 2.06 on LG OpV w/ the usual clock settings.

    This evening I updated to the newest version of Link2sd when I noticed it was available in my Play store updates. Link2SD installed and shortly after it did and while I was in the browser (I think...) the phone rebooted as it sometimes does. After the reboot I got a notification that the SD card was safe to remove. I took the card out and put it back in and the same "safe to remove" message popped up. The phone would no longer read the card and I could not get my laptop to read the card (winxp and I tried mini partition tools.

    The card was a 32gb formatted w/ a 1gb partition (ext 3 I think formatted in recovery) for Link2SD to use. The rest of the card was Fat32. I've been using the card for several weeks. I tried to read the card on my laptop through the phone's usb and directly w/ the micro sd adapter, but with no luck. The laptop would not even recognize that a card was present.

    All the apps that I linked to the 1gb partition are now not recognized and I get the "app not installed message when I try to use them. I can also not access the rest of the card where I had a LOT of music stored as well as some ebooks and other bits and pieces of stuff I'd like to get back.

    I've rebooted the phone several times with the card in and out. I've removed the battery. I've tried the "fdisk-h" command in terminal emulator. All w/no luck. My original 2gb card that came with the phone still works so it isn't the phone. I have tried to mount the card in recovery and just get an error. I have not tried to format in recovery as I don't know what this will do and I am hoping someone will be able to give me a suggestion which will help me get back all my currently inaccessible data. Any suggestions?

    Before you ask, yes I have backed up all the apps on my phone... to this card. And, no because of the size of this card and the amount of time required I had not backed it up to my computer. I do have my original app/data and Nandroid backups from when I rooted and ROM'd on my original 2gb card. However the app/data b/u is way out of date.

    So does anyone have any suggestions? Do I try to format the card in recovery? If I do, that will erase everything won't it?

    Any help would be appreciated.
    05-15-2012 11:14 PM
  2. dbacon84's Avatar
    Looks like a lot of people viewed my original post, but like me were unable to think of a solution. In case anyone else runs into this situation, I thought it might be useful for me to share what I ended up doing.

    My PC would not read the SD card and I could not mount it in recovery on the OpV. What I ended up doing was to partition on the OpV in recovery. This made it readable again, but it was empty. So I downloaded Remo Recovery as mentioned on another thread here and was able to recover files I wanted to get back and had no back of (mainly pictures).

    I then formatted the card and partitioned it again and it is now useable once more. I still am not sure what happened to trash it in the first place, but suspect it may have had something to do w/ how it was parttitioned interfering w/ the update to Link2SD.

    The lesson I learned is to BACK UP the card frequently. My procedure now is to back up the OP w/ MyBackup. Then connect the OP to the computer and copy all vital files there. I figure if the card crashes again, I can load the back up to another card and get all that stuff back.

    Lesson learned the hard way.

    Thanks to all for looking. I'd still be interested to hear any theories anyone might have on what happened to my card as I'm still not completely sure...
    05-18-2012 09:32 AM
  3. anon(235100)'s Avatar
    Just looked at this thread. I think you did the best thing that could be done- exhausting all of the appropriate steps you took.
    05-18-2012 11:16 AM
LINK TO POST COPIED TO CLIPBOARD