07-19-2012 12:45 AM
63 123
tools
  1. dollarhax's Avatar
    Story is that my sister has a LG optimus v (as do i) but hers was on stock whereas mine was rooted since January. She had some bugs (text messaging and calling just failing on open) so I told her I'd just root it and flash CM7 on it for her and it'd fix the problems and help with things like battery life. Here are the series of events that transpire.

    >Problems arise. She calls tech support, they have her try to troubleshoot it through resetting the phone things to where MIN and MEID or whatever are changed to 1111111111. She does this, but doesn't set it back to the numbers. (I was unaware of this).

    >I root and flash it just fine, but it still won't make calls and it will not send texts or receive calls. Just asks if I'd like to make a toll free call.

    >Confused, I restored and tried unrooting through Gingerbreak by pressing the un-root button. Still doesn't work.

    >I'm like wtf so I do some digging and find out that since it's trying to call from that number, it's obviously wrong. I then get a call to go pick up my brother from work, so I leave the phone with my sister and my dad to call VM and ask them what the numbers are so that they can be returned to normal and it would be functional again. I restored the phone back to the backup from before because I was convinced it was the root that went wrong and not the number, so that means it was booting into her previous thing. Bugs were gone - messaging and phone apps were not shutting down upon opening.

    >They get the numbers, put them back in, phone still doesn't work. This is done while I'm gone. I get home and instead of just taking the phone, I let him continue on with the phone call. Of course, they tell him to do a factory reset. NOPE NOPE NOPE NOPE NOPE.

    >They reset it.

    >I try to restore it, goes into recovery reboot loop.

    >After some serious googling, find this: http://androidforums.com/optimus-v-a...ml#post3263770

    >At this point I try downloading the .zip file and putting it on the SD card (Mind you, the computer will not read it through the phone despite trying to turn on USB sharing. I have to use a separate phone to get it on the SD card in the first place).

    >Try go to install from .zip, just keep getting that the installation has failed. I tried putting the .img within the .zip, as well without. Neither work, same error. This is where I'm stuck.

    What do I do? Currently I'm downloading the SDK for Android, hoping I can get the adb shell somehow so I can install it through the computer but my hopes are not high.

    I feel terrible because I essentially bricked my sister's phone which she paid for herself.
    06-16-2012 12:07 AM
  2. cole2kb's Avatar
    You are on the right track to getting a ROM back on there. Get ADB set up, and you should be able to flash a custom recovery. I recommend Xionia. What I would recommend you do, is to download the ZV9 update.zip that is floating around. Once you get your custom recovery on there, flash the update.zip, reboot, and flash it again. Then, try to run the Activate app, and if that doesn't work, Virgin should be able to walk you through and do whatever, as this will be a non-rooted, fully stock phone once again.
    dollarhax likes this.
    06-16-2012 01:26 AM
  3. dollarhax's Avatar
    Any chance for download links and a seriously hand holding direction set? Currently what I've downloaded tonight is (in no particular order, basically grasping at straws as this is my first mess up) I have no idea how to get an ADB working.

    "SuperOneClick"
    SDK.zip
    flash_image.zip (from the Xionia link?)
    xionia.cwma_12518.6.rar
    Had to install Java and Java SDK as well apparently
    The actual SDK installer from android dev or something or another

    Not sure how to get the ADB. When I run the adb.exe, it just flashes a small command prompt and it goes away. I've installed the Optimus V drivers to my computer as well. How will it work on my phone if the phone is hardly being read through the computer? At least, the SD card isn't being read anyways. It won't show up under Computer unless I use another phone to do it.
    06-16-2012 01:59 AM
  4. LeslieAnn's Avatar
    Here is Xionia .4
    xionia_cwma_12518.4_virgin.rar

    You can't run adb, you have to open command prompt and start it from that. Double clicking it will only have it flash on then close.
    dollarhax and yondero like this.
    06-16-2012 03:18 AM
  5. ROMorama's Avatar
    Don't know if you're familiar w/Windows command prompt, but you have to specify the path to the ADB folder before you can use it. You do this using the command "cd" (without quotes), which means change directory. On most computers it looks like this:

    cd C:\Android\android-sdk\platform-tools

    Then you can use the ADB commands.
    To check if the phone is recognized, just type "adb devices" (again, no quotes). It'll give you a list of attached Android devices.

    Sent from my VM670 using Android Central Forums
    dollarhax likes this.
    06-16-2012 09:23 AM
  6. dollarhax's Avatar
    So now that I have figured out the whole CD thing, i type in adb shell and it gives me the # thing.

    I then go to type in the command # mount -o remount,rw -t yaffs2 /dev/block/mtdblock5 /system and it just tells me invalid argument. Very confused, copying it letter for letter and it's giving me problems. what do? I have the .zip and the .img both on the root of the SD card, and it says it is recognizing A1000019678B27 recovery when I typed in adb devices.
    06-16-2012 11:59 AM
  7. dollarhax's Avatar
    Just tried mounting the sd card in the CWM-based recovery and then when I typed in the first line, it gave me a bunch of BusyBox commands? Seemed right, so I went on to type the next line
    can't open ' /sd_card/flash_image' : no such file or directory

    Except I just copied flash_image.zip to the SD card. should I unzip it then? i unrar'd the .rar but didn't unzip the .zip, should I do that?
    06-16-2012 12:04 PM
  8. dollarhax's Avatar
    Sorry for multiple posts, posting as problems come up.

    Unzipped the .zip, passed the problem of no such file or directory. then did the 755 and it worked, had an error on the install-recovery but the directions say to ignore it, but the next step after when putting in: # mount -o remount,ro -t yaffs2 /dev/block/mtdblock5 /system it just tells me invalid argument?

    Almost want to just skip it and try the next step anyways...
    06-16-2012 12:25 PM
  9. dollarhax's Avatar
    Skipped it and tried it anyways. Of course more problems.

    So it stopped the reboot loop which is good, but now it is booting into CM7. Every time I get into recovery, it is not the Xionia recovery and instead is the CWM-based recovery, and it isn't in it for long before saying it crashed and then just boots into CM7 again. This is the 2nd reboot, not sure if I'll ever be able to get into recovery again at this stage...

    What do? (Let the record be known that I am now 100% against phones. The severe restrictions on these things causing this many problems is nothing short of annoying)
    06-16-2012 12:36 PM
  10. dollarhax's Avatar
    formats cashe and data and then factory resets it and then it's back to CM7. I'm guessing I somehow goofed up the recovery. Is there a way to fix that from within the phone OS since I can now get to that at least?
    06-16-2012 12:37 PM
  11. cole2kb's Avatar

    Installing a recovery the old-fashioned way (maybe the only way, for your new screen, if you flashed a ROM and recovery at the same time with ROM manager) :
    To manually flash your shiny new custom recovery, put the recovery.img, flash_image, on your sd. Download and Open Terminal Emulator on the phone itself, if your rom is still working, and type the following code (if you're using adb, you can drop the first two lines and replace with "adb remount" (no quotes when you type it)):
    Code:
    su
    
    mount -o remount,rw /system /system
    
    cat /sdcard/flash_image > /system/bin/flash_image
    
    chmod 755 /system/bin/flash_image
    
    mount -o remount,ro /system /system
    
    flash_image recovery /sdcard/NAME-OF-RECOVERY.img
    if you get any errors above, don't type the next command or you'll boot into nothing...
    research the errors before trying to reboot.
    Code:
    reboot recovery
    NAME-OF-RECOVERY.img should be replaced by the filename of whichever of the recoveries (not the .zip versions) you have chosen to use.

    that sequence of commands will install, and reboot you into, the (hopefully) working recovery.


    Follow these steps to flash new recovery

    Sent from my LG-VM670 using Android Central Forums
    dollarhax likes this.
    06-16-2012 01:24 PM
  12. dollarhax's Avatar
    "
    chmod 755 /system/bin/flash_image
    "

    Tells me there's no such thing again.

    Siiigggghhhh. Is there a way to go about fixing this problem too? Google isn't returning much in terms of help other than people with poor grammar and vague instructions.
    06-16-2012 03:16 PM
  13. cole2kb's Avatar
    Did the command before that execute successfully?

    Sent from my LG-VM670 using Android Central Forums
    dollarhax likes this.
    06-16-2012 05:01 PM
  14. ROMorama's Avatar
    Download the app called Flash Image GUI, and use it to flash Xionia. If it still bootloops let us know, as there are a few things more that you could try. This is just the simplest.

    Sent from my VM670 using Android Central Forums
    dollarhax likes this.
    06-16-2012 05:03 PM
  15. dollarhax's Avatar
    alright so i managed to do the whole sequence of the su command thing, but did it through adb instead. i tried using "adb remount" and that didn't work but everything after did? im guessing without remounting it made the rest of it worthless though, as it just boot looped again. here's a pic

    I tried the flash image gui to flash Xionia, it didn't work either. keeps going back to clockwork. seems for whatever reason the xionia isn't sticking
    06-16-2012 06:02 PM
  16. cole2kb's Avatar
    Do "adb remount" at a standard command prompt and then enter the shell and continue. So, it should look something like

    ...\platform-tools\>adb remount
    remount succeeded (don't type this, it should say this after you send the remount)
    \platform-tools\>adb shell
    Etc....


    Sent from my LG-VM670 using Android Central Forums
    dollarhax likes this.
    06-16-2012 06:31 PM
  17. ROMorama's Avatar
    I tried the flash image gui to flash Xionia, it didn't work either. keeps going back to clockwork. seems for whatever reason the xionia isn't sticking
    Here's a flashable version of Xionia that you can install from CWM. It's a zip file, so you can "install zip from SD". Still might not work, but perhaps worth a shot?




    Sent from my VM670 using Android Central Forums
    dollarhax likes this.
    06-16-2012 07:37 PM
  18. cole2kb's Avatar
    Hey man, if you can't get it working, I'd be happy to use some sort of screen casting software and see if I can just do it for you. Send me a pm and we can set something up.

    Sent from my LG-VM670 using Android Central Forums
    dollarhax likes this.
    06-16-2012 08:50 PM
  19. magus7091's Avatar
    Open terminal emulator and type:
    su (enter) click allow on super user request
    Then type:
    flash_image recovery mnt/sdcard/[path to recovery]/[recovery file name].img (enter)
    I.e., if your recovery is in the root of your sd card, with the name recovery.img the commands would be
    su
    flash_image recovery mnt/sdcard/recovery.img
    reboot recovery

    After the final command you should be dumped at the newly installed recovery, and should get some feedback if it fails..

    Sent from my LG-VM670 using Android Central Forums
    dollarhax likes this.
    06-16-2012 09:06 PM
  20. dollarhax's Avatar
    tried the remount, didn't work.

    i can't get to cwm long enough (it just crashes and reboots to cm7 with a fresh install after wiping cache and what have you). i can get to the recovery if i just break it again. that is, if i try to flash through flash gui. i'm going to try what magus suggested and then see what to do from there.
    06-16-2012 11:24 PM
  21. dollarhax's Avatar
    no go on magus idea either
    06-17-2012 12:09 AM
  22. cole2kb's Avatar
    You don't need to be in recovery to do those steps, you can do them from inside your ROM. You can stay booted into CM7, right?

    Let's break this down, and start over. Now that I'm at a keyboard, I can type out a novel on this if need be. There is no reason why this shouldn't work, that I can tell.

    Here goes.

    Download this file to your SD card: http://dl.dropbox.com/u/72059024/flash_image
    Also, this one: http://dl.dropbox.com/u/72059024/recovery.img

    Let your phone boot up to CM7.
    Download Terminal Emulator from the Market.
    Plug it in to your PC.
    Open a command prompt and go to the platform-tools folder.
    Type in "adb remount"
    If it doesn't say "remount succeeded", stop and report back as to what exactly it says / does.

    Open Terminal Emulator on your phone. All of the following commands will be typed in there, not on your PC.
    Type in 'su'. It should now show you a prompt for Superuser access, press 'Allow'. Go through the following commands below, one at a time.

    Please report back immediately with ANY errors.

    cat /sdcard/flash_image > /system/bin/flash_image

    chmod 755 /system/bin/flash_image

    mount -o remount,ro /system /system

    flash_image recovery /sdcard/recovery.img

    reboot recovery

    There is no reason I can think of why this won't work. I don't know what is going wrong otherwise without seeing it for myself, which, like I said, is possible, but we would just need to set up a time to do so.

    If all went well, you should be in Xionia recovery. From here, we will flash the stock ZV9 ROM, but I don't want to bog you down with steps if you can't even get this far.

    I know you've apparently done all this before, but humor me. Try it one more type, exactly as typed.
    dollarhax likes this.
    06-17-2012 12:36 AM
  23. dollarhax's Avatar
    Did it exactly as typed, just goes back to CWM recovery failed nonsense. erases, turns on and off a few times, goes to CM7 charging screen. no errors in between any of it (other than me accidentally typing remouny instead of remount which i fixed). when i do flash_image recovery /sdcard/recovery.img, should it be telling me anything? i hit enter and it just goes to the next line.
    06-17-2012 12:52 AM
  24. cole2kb's Avatar
    Sometimes it will, sometimes it won't.

    How much time will it give you in recovery before it reboots? Do you have time to hit a few buttons?

    My next idea is for you to copy the stock update.zip to your SD card, and just start the flash in recovery with hopes that it won't reboot mid-way through, but I can understand if you don't want to try that.
    dollarhax likes this.
    06-17-2012 12:56 AM
  25. cole2kb's Avatar
    When you type 'su' in the terminal, does it ask you for Superuser access?
    dollarhax likes this.
    06-17-2012 01:00 AM
63 123
LINK TO POST COPIED TO CLIPBOARD