01-01-2014 07:38 PM
167 ... 4567
tools
  1. yaconsult's Avatar
    Look at this post: http://forums.androidcentral.com/opt...ml#post3204515
    Tell me if it went as far as it should have.
    We need to see if we can get it into the fastboot screen somehow. If your showing just a black screen then the recovery partition might have gotten messed up a little, we will need fastboot commands to wipe it and install good recovery, if you have no adb working on phone.

    If you have a ZV4 phone you will be better off with this: VM670ZV4_KP500 this also has my updated instructions. You can get into the fastboot screen easier with this.
    Hi Andy,

    That is the guide I have been using. I believe that it completed successfully according to this log: http://forums.androidcentral.com/att...16-unbrick.txt

    The problem remains that adb can see the phone but its status is offline. Doesn't that mean that fastboot will also see it as offline or does fastboot work differently? I believe that the boot process is looping before it gets to the point where usb communication is working. After the Virgin boot animation and android logo are displayed, the screen gives a quick flash with the cursor at the top and then goes back to displaying and big android logo across the middle of the screen and just repeating this process forever.

    Do you know if the unbrick procedure installs any kind of default recovery or not?

    Could the format of the sdcard be a factor? I was not sure which partitions it would expect to see on the card after an emergency install. I can format it any way it needs on my linux system.

    How can I tell if it is a ZV4 or ZV5 phone? I may have a nandroid backup of the original software somewhere. I'll try checking some places I may have uploaded it to.

    Thank you for your help!
    AndyOpie150 likes this.
    12-28-2013 01:36 PM
  2. AndyOpie150's Avatar
    Look at the post I linked you to then run again and see if it makes it all the way. If not try the KP-500.

    ADB will not work until the debugging settings is selected, which you can't do ubtil the ROM boots up.

    ADB and fasboot are totally diffrent.
    SD card doesn't play a part.

    If neither the KDZ or KP-500 worked, we will need to get the phone into the fasboot screen.

    The last ZV4's where available until October 2011. The first ZV5's came out in late August of 2011. The ZV5's have a locked bootloader (very hard to get into fastboot screen). The first ZV5's still used the Novatek screen. By November 2011 they switched to the Hitachi screen.
    If you have a Hitachi screen you must never use the ZV4 firmware.
    Posted via Android Central App
    yaconsult likes this.
    12-28-2013 03:14 PM
  3. yaconsult's Avatar
    I linked to the full log of the [GUIDE] Unbrick/Upgrade Optimus V [EASY] [KDZ] debrick procedure in the post just before yours. At the end of it, it has:
    23:47:52 : CDMA: wParam = 7, lParam = 100
    23:48:20 : CDMA: wParam = 20, lParam = 110
    23:48:20 : Model Dll Msg Not Found(20, 110)
    23:48:20 : CDMA: wParam = 8, lParam = 0
    23:48:20 : Step : Phone Reset(DLL Cmd)
    23:48:38 : CDMA: wParam = 11, lParam = 0
    23:48:38 : Step : Phone Reset
    23:48:38 : CDMA: wParam = 20, lParam = 0
    23:48:38 : Model Dll Msg Not Found(20, 0)
    23:48:38 : CDMA: wParam = 12, lParam = 1
    23:48:38 : Step : UPDATE FINISHED!
    23:48:38 : ResetStartInfo() Call
    23:48:38 : _DetachDLL Call
    23:48:38 : _DetachDLL Call End
    23:48:38 : FreeLibrary Call
    23:48:40 : FreeLibrary Call End
    23:48:40 : ResetStartInfo() Call End
    23:48:40 : OnModelDllMsg(OnMsgFromModelDll-CDMA) delete m_pLGCyonUpdate
    23:48:40 : ===FINISHED===
    It says successful, but there are also some "not found" messages. Are those normal/expected or does it indicate a problem even though it says success at the end?
    AndyOpie150 likes this.
    12-28-2013 03:32 PM
  4. AndyOpie150's Avatar
    The dll messages are normal.
    Try the KP-500 for the ZV5 that I linked you to, unless you have figured out your phone has a Novatek screen, then and only then, use the KP-500 for the ZV4 I linked you to.

    Posted via Android Central App
    yaconsult likes this.
    12-28-2013 04:41 PM
  5. yaconsult's Avatar
    I was playing around with kp500 but I'm wondering now if there is a connection problem. I had noticed that the phone was constantly connecting from usb when it was in emergency mode. I assumed that this was because the phone while in emergency mode might be retrying to establish a connect. But now I'm wondering if it's a problem.

    I have tried three different usb cables on two different computers and in all cases, while the phone is in emergency mode, it keeps reconnecting and kp500 pops up a connection error and retry. Should it just connect once and stay connected?
    12-28-2013 05:07 PM
  6. AndyOpie150's Avatar
    It takes several tries to get the KP-500 to work.
    You did download and install the LG Mobile Support Tool, Right? You need to open it up, then close it once it connects. Then just keep going through the restart procedure (pull usb, and battery, reinstall battery, then get into emergency mode) until it finally works with no restart error.
    You need a good internet connection.
    yaconsult likes this.
    12-28-2013 05:26 PM
  7. yaconsult's Avatar
    OK, I'll try it a few more times. You have linked me to two zips: UnBrick OV KP500 and Unbrick OV KDZ. I understand that you are recommending that I keep trying the KDZ version. I will try doing it and making a screencast so you can see what is happening. Internet connection is not a problem - I have a very good and fast one.
    12-28-2013 07:02 PM
  8. AndyOpie150's Avatar
    I posted the KP-500 would be a better choice at this time (at least I think I did).

    Posted via Android Central App
    yaconsult likes this.
    12-28-2013 07:34 PM
  9. yaconsult's Avatar
    You did - my mistake. It seems that the problem I am having is that the phone keeps disconnecting and reconnecting before it can finish flashing. Here is the log:

    18:23:00 : [C:\LGMobileUpgrade] 丮 õ
    18:23:00 : RemoveDirectory1 Error(2):C:\LGMobileUpgrade
    18:23:00 : Start Date : 2013-12-28 18:23:00
    18:23:00 : -------- Buyer Test mode ---------
    18:23:00 : [C:\ProgramData\LGMOBILEAX\Phone] 丮 õ
    18:23:00 : RemoveDirectory1 Error(2):C:\ProgramData\LGMOBILEAX\Phone
    18:23:00 : *****CheckOS Start********
    18:23:00 : Microsoft_Windows_Vista Home Edition_
    18:23:00 : *****CheckPCSyncPrograms Start*****
    18:23:01 : PCSyncPrograms Not Found
    18:23:01 : SetEmerModeAT()
    18:23:01 : _IsConnectedPhone Call
    18:23:08 : _IsConnectedPhone(2)
    18:23:08 : 0 - NotConnected.
    18:23:08 : 1 - Normal connect success
    18:23:08 : 2 - Emergency connect success
    18:23:15 : Verifying phone connection...
    18:23:15 : dwWaitResetTime(40000 ms)
    18:23:16 : Phone Mode(2)
    18:23:16 : *****GetPhoneType Start*****
    18:23:24 : Phone Type : CDMA
    18:23:24 : *****Start GetPreviousStep*****
    18:23:24 : _GetPreviousStep(dwStep:0x5)
    18:23:24 : *****GetPhoneBinaryVersion Start*****
    18:23:24 : CSE mode -> Version Replace
    18:23:24 : *****Get ESN / IMEI / MEID Start*****
    18:23:36 : *****GetPhoneNumber Start*****
    18:23:38 : Phone Number : 00000000000
    18:23:39 : ˻ ĶŸ - ESN_IMEI : 00000000000, Model :
    18:23:41 : _GetAuthMark : wAuthMark(32177)
    18:23:41 : Wait 3Sec
    18:23:47 : _SetAuthMark Ok : wAuthMark(32177), PhoneMode(2)
    18:23:47 : *****CheckPCSyncPrograms Start*****
    18:23:47 : PCSyncPrograms Not Found
    18:23:48 : CLGMobileHttp Class Ҹ.
    18:23:48 : CLGMobileHttp Class Ҹ...
    18:23:48 : ****************CheckAndDownload********************
    18:23:48 : ******Extract Start c:\unbrick ov kp500\vm640zv4.cab*****
    18:23:48 : Model Dll Dir(C:\ProgramData\LGMOBILEAX\Phone\)
    18:23:48 : ExtractInfo Error(0)
    18:23:48 : Extract cab file error.
    18:23:48 : [C:\ProgramData\LGMOBILEAX\Phone] 丮 õ
    18:23:48 : RemoveDirectory1 Error(2):C:\ProgramData\LGMOBILEAX\Phone
    18:23:48 : !pUpgrade->StartProcessing ... PostMsg STEP_TYPE_ENV_ERROR
    18:23:48 : CLGMobileHttp Class Ҹ.
    18:23:48 : CLGMobileHttp Class Ҹ...
    18:23:48 : Page_Error κԴϴ
    18:23:48 : OnStepMsg STEP_TYPE_ENV_ERROR delete m_pLGCyonUpdate

    I wonder if the page error is due to the phone disconnecting? At this point, there is a popup which says "update stopped due to an error" and the only option is to exit. When I had tried the zv4 recovery, it seemed that the phone usually stayed connected once the program started writing to it.
    12-28-2013 08:34 PM
  10. AndyOpie150's Avatar
    Did you ever figure out if you had a Novatek screen, or an Hitachi?
    If Novatek use the ZV4 firmware.

    Posted via Android Central App
    yaconsult likes this.
    12-28-2013 08:38 PM
  11. yaconsult's Avatar
    Did you ever figure out if you had a Novatek screen, or an Hitachi?
    If Novatek use the ZV4 firmware.
    Not for sure. I'm comparing it to my early model phone which certainly has the old screen and it has a number stamped in the corner under the battery that is G114. On the phone that I am trying to recover, the stamped number is K11L. I know that it was purchased at least 6 months or more after I bought mine.

    I just completed the recovery again using the ZV5 version - you can see the log attached to this message to check for errors/problems. I will also attach a video of the phone booting after the recovery is complete. Couldn't attach the video showing the phone booting for some reason, even tried zipping it, but it's small so I just uploaded it to: VID_20131228_201620.m4v It's just over one minute long and will let you see what happens when the phone boots. You can see the screen flash just past the one minute mark and I believe that that is where the boot process is hanging for some reason.

    I have both phones plugged in to the computer at the moment and the adb status of the good phone is "device" while the status of the phone I am trying to recover is "offline" while it's sitting at that android logo that you see at the end of the video.
    Attached Files
    12-28-2013 10:35 PM
  12. AndyOpie150's Avatar
    When did you buy the spare. Have you noticed any difference in screen color.
    The Novatek was more vibrant, and the Hitachi was a shade too yellow.

    Posted via Android Central App
    12-29-2013 09:33 AM
  13. yaconsult's Avatar
    An online friend gave me the phone when he upgraded to a galaxy. I asked him when he got it and all he could tell me was: "2010 maybe, 2011 more likely, no idea really".

    I looked at the back of the phones and noticed that they have different numbers stamped in the metal just below the battery opening. My older working phone is stamped WS5-A and the bricked phone is stamped WS4-B. That surprises me because I know he bought his phone after I had mine for at least a year and I know that my phone has the first screen because I can recall back to when the black screen problem first cropped up and I still had the original bobz recovery installed from before he updated it to handle the newer screens. Then again, I guess there is no way to know how long a phone sat on a shelf or in a warehouse before it was shipped.
    12-29-2013 12:10 PM
  14. AndyOpie150's Avatar
    It's totally up to you at this point as to weather you want to try the ZV4. If it doesn't work the first time, we should be able to get into the fastboot screen to use fastboot commands to wipe all partitions and try again (if it is a ZV4). Then it shoukd work.
    This is how I unbricked my spare when it wouldn't go all the way with the KP-500 (because the partitions where a little messed up).

    Posted via Android Central App
    12-29-2013 02:46 PM
  15. thewraith420's Avatar
    If the zv4 firmware does the trick and unbricks the phone and it turns out he's got a zv5 phone phone then the worst thing would be that it wouldn't have the right screen driver. Droid@screen should allow use of the phone using the computer screen to see what your doing. You could then boot to your recovery and flash the zv9 update

    Sent from my XT907 using Tapatalk
    AndyOpie150 likes this.
    12-29-2013 05:33 PM
  16. yaconsult's Avatar
    This sounds good. The problem is that the zv4 burning utility doesn't seem to work on my phone because it keeps disconnecting and doesn't stay connected long enough for the burn to complete. But the zv5 utility does seem to be able to write its rom image to the phone and finish successfully. Is it possible to get a version of the zv4 firware that I can burn using the zv5 recovery program?
    12-29-2013 05:53 PM
  17. AndyOpie150's Avatar
    http://www.mediafire.com/?qo3jq95mbt9giz5
    Tell me how you setup your android sdk. Did you install the Java jdk6_u45? Remember I mentioned it might not make it, because your partitions are messed up. Try the KDZ, then when it doesn't make it, give me detailed info on how you set up the sdk.
    I just want to make sure everything is right before trying the fastboot commands.
    Posted via Android Central App
    12-29-2013 06:07 PM
  18. yaconsult's Avatar
    That seemed to work using the zip you uploaded. Here is a paste of the recovery log: optimus recovery - Pastebin.com

    The phone plays the startup noise but the screen never displays anything so it's probably the wrong screen version for this phone. Unfortunately, after giving it time to start, the status in adb is still offline.

    I have the android tools package installed on my fedora system which includes fastboot but 'fastboot devices' does not see the phone. 'adb devices' does but it remains offline.

    I tried booting into the stock recovery with power-volume down-home. I get a dark screen with faint lighting around the edges and when I type 'fastboot devices', I get '??????????? fastboot'. So does that mean I have it in fastboot mode?
    12-29-2013 11:46 PM
  19. yaconsult's Avatar
    Well, I think this is progress! Since I was able to see the phone in fastboot mode I found that after doing the recovery reboot with the keys, I could see the phone with adb and it was in recovery mode rather than offline! So I tried flashing skinbark's latest recovery. When I still had no screen working, I tried bobz's standard recovery that is reported to work with both screens.

    ~ # flash_image recovery VM670NH_recovery.img
    mtd: successfully wrote block at 0
    mtd: successfully wrote block at 20000
    mtd: successfully wrote block at 40000
    mtd: successfully wrote block at 60000
    mtd: successfully wrote block at 80000
    mtd: successfully wrote block at a0000
    mtd: successfully wrote block at c0000
    mtd: successfully wrote block at e0000
    mtd: successfully wrote block at 100000
    mtd: successfully wrote block at 120000
    mtd: successfully wrote block at 140000
    mtd: successfully wrote block at 160000
    mtd: successfully wrote block at 180000
    mtd: successfully wrote block at 1a0000
    mtd: successfully wrote block at 1c0000
    mtd: successfully wrote block at 1e0000
    mtd: successfully wrote block at 200000
    mtd: successfully wrote block at 220000
    mtd: successfully wrote block at 240000
    mtd: successfully wrote block at 260000
    mtd: successfully wrote block at 280000
    mtd: successfully wrote block at 2a0000
    mtd: successfully wrote block at 2c0000
    mtd: successfully wrote block at 2e0000
    mtd: successfully wrote block at 300000
    mtd: successfully wrote block at 320000
    mtd: successfully wrote block at 340000
    mtd: successfully wrote block at 360000
    mtd: successfully wrote block at 380000
    mtd: successfully wrote block at 3a0000
    mtd: successfully wrote block at 3c0000
    mtd: successfully wrote block at 3e0000
    mtd: successfully wrote block at 400000
    wrote recovery partition

    [root@giga Downloads]# adb devices
    List of devices attached
    0123456789ABCDEF recovery

    But after that, adb reboot recovery seems to just sit there. So I pull out the cable and battery and boot with home-volume down-power but all I get is a black screen with lighting around the edge. adb sees it as being in recovery mode, but there is nothing on the screen:

    # adb devices
    List of devices attached
    A1000019429799 recovery

    Where can I go from here??? And why the heck doesn't the screen work with with this recovery? Is it because I have the wrong ZV version?

    Now that I have the phone working in recovery mode I can see that it has the hitachi screen, which according to posts in this forum has zv5. My original, working phone, has the novatek screen and zv4.

    If I don't boot into recovery and let the phone do a normal boot, it makes the startup sounds but the screen stays blank and the phone never comes online for usb - adb devices shows it as offline.

    Thanks!
    12-30-2013 01:07 AM
  20. AndyOpie150's Avatar
    Are you doing all of this with a Linux distro? The KDZ and KP-500 are supposed to used in a Windows OS.
    To properly set up the Android SDK on your Linux distro go here: https://www.linuxdistrocommunity.com...d.php?tid=1621
    If everything checks out then with the phone in the recovery, open a terminal type in this:
    Code:
    adb shell
    adb reboot bootloader
    If it makes it into the fastboot screen (might not if it's a ZV5), then type in this:
    Code:
    fastboot erase recovery
    fastboot erase boot
    fastboot erase cache
    fastboot erase userdata
    fastboot erase system
    Then run the ZV5 KDZ or KP-500 from a Windows OS again.
    This is what I had to do with my ZV4.

    The problem your having is that when you try to flash the ZV5 firmware one of the partitions is not getting properly erased (the image is being flashed on top of the old image, until the partition becomes totally full), so you need to do it manually with fastboot commands.

    If you can't get it into fastboot screen we will have to try something else to get it into the fastboot screen.

    Note: You could try Droid@Screen to see your recovery menu from your computers screen, then try to flash a ROM and Gapps.
    Works great for me on my Xubuntu distro. I had to install the Oracle Java jdk6 and not the open jdk6. The SDK had to be set up properly as well, so go to the link I gave you and make sure all that is setup, then download the Droid at Screen.jar and place on your desktop. Right click on it then select to open with the Oracle Java jdk6. Set the path to the adb.exe and you should see your recovery menu on your computer screen.
    yaconsult likes this.
    12-30-2013 06:45 AM
  21. thewraith420's Avatar
    As I said at this point I'd fire up droid @ screen and use the zv9 update from your stock, but black screened recovery.

    Sent from my XT907 using Tapatalk
    yaconsult likes this.
    12-30-2013 09:26 AM
  22. AndyOpie150's Avatar
    If he does have a ZV4, or at the very least a Novatek screen, it will lock the bootloader.
    I would like to see for sure what baseband he has and what screen before that is done.
    I'm not a personal fan of the ZV9, especially for a phone that is going to be used for ROM testing.
    If he can flash the MiRaGe ROM and gapps we can determine what screen he has fo sure. If he has a Novatek screen we can flash a ZV4 with an unlocked bootloader. This would be the best thing for a ROM and recovery testing phone.

    Posted via Android Central App
    yaconsult likes this.
    12-30-2013 11:02 AM
  23. thewraith420's Avatar
    Maybe I'm wrong but he said the zv4 stuff worked and confirmed it by adb while in recovery. He's on zv4 so the bootloader is unlocked at this point. Just can't see anything due to the wrong screen driver. Its a lot less steps to fire up Droid@screen and flash zv9 update then to Root while on blank screen and flash a custom recovery then flash mirage

    Sent from my XT907 using Tapatalk
    yaconsult likes this.
    12-30-2013 12:32 PM
  24. yaconsult's Avatar
    Andy, you missed the part at the end of my recovery log post above at the end where I confirmed that the phone has the hitachi screen using adb, dmesg and grep.

    I can work in both windows and fedora linux environments. I have the adb-tools installed on fedora and that's where I used the adb and fastboot commands. I used windows 7 for running the windows recovery programs.

    The current status of the phone after flashing the bobz recovery logged above is that when I boot into recovery mode with home-vol down-power, I can see the phone in adb and it is in recovery mode. The screen is black. fastboot does not see the phone when it is in this mode but adb does.
    12-30-2013 12:35 PM
  25. thewraith420's Avatar
    You can try adb reboot bootloader. Probably still won't be able to see anything on the screen but adb reboot bootloader should work now.. On another note you have the vm670nh.img recovery flashed but it still won't show anything on screen?

    Sent from my XT907 using Tapatalk
    12-30-2013 01:04 PM
167 ... 4567
LINK TO POST COPIED TO CLIPBOARD