1. capslock118's Avatar
    Hi everyone,

    I just bought a 32GB sdhc card. At first it mounted just fine on my windows 7x64 machine. I opened up minitool partition wizard home edition to format the card with about 2GB for sd-ext and the rest for fat32. It said it was successful but now the card will not mount in windows 7 or in my optimus V phone (which supports 32gb sdhc).

    So then I tried to format the card with CWM instead directly on the phone. Here is the log from that experience:

    Partitioning SD Card... please wait...

    checking script requirements...done

    unmounting all partitions...done


    partition 1 may not be aligned to cylinder boundaries.
    to continue, this must be corrected.

    this action will remove all data from your sdcard.

    correcting cylinder boundaries...sh: 0: unknown operand
    done


    err: must have a fat32 partition greater than 0MB

    Done!
    Basically I think minitool screwed up my card (or i did using the wrong settings) or the card was already bricked; but not so much that my card cannot try to read it. However, I can't mount the card in my phone in CWM or if the phone had the rom loaded. Further, I can't see it when invoking fdisk -l through ADB.

    Does anyone know if there is a way to somehow fix this cylinder issue or do you think this card is bricked and is not even heavy enough to be a paper weight?

    thanks.
    08-17-2012 12:07 PM
  2. bkttk2's Avatar
    Will minitool recognize your card at all?

    If so I would recommend trying to reformat the entire card including the sd-ext. If this works try minitool again and create two partions. One as FAT32 - ensure you set as primary. For your sd-ext partition also format this as FAT32 and again set as Primary. Ignore the Windows will not recognize message.

    If you made it this far you should be able to put your card back in your phone reboot and see if it works. Another option, again using minitool, would be to format the entire card as FAT32 setting selection to Primary. Hopefully card is then back to being able to be fully recognized. Place card in Optimus V boot into recovery and then partition using CWM.

    Hopefully this info helps. Understand you will not be able to try any of the suggestion if the minitool does not recognize your card. Hopefully it is salvageable.
    08-17-2012 01:01 PM
  3. capslock118's Avatar
    It doesn't, although I will try again for giggles.

    basically windows 7 doesn't recognize the thing so minitool can't reach it either.

    I only have ubuntu on a virtual machine but trying to have that os recognize it through fdisk it just gives up; that might be windows 7 though since ultimately it has to go through that to get to the usb if I understand right.
    08-17-2012 01:24 PM
  4. capslock118's Avatar
    it looks like CWM uses sdparted to do these operations.

    I tried running that through adb manually but it failed with the same error:

    err: must have a fat32 partition greater than 0MB
    08-17-2012 01:47 PM
  5. capslock118's Avatar
    correction,

    give it enough time and minitool boots up and shows a disk 2 with 8gb capacity; the size doesn't make sense, but that must be the sdcard.

    i have no options though in minitool to do anything with it

    Attachment 34767
    08-17-2012 03:36 PM
  6. bkttk2's Avatar
    Not sure I have much else to suggest at this time. Will see if anyone else has suggestions. Since it is showing bad disk think it may be gone.

    I did find this

    32gb SDHC card won't woek after format - xda-developers

    Not tons of info but may provide a hint of something else to try than buying a new one. Good Luck!!
    08-17-2012 04:33 PM
LINK TO POST COPIED TO CLIPBOARD