1. mayverywellbe's Avatar
    My sd-ext partition doesn't seem to be getting detected anymore. All the apps show up in the list of apps in settings but nothing shows up in the drawer and the shortcuts on the main screen tell me they're not installed. The main partition is fine. This is after I dropped my phone and the battery popped out so it didn't shut down properly and it was like this when I turned it back on. I've tried remounting and taking it out and putting it back in again and it still doesn't mount. Is there a way to get that partition back? I'm running Quattrimus ICS CM9
    09-05-2012 05:13 PM
  2. sellersj27's Avatar
    Have you tried clearing cache/dalvik cache? I think that your sd-ext will be rewritten once your dalvik is cleared.
    09-06-2012 07:47 AM
  3. clodfelterac's Avatar
    probably not the quick fix youre looking for, but
    -copy sd to pc
    -repartition sd in recovery
    -copy sd(copy) to sd(fresh)
    -full wipe
    -flash rom/gapps
    09-06-2012 02:14 PM
  4. mayverywellbe's Avatar
    Yeah I was kind of hoping for a solution that didn't involve me having to reinstall/recover everything or reflashing anything.
    09-06-2012 05:02 PM
  5. G.Monroy.92's Avatar
    I am having kind off the same issue, but my sd card just wont mount at all for anything. I have tried 3 different sd cards.

    I have also tried formating the sd cards no the pc and clearing all the date (doing it on the pc bc my phone wont my mount the sd card to doi it in there)
    09-07-2012 12:49 AM
  6. mayverywellbe's Avatar
    So I tried clearing only the sd-ext partition (using MiniTool Partition Wizard) and reformatting and reflashed and I don't think I did it properly since space seems to be running out quicker when I ran titanium backup and some apps won't install and they won't even update and when I try to get from the app store it keeps telling me that packages are invalid. So I guess I'll try reformatting in recovery. I should be able to get away with only reformatting the sd-ext partition right and leaving the main one alone?
    09-10-2012 12:35 PM
  7. clodfelterac's Avatar
    i always partition via recovery... 1g/0swap... ive used sandisk, but run a pny in my daily... repartitioning/full wipe/reflash has always solved the problem for me, granted ive only ran into the errors once or twice... :-)
    09-10-2012 01:19 PM
  8. adamhos's Avatar
    Depends on how the rom is written an what you made your partition
    I notice some will work with ext4
    Others need ext2 or fat32
    And I always use windows disk management or mini partition tool

    Sent from my VM670 using Android Central Forums
    09-10-2012 04:01 PM
  9. mayverywellbe's Avatar
    Well this happened again. Didn't even drop it this time. Started Endomondo, put it in my bag, took it out like 10 minutes later and yeah. Could this be a problem with the ROM and whatever script it uses to move the apps to the sd-ext partition? Should I ask on the thread for it?
    10-06-2012 02:10 PM