08-07-2017 09:49 PM
1,625 ... 1011121314 ...
tools
  1. bigsupersquid's Avatar
    it is pm.sleep_mode killing accelerometer.
    it's set to power collapse. turning that up actually fixes the darn thing.
    inconsistent bunk.
    //edit: duh.
    this kernel has the p500 ami304 driver.
    their ami304d binary is different.
    including it in the rom gets rid of the calibration loop for good.
    and the pa gapps work fine on os2sd. slicker than the skinny gapps.
    they're too big for the internal install though.
    03-02-2014 05:18 PM
  2. chedder66's Avatar
    awesome. I'll fix the keys....

    Sprint fix and Verizon fix added to first post. .
    Thanks. On the newest fix it seems like both home and menu are set to home. I borrowed a kl from a sprint build for now.

    Does the play store work on the internal build? Did I miss some trick on getting it working?
    03-02-2014 08:00 PM
  3. bigsupersquid's Avatar
    Thanks. On the newest fix it seems like both home and menu are set to home. I borrowed a kl from a sprint build for now.
    that I need to do as well to drop in the zip instead of trying to patch one.
    Does the play store work on the internal build? Did I miss some trick on getting it working?
    it does, but flashing can be glitchy.
    reboot recovery, mount internal system, flash regular skinny gapps. pa gapps won't fit and sd gapps install to the wrong place. if it's still twitchy it may want philz or regular cwm recovery.
    chedder66 likes this.
    03-02-2014 08:43 PM
  4. bigsupersquid's Avatar
    //edit: duh.
    this kernel has the p500 ami304 driver.
    their ami304d binary is different.
    including it in the rom gets rid of the calibration loop for good.
    finally.
    zram enabled too.
    adb shell free
    total used free shared buffers
    Mem: 422888 347256 75632 0 12820
    -/+ buffers: 334436 88452
    Swap: 65532 0 65532
    rebuilding before upload.

    I find it amusing that my optimus v has absorbed proprietary system binaries not only from the optimus s with the same hardware, but also the optimus one with a different SoC.
    03-03-2014 09:48 AM
  5. TrikkJames's Avatar
    Hi can someone here confirm that Google+ works on this ROM? The app I mean.
    03-03-2014 03:55 PM
  6. chedder66's Avatar
    . if it's still twitchy it may want philz or regular cwm recovery.
    I think system was just too full. It worked after I deleted a few things

    If anyone is looking to try the internal build, the "fixed" int2ext zip floating around from jb seems to work okay.
    bigsupersquid likes this.
    03-03-2014 07:42 PM
  7. bigsupersquid's Avatar
    no g+ account, never tried the app.

    r2.0 kernel uploaded. mount /system before flashing. use twrp for os2sd, mount os2sd system before flashing.
    contains ami304d, and new updater-script to handle internal or OS2SD depending on which /system is mounted at the time.

    build having issues, big cm sync. ugh.
    so I put up the kernel with the accelerometer fix included. Since that ami304d is nonstandard for thunderc it's appropriate to have it with the kernel anyway.
    03-03-2014 07:56 PM
  8. Lpen21's Avatar
    Hi can someone here confirm that Google+ works on this ROM? The app I mean.
    Loaded ok but FC while attempting to sign in.
    03-03-2014 07:56 PM
  9. TrikkJames's Avatar
    Loaded ok but FC while attempting to sign in.
    I tried earlier and yeah the newest update causes a lot of problems for most people. Same for me on every ROM...doesn't allow signing in and force closes when attempting to open.
    03-04-2014 12:14 AM
  10. bigsupersquid's Avatar
    p500 accelerometer middleware. fixes rotation. zram enabled. probably some other changes.
    cm-11-20140303-OS2SD-thunderc.zip

    day-old stale build with patched ami304d so you all can have access to zram. can't build right now, big upstream mess.

    internal users, sorry. no recent build to tweak. flash the r2.0 kernel with /system mounted to fix accelerometer.
    dingermtb likes this.
    03-04-2014 10:18 AM
  11. daffy_duck_nj's Avatar
    Just tried the OS2SD build, the one before 0303. For some reason, it loads slowly for me. Formatted a Class 4 card with TechVendetta's TWRP recovery before flashing. Followed your directions to flash ROM and skinny gapps sd. Would flashing the entropy speedup fix help in my case? The other problem is that I can't use WiFi with it. I don't use this V as my main phone ATM.

    My version of the V is the older one with the Novatek screen. It shipped with 2.2.1. (purchased June, 2011) Otherwise I'm going back to the internal version, the newer clockwork recovery for the V, and installing the updated kernel. My card seems fine, and before I flashed this ROM, it was running smoothly with the MirAGE GB rom.
    03-04-2014 11:38 AM
  12. bigsupersquid's Avatar
    Just tried the OS2SD build, the one before 0303. For some reason, it loads slowly for me. Formatted a Class 4 card with TechVendetta's TWRP recovery before flashing. Followed your directions to flash ROM and skinny gapps sd. Would flashing the entropy speedup fix help in my case? The other problem is that I can't use WiFi with it. I don't use this V as my main phone ATM.

    My version of the V is the older one with the Novatek screen. It shipped with 2.2.1. (purchased June, 2011) Otherwise I'm going back to the internal version, the newer clockwork recovery for the V, and installing the updated kernel. My card seems fine, and before I flashed this ROM, it was running smoothly with the MirAGE GB rom.
    try the most recent os2sd before going to the internal, the 3/3
    crossbreeder probably won't help loading times. a slow card will make it unbearable. test card read/write speeds with an app maybe.
    03-04-2014 12:01 PM
  13. Lpen21's Avatar
    Need clarification- I have the 0301(os2sd) build, to update to the latest what are the steps. Do I mount system and os2sd system the flash?
    As far as the previous post regarding sd cards found that out the hard way. Don't skimp on sd card quality or you will be bogged down like there is now tomorrow with endless lag. I have a sandisk 8g card now which is awesome and can take the abuse.
    03-04-2014 12:43 PM
  14. Lpen21's Avatar
    Just tried the OS2SD build, the one before 0303. For some reason, it loads slowly for me. Formatted a Class 4 card with TechVendetta's TWRP recovery before flashing. Followed your directions to flash ROM and skinny gapps sd. Would flashing the entropy speedup fix help in my case? The other problem is that I can't use WiFi with it. I don't use this V as my main phone ATM.

    My version of the V is the older one with the Novatek screen. It shipped with 2.2.1. (purchased June, 2011) Otherwise I'm going back to the internal version, the newer clockwork recovery for the V, and installing the updated kernel. My card seems fine, and before I flashed this ROM, it was running smoothly with the MirAGE GB rom.
    This happened to me with a "cheap" sd I had laying around. Was slow to partion, keys in recovery stuck for like 30 sec and the ROM had terrible lag. The same card was fine running harmonia 2.09. I also have the old V.
    bigsupersquid likes this.
    03-04-2014 01:08 PM
  15. bigsupersquid's Avatar
    This happened to me with a "cheap" sd I had laying around. Was slow to partion, keys in recovery stuck for like 30 sec and the ROM had terrible lag. The same card was fine running harmonia 2.09. I also have the old V.
    My original V original sd card wouldn't even connect to 3g in gingerbread from sd, it was so slow. It's definitely a factor.

    I dunno what's up with the module size. small before system is compressed, too. Now I've gotta try a clean build and see if the kernel make-s differently in the android build system than by itself.
    03-04-2014 01:21 PM
  16. AndyOpie150's Avatar
    I'm using the 2GB SD card that originally came with the phone.
    ZV4 with Novatek screen.

    I flashed newest build with thekravens latest ClockworkMod recovery. I wiped everything including the dalvik cache. Then I formatted everything but the SD card.

    I'm using App Manager lll to move those apps that can be moved to the SD card.
    I added the entropy_n_rngd tool to the system.

    Interactive governor. 480min and 729max.

    Everything is working great. Entropy value is usually at 4096.

    PS: I used Link2SD just to delete those system apps I knew I didn't need, to free up a little more RAM. Currently running between 70% and 60% free.

    Posted via Android Central App
    03-04-2014 02:03 PM
  17. daffy_duck_nj's Avatar
    try the most recent os2sd before going to the internal, the 3/3
    crossbreeder probably won't help loading times. a slow card will make it unbearable. test card read/write speeds with an app maybe.
    This happened to me with a "cheap" sd I had laying around. Was slow to partion, keys in recovery stuck for like 30 sec and the ROM had terrible lag. The same card was fine running harmonia 2.09. I also have the old V.
    I bought my card from J&R in New York City. It's a Kingston Class 4, 32 GB. I bought that around the summer of 2012, when the PNY card (also class 4, 32 gb) I bought before that gave out. That card came from a Samsung Intercept... got rid of that phone in less than a week! That phone was a POS.

    I'll try the update.
    03-04-2014 02:59 PM
  18. AndyOpie150's Avatar
    Try the Sandisk class 4 micro SD. My 16GB has a read speed near 40MB/s. That is the best read speed you can get.

    Posted via Android Central App
    Lpen21 likes this.
    03-04-2014 04:26 PM
  19. bigsupersquid's Avatar
    hey Andy
    point me to the 3g and GPS tweaks you tried on slim?
    Try the Sandisk class 4 micro SD. My 16GB has a read speed near 40MB/s. That is the best read speed you can get.

    Posted via Android Central App
    03-04-2014 05:35 PM
  20. badblue1__'s Avatar
    EDIT :.... Sorry, phone went haywire on me and my clipper isn't copying links for some reason, but look in the sticky Op V Reference Guide, page 2 post #45

    Sorry for the screwup!
    bigsupersquid likes this.
    03-04-2014 06:39 PM
  21. badblue1__'s Avatar
    Phone got real hot while plugged in and typing on forums
    03-04-2014 06:46 PM
  22. bigsupersquid's Avatar
    I hope Andy doesn't mind, but i always keep this for future reference ...
    ...
    heh, that's a report post link. I can't use that...
    I like this
    the build default gps.conf was set to europe servers. ewww.
    badblue1__ likes this.
    03-04-2014 06:47 PM
  23. bigsupersquid's Avatar
    Need clarification- I have the 0301(os2sd) build, to update to the latest what are the steps. Do I mount system and os2sd system the flash?
    As far as the previous post regarding sd cards found that out the hard way. Don't skimp on sd card quality or you will be bogged down like there is now tomorrow with endless lag. I have a sandisk 8g card now which is awesome and can take the abuse.
    just boot into recovery and flash. do not reboot.
    mount os2sd system afterwards and flash gapps. mount os2sd data, then wipe dalvik cache and cache.
    then reboot system. it's only the first boot with a clean /data partition where you have to flash, reboot, flash, reboot...
    Lpen21 likes this.
    03-04-2014 06:50 PM
  24. badblue1__'s Avatar
    heh, that's a report post link. I can't use that...
    Sorry, see edit post, phone went haywire on me!
    03-04-2014 07:18 PM
  25. badblue1__'s Avatar
    For better 3G connections go to /system/etc/sysctl.conf Add this: Code:

    # sysctl.conf file vm.overcommit_memory = 1 vm.panic_on_oom = 0 vm.oom_kill_allocating_task = 0 vm.dirty_background_ratio = 90 vm.dirty_background_bytes = 0 net.ipv4.tcp_ecn=0 net.ipv4.route.flush = 1 net.ipv4.tcp_rfc1337 = 1 net ipv4ip no pmtu disc = 0

    For faster GPS locks go to: /system/etc/gps.conf Delete everything in it and add this: Code:

    NTP_SERVER=us.pool.ntp.org XTRA_SERVER_1=http://xtra1.gpsonextra.net/xtr a.bin XTRA_SERVER_2=http://xtra2.gpsonextra.net/xtr a.bin XTRA_SERVER_3=http://xtra3.gpsonextra.net/xtr a.bin DEFAULT_AGPS_ENABLE=TRUE DEFAULT USER PLANE=TRUE
    AndyOpie150 likes this.
    03-04-2014 08:49 PM
1,625 ... 1011121314 ...

Similar Threads

  1. Is moto x camera good for a vacation?
    By AImbriano in forum Moto X (2013)
    Replies: 19
    Last Post: 02-09-2014, 08:21 AM
  2. Case for Note 3 with the wireless charging battery/back cover
    By DocGo in forum Samsung Galaxy Note 3
    Replies: 1
    Last Post: 01-31-2014, 07:45 AM
LINK TO POST COPIED TO CLIPBOARD