08-07-2017 10:49 PM
1,625 ... 1112131415 ...
tools
  1. AndyOpie150's Avatar
    After looking at the GPS configure file already included in the ROM, it seemed better than the tweak posted by badblue1 (same one I used on Bean_Whiz).
    I now have service again, so I will also test on old V with 16GB SD card to see if 3G tweak gives a noticable improvement.
    badblue1__ likes this.
    03-04-2014 11:26 PM
  2. bigsupersquid's Avatar
    After looking at the GPS configure file already included in the ROM, it seemed better than the tweak posted by badblue1 (same one I used on Bean_Whiz).
    I now have service again, so I will also test on old V with 16GB SD card to see if 3G tweak gives a noticable improvement.
    funny, my gps.conf was horrid, had europe servers.
    I replaced it based on the last link I posted:
    NTP_SERVER=0.us.pool.ntp.org
    NTP_SERVER=1.us.pool.ntp.org
    NTP_SERVER=2.us.pool.ntp.org
    NTP_SERVER=3.us.pool.ntp.org
    NTP_SERVER=0.north-america.pool.ntp.org
    NTP_SERVER=1.north-america.pool.ntp.org
    NTP_SERVER=2.north-america.pool.ntp.org
    NTP_SERVER=3.north-america.pool.ntp.org
    NTP_SERVER=us.pool.ntp.org

    XTRA_SERVER_1=http://xtra1.gpsonextra.net/xtra.bin
    XTRA_SERVER_2=http://xtra2.gpsonextra.net/xtra.bin
    XTRA_SERVER_3=http://xtra3.gpsonextra.net/xtra.bin

    # DEBUG LEVELS: 0 - none, 1 - Error, 2 - Warning, 3 - Info
    # 4 - Debug, 5 - Verbose
    DEBUG_LEVEL =0

    # Intermediate position report, 1=enable, 0=disable
    INTERMEDIATE_POS=0

    # Accuracy threshold for intermediate positions
    # less accurate positions are ignored, 0 for passing all positions
    ACCURACY_THRES=0

    # Report supl ref location as position, 1=enable, 0=disable
    REPORT_POSITION_USE_SUPL_REFLOC=1

    # Wiper (wifi positioning), 1=enable, 0=disable
    ENABLE_WIPER=1

    ################################
    ##### AGPS server settings #####
    ################################

    # FOR SUPL SUPPORT, set the following
    SUPL_HOST=supl.google.com
    SUPL_PORT=7276
    SUPL_NO_SECURE_PORT=3425
    SUPL_SECURE_PORT=7275
    SUPL_TLS_HOST=FQDN
    SUPL_TLS_CERT=/etc/SuplRootCert

    # FOR C2K PDE SUPPORT, set the following
    C2K_HOST=c2k.pde.com
    C2K_PORT=1234

    CURRENT_CARRIER=common
    DEFAULT_AGPS_ENABLE=TRUE
    DEFAULT_SSL_ENABLE=FALSE

    # TRUE for "User Plane", FALSE for "Control Plane"
    DEFAULT_USER_PLANE=TRUE
    and I also combined two different sysctl tweaks from xda: battery data
    for testing purposes. I reduced them both to 1)remove errors and 2)remove unused settings.
    They are NOT baked into the rom ((yet.))
    #sysctl.conf file
    fs.nr_open=1053696
    fs.inotify.max_queued_events=32000
    fs.inotify.max_user_instances=256
    fs.inotify.max_user_watches=10240
    fs.lease-break-time=10
    fs.file-max=165164
    kernel.threads-max=525810
    kernel.random.write_wakeup_threshold=256
    kernel.random.read_wakeup_threshold=128
    kernel.panic=5
    kernel.panic_on_oops=1
    kernel.msgmni=2048
    kernel.msgmax=64000
    kernel.shmmni=4096
    kernel.shmall=2097152
    kernel.shmmax=268435456
    kernel.sem=500 512000 64 2048
    kernel.sched_child_runs_first=0
    fs.lease-break-time=10
    fs.file-max=65536
    vm.dirty_ratio=90
    vm.dirty_background_ratio=80
    vm.oom_kill_allocating_task=1
    vm.overcommit_memory=1
    vm.page-cluster=3
    vm.drop_caches=3
    vm.min_free_kbytes=4096
    vm.panic_on_oom=0
    vm.dirty_expire_centisecs=1000
    vm.dirty_writeback_centisecs=2000
    vm.oom_kill_allocating_task=0
    vm.vfs_cache_pressure=10
    vm.min_free_order_shift=4
    vm.laptop_mode=0
    vm.block_dump=0
    net.ipv4.tcp_ecn=0
    net.ipv4.route.flush = 1
    net.ipv4.tcp_rfc1337 = 1
    net.ipv4.ip_no_pmtu_disc = 0
    net.ipv4.tcp_sack = 1
    net.ipv4.tcp_fack = 1
    net.ipv4.tcp_window_scaling = 1
    net.ipv4.tcp_timestamps = 1
    net.ipv4.tcp_rmem = 4096 39000 187000
    net.ipv4.tcp_wmem = 4096 39000 187000
    net.ipv4.tcp_mem = 187000 187000 187000
    net.ipv4.tcp_no_metrics_save = 1
    net.ipv4.tcp_moderate_rcvbuf = 1
    AndyOpie150 and badblue1__ like this.
    03-05-2014 07:23 AM
  3. Lpen21's Avatar
    After flashing latest update had the following occur:
    Gained exchange mail icon which was missing before, very cool since I use it
    Gained a video/movie app(movie studio)
    Lost google search widget( may not replace anyway)
    Gained CM wallpapers
    Gained widget called "unified mail" but force closes when u try to use
    Noticed also had trebuchet launcher, this is where it got interesting. I originally had selected launcher 3, decided to try trebuchet and got caught in and endless "trebuchet has stopped working" loop. This happened on the welcome screen so could not access controls. Reboot did not help. Luckily status bar gave me access and I chose launcher3 again. Not sure if just me or anyone else have same happen. Overall prefer this since I gained exchange mail services.
    bigsupersquid likes this.
    03-05-2014 07:32 AM
  4. AndyOpie150's Avatar
    funny, my gps.conf was horrid, had europe servers.
    I replaced it based on the last link I posted:
    Sorry, I missed the Europe part. Between my bone marrow not functioning and to much amino acids in blood I 'm a mess. Not enough red and white bloods cells are produced and amino acids messing with brains synapsis. This is why I've had to back off helping.
    bigsupersquid and badblue1__ like this.
    03-05-2014 07:55 AM
  5. bigsupersquid's Avatar
    After flashing latest update had the following occur:
    Gained exchange mail icon which was missing before, very cool since I use it
    Gained a video/movie app(movie studio)
    Lost google search widget( may not replace anyway)
    Gained CM wallpapers
    Gained widget called "unified mail" but force closes when u try to use
    Noticed also had trebuchet launcher, this is where it got interesting. I originally had selected launcher 3, decided to try trebuchet and got caught in and endless "trebuchet has stopped working" loop. This happened on the welcome screen so could not access controls. Reboot did not help. Luckily status bar gave me access and I chose launcher3 again. Not sure if just me or anyone else have same happen. Overall prefer this since I gained exchange mail services.
    the only way to use trebuchet is to remover launcher3... didn't realize they were both in there.
    unified mail is broken, at least for me. won't start up. forgot to remove it.
    This was a personal test install... didn't plan to upload it but the big cm sync gacked my build system and I'll probably be stalled for days. The zram was a cool deal and I wanted to share it. There may well be other glitches.
    03-05-2014 08:16 AM
  6. bigsupersquid's Avatar
    Sorry, I missed the Europe part. Between my bone marrow not functioning and to much amino acids in blood I 'm a mess. Not enough red and white bloods cells are produced and amino acids messing with brains synapsis. This is why I've had to back off helping.
    sorry, Andy... I get brainfried without even being ill. No good excuses for me.
    03-05-2014 08:18 AM
  7. Lpen21's Avatar
    the only way to use trebuchet is to remover launcher3... didn't realize they were both in there.
    unified mail is broken, at least for me. won't start up. forgot to remove it.
    This was a personal test install... didn't plan to upload it but the big cm sync gacked my build system and I'll probably be stalled for days. The zram was a cool deal and I wanted to share it. There may well be other glitches.
    I'll take this any day of the week glitches and all. I mean who would have ever thought Kit Kat on a V and 1.7gigs free space. A big THANKS for sharing all this with us.
    03-05-2014 09:01 AM
  8. Lpen21's Avatar
    sorry, Andy... I get brainfried without even being ill. No good excuses for me.
    Andy, hope you don't' mind me asking, but where the steroid treatments they where giving you helping? I will continue to pray for you my friend.
    03-05-2014 09:04 AM
  9. AndyOpie150's Avatar
    Yes. He only perscribed enough to see if it would work. Then He had me give blood for a LFT and CVC test. Now I have to wait for next appointment to find out results. I'll probably be on them till I die. Off of them I'm back to being worse.
    03-05-2014 12:40 PM
  10. Lpen21's Avatar
    Yes. He only perscribed enough to see if it would work. Then He had me give blood for a LFT and CVC test. Now I have to wait for next appointment to find out results. I'll probably be on them till I die. Off of them I'm back to being worse.
    Glad to hear it, hopefully good news at your next appointment.
    ppossumm and AndyOpie150 like this.
    03-05-2014 02:03 PM
  11. AndyOpie150's Avatar
    Just tried the OS2SD version. 16GB SD card formatted with techvendetta's TWRP recovery. GPS, 3G, and entropy tweaks.
    It's a little laggy even at 480-729.
    Other than that it is the future of ROM development for the V.
    I had already installed about 20 apps before installing a 101MB app which ends up being over 140MB after install and initializing.
    I really like it.
    I installed the latest google play services apk from a folder with all my saved apk's. Google Play Store then worked flawlessly if not a bit laggy
    bigsupersquid: I really think all your efforts should be concentrated on the OS2SD version. I'll try to help where possible.

    Posted via Android Central App
    bigsupersquid likes this.
    03-07-2014 04:50 PM
  12. TrikkJames's Avatar
    Alright peeps, I figured out why Google+ doesn't run on this ROM.

    I installed GB, and downloaded Google+. I immediately noticed a difference in the size of the file. The G+ that appears in ICS, JB, and KK are all 33.5mb. And the version that appears in Froyo and GB are 13.97mb.

    Two different apks. So, since the 33mb version doesn't work due to it being more "advanced", I'm gonna try something and hopefully one of you can test it for me. If it works, by all means include my post in the OP for Google+ users!

    Here's the 13.97mb version that I uploaded to Google Drive: https://docs.google.com/file/d/0B_v9...E4yUkdxYlVJV0U

    Tell me if it works. If yes, I'll update my post with a more longer lasting link and better explanation.
    Update: This method doesn't work. However if you're smart enough to figure out how to solve this issue, be my guest.
    AndyOpie150 likes this.
    03-07-2014 05:10 PM
  13. nitestalkr's Avatar
    For some reason my phone self rebooted and everything started to force close, and i got stuck in the infamous trebuchet loop. Fixed by reflashing, just thought i'd mention it so others know they're not the only ones with this issue.

    It seems to occur after a few weeks of use on a single update.

    Sent from my LG-VM670 using Xparent Red Tapatalk 2
    bigsupersquid likes this.
    03-07-2014 05:17 PM
  14. AndyOpie150's Avatar
    Do you turn the phone off every day, or do you leave it on 24-7 like I do?
    03-07-2014 07:08 PM
  15. TrikkJames's Avatar
    Hey Andy, did the GB Google+ work on KK? Thought maybe since you thanked my post that you tried it.
    03-07-2014 07:11 PM
  16. Lpen21's Avatar
    For some reason my phone self rebooted and everything started to force close, and i got stuck in the infamous trebuchet loop. Fixed by reflashing, just thought i'd mention it so others know they're not the only ones with this issue.

    It seems to occur after a few weeks of use on a single update.

    Sent from my LG-VM670 using Xparent Red Tapatalk 2
    I was able to get out of this by leaving the "trebuchet has stopped working" message alone and pulling status bar down which allowed me to get into settings and reapply the system launcher. I then deleted trebuchet. Admittedly Foolishly caused this myself by actually picking trebuchet.
    bigsupersquid likes this.
    03-07-2014 07:13 PM
  17. Lpen21's Avatar
    Just tried the OS2SD version. 16GB SD card formatted with techvendetta's TWRP recovery. GPS, 3G, and entropy tweaks.
    It's a little laggy even at 480-729.
    Other than that it is the future of ROM development for the V.
    I had already installed about 20 apps before installing a 101MB app which ends up being over 140MB after install and initializing.
    I really like it.
    I installed the latest google play services apk from a folder with all my saved apk's. Google Play Store then worked flawlessly if not a bit laggy
    bigsupersquid: I really think all your efforts should be concentrated on the OS2SD version. I'll try to help where possible.

    Posted via Android Central App
    Andy, I also installed crossbreeder and have no noticeable lag even at cpu settings below 729/480. I cranked it back up there per everyone's advice to do so , so maybe crossbreeder really helps. Also also I find that the skinny gaps zip seems a bit more stable to me the the other gaps package.
    AndyOpie150 likes this.
    03-07-2014 07:18 PM
  18. Lpen21's Avatar
    Alright peeps, I figured out why Google+ doesn't run on this ROM.

    I installed GB, and downloaded Google+. I immediately noticed a difference in the size of the file. The G+ that appears in ICS, JB, and KK are all 33.5mb. And the version that appears in Froyo and GB are 13.97mb.

    Two different apks. So, since the 33mb version doesn't work due to it being more "advanced", I'm gonna try something and hopefully one of you can test it for me. If it works, by all means include my post in the OP for Google+ users!

    Here's the 13.97mb version that I uploaded to Google Drive: https://docs.google.com/file/d/0B_v9...E4yUkdxYlVJV0U

    Tell me if it works. If yes, I'll update my post with a more longer lasting link and better explanation.
    No dice, does not install for me.
    03-07-2014 07:29 PM
  19. bigsupersquid's Avatar
    When I finally get a build going again, I'll make sure that trebuchet goes into the extras folder to avoid that nasty little loop.
    For now it's all borked, since the last big cm push I've had no 3g in builds, radio complains about not having nv settings or ruim chosen (and I have no sim card for ruim, so it must want nv.)
    It may be a while before I get to it. 4WD transmission replacement and house upgrades will be eating my personal time for a bit.
    I found the kernel module size issue,
    mdpath=`find out/target/product/thunderc/system/lib/modules -type f -name modules.order`; if [ "$mdpath" != "" ];then mpath=`dirname $mdpath`; ko=`find $mpath/kernel -type f -name *.ko`; for i in $ko; do prebuilts/gcc/linux-x86/arm/arm-eabi-4.7/bin/arm-eabi-strip --strip-unneeded $i; mv $i out/target/product/thunderc/system/lib/modules/; done; fi
    stripping. Regular build of the kernel does not do that.
    AndyOpie150 likes this.
    03-07-2014 07:55 PM
  20. nitestalkr's Avatar
    Do you turn the phone off every day, or do you leave it on 24-7 like I do?
    Yea, pretty much. Although when it dies, i usually let it be dead for a few hours throughout the day.


    I was able to get out of this by leaving the "trebuchet has stopped working" message alone and pulling status bar down which allowed me to get into settings and reapply the system launcher. I then deleted trebuchet. Admittedly Foolishly caused this myself by actually picking trebuchet.
    I was on 02202014 internal build when it happened, so i only had trebuchet.

    Sent from my LG-VM670 using Xparent Red Tapatalk 2
    bigsupersquid likes this.
    03-07-2014 08:01 PM
  21. bigsupersquid's Avatar
    ...
    bigsupersquid: I really think all your efforts should be concentrated on the OS2SD version. I'll try to help where possible.
    Posted via Android Central App
    ah, yes. I am looking at firerat's custom mtd partition mod for a speedup like skinbark was talking about early on with the OS2SD.
    Trying to use the kernel mtd swap functions fail with errors both with mkswap and swapon. And I don't imagine that /cache speed has a lot of effect on run speeds.
    So, I was thinking to combine the /system and /data partition space for just /system on mtd. Then card p2 becomes sd-ext, p3 data, and p4 still cache. CM wants sd-ext. Recovery and other things bork up p2 if not expecting it like the new twrp.
    With /system apps on one media and /data apps on another run times may improve like skinbark was thinking.
    I need someone with this running to post the dmesg from just after booting an optimus S... or optimus V with S firmware.
    Actually I only need these two bits:
    <6>[ 0.000000] Partition (from atag) boot -- Offset:141 Size:38
    <6>[ 0.000000] Partition (from atag) cache -- Offset:179 Size:371
    <6>[ 0.000000] Partition (from atag) recovery -- Offset:4ea Size:38
    <6>[ 0.000000] Partition (from atag) splash -- Offset:522 Size:a
    <6>[ 0.000000] Partition (from atag) FOTA_STO -- Offset:52c Size:8
    <6>[ 0.000000] Partition (from atag) system -- Offset:534 Size:524
    <6>[ 0.000000] Partition (from atag) userdata -- Offset:a58 Size:597
    <6>[ 0.000000] Partition (from atag) misc -- Offset:fef Size:4
    <6>[ 0.000000] Partition (from atag) persist -- Offset:ff3 Size:c

    <6>[ 1.402146] msm_nand_probe: phys addr 0xa0a00000
    <6>[ 1.402169] msm_nand_probe: dmac 0x7
    <6>[ 1.402228] msm_nand_probe: allocated dma buffer at ffde4000, dma_addr 2c432000
    <6>[ 1.402761] status: c00020
    <6>[ 1.402778] nandid: 5590bc2c maker 2c device bc
    <6>[ 1.402804] ONFI probe : Found an ONFI compliant device MT29F4G16ABBDA3W ,
    <6>[ 1.402844] Found a supported NAND device
    <6>[ 1.402859] NAND Id : 0x5590bc2c
    <6>[ 1.402873] Buswidth : 16 Bits
    <6>[ 1.402884] Density : 512 MByte
    <6>[ 1.402896] Pagesize : 2048 Bytes
    <6>[ 1.402909] Erasesize: 131072 Bytes
    <6>[ 1.402921] Oobsize : 64 Bytes
    <6>[ 1.402934] CFG0 Init : 0xa85408c0
    <6>[ 1.402948] CFG1 Init : 0x0004745e
    <6>[ 1.402961] ECCBUFCFG : 0x00000203
    <5>[ 1.402979] Creating 9 MTD partitions on "msm_nand":
    <5>[ 1.403008] 0x000002820000-0x000002f20000 : "boot"
    <5>[ 1.407849] 0x000002f20000-0x000009d40000 : "cache"
    <5>[ 1.464499] 0x000009d40000-0x00000a440000 : "recovery"
    <5>[ 1.469191] 0x00000a440000-0x00000a580000 : "splash"
    <5>[ 1.470971] 0x00000a580000-0x00000a680000 : "FOTA_STO"
    <5>[ 1.472586] 0x00000a680000-0x000014b00000 : "system"
    <5>[ 1.556716] 0x000014b00000-0x00001fde0000 : "userdata"
    <5>[ 1.648236] 0x00001fde0000-0x00001fe60000 : "misc"
    <5>[ 1.649569] 0x00001fe60000-0x00001ffe0000 : "persist"
    just to make sure that nobody with S firmware bootloops if they try it after the mod is in place.
    AndyOpie150 likes this.
    03-07-2014 08:02 PM
  22. TrikkJames's Avatar
    No dice, does not install for me.
    Dang. I was afraid of that. Well I tried.
    03-07-2014 10:34 PM
  23. AndyOpie150's Avatar
    Yea, pretty much. Although when it dies, i usually let it be dead for a few hours throughout the day.


    Sent from my LG-VM670 using Xparent Red Tapatalk 2
    Try not to let it die. Charge it up when it gets below 20%.

    Posted via Android Central App
    03-08-2014 02:27 AM
  24. AndyOpie150's Avatar
    Hey Andy, did the GB Google+ work on KK? Thought maybe since you thanked my post that you tried it.
    Haven't had chance till now, but looks like it won't work. Will try some other ideas though.

    Posted via Android Central App
    03-08-2014 02:29 AM
  25. AndyOpie150's Avatar
    ah, yes. I am looking at firerat's custom mtd partition mod for a speedup like skinbark was talking about early on with the OS2SD.
    Trying to use the kernel mtd swap functions fail with errors both with mkswap and swapon. And I don't imagine that /cache speed has a lot of effect on run speeds.
    So, I was thinking to combine the /system and /data partition space for just /system on mtd. Then card p2 becomes sd-ext, p3 data, and p4 still cache. CM wants sd-ext. Recovery and other things bork up p2 if not expecting it like the new twrp.
    With /system apps on one media and /data apps on another run times may improve like skinbark was thinking.
    I need someone with this running to post the dmesg from just after booting an optimus S... or optimus V.
    Are you saying you need a dmesg of OS2SD ROM right after bootup or OS2SD with the mod you mentioned?

    Posted via Android Central App
    03-08-2014 02:33 AM
1,625 ... 1112131415 ...

Similar Threads

  1. Is moto x camera good for a vacation?
    By AImbriano in forum Moto X (2013)
    Replies: 19
    Last Post: 02-09-2014, 09:21 AM
  2. Case for Note 3 with the wireless charging battery/back cover
    By DocGo in forum Samsung Galaxy Note 3
    Replies: 1
    Last Post: 01-31-2014, 08:45 AM
LINK TO POST COPIED TO CLIPBOARD