08-07-2017 09:49 PM
1,625 ... 4445464748 ...
tools
  1. Shinkenred's Avatar
    you can use the skinny-gapps-new with update-binary from the ROM zip for os2sd.
    Got'em. So how would I use the update binary? Just flash it before flashing skinny-gapps-new?
    08-25-2014 06:30 PM
  2. syguyice's Avatar
    Root/SuperUser doesn't seem to be all there; about half the apps that require root access I try fails by saying they couldn't find root/superuser, even with the SuperUser setting under Settings configured to allow everything. Things seem to improve a little after I flashed a new superuser from xda, but still not completely fixed. Is there a specific binary/procedure I should use to give proper/full root to apps?
    08-26-2014 05:47 AM
  3. bigsupersquid's Avatar
    Got'em. So how would I use the update binary? Just flash it before flashing skinny-gapps-new?
    move it from the rom zip to the gapps zip before putting it on the card.
    Root/SuperUser doesn't seem to be all there; about half the apps that require root access I try fails by saying they couldn't find root/superuser, even with the SuperUser setting under Settings configured to allow everything. Things seem to improve a little after I flashed a new superuser from xda, but still not completely fixed. Is there a specific binary/procedure I should use to give proper/full root to apps?
    never seen that before.
    you using internal or os2sd? more info.
    Shinkenred likes this.
    08-26-2014 01:02 PM
  4. Shinkenred's Avatar
    move it from the rom zip to the gapps zip before putting it on the card.
    ...just to be sure, how do I do that? WinZip isn't being very helpful.
    08-26-2014 04:59 PM
  5. bigsupersquid's Avatar
    ...just to be sure, how do I do that? WinZip isn't being very helpful.
    hm. if winzip will work at all, it should be able to drag-and-drop.
    open both zips, navigate inside to /META-INF/com/google/android/
    drag update-binary from that folder in rom zip to same folder in gapps zip, close both. save if it requires it.

    working on figuring out how to make twrp flash pre-tls stuff that's still recent. older update-binary doesn't make it have a fit.
    got the multi switch working smoothly without recovery reboot now. Recoded politely without any 'pkill recovery' and respawn involved, and I had the extra files all confusicated and I'm surprised it even worked
    Shinkenred likes this.
    08-26-2014 06:43 PM
  6. Shinkenred's Avatar
    hm. if winzip will work at all, it should be able to drag-and-drop.
    open both zips, navigate inside to /META-INF/com/google/android/
    drag update-binary from that folder in rom zip to same folder in gapps zip, close both. save if it requires it.
    ...scrap. That's not happening. It won't even open more than one zip at a time.

    UPDATE: Now it's opening both, but I seem to have gotten the update-binary out of the 06/28 os2sd and into skinny_gapps_new. Gonna have to clear out some room from my SD card so I can make a backup of my current setup.
    08-26-2014 06:54 PM
  7. MechaFenix's Avatar
    Is it worth it to create my own gapps? I find that I install the same google apps every time I break the rom or simply do a clean install. I would also like to be a little more daring like switching the mail with gmail and calendar with google calendar. One step at a time I guess.

    Maybe it will make a programmer out of me, or maybe I will go bald and grow a neck beard. I don't know. It might be worth exploring.
    08-27-2014 03:53 PM
  8. dradzanowski's Avatar
    TWRP works, beautiful.
    However, it says "can't mount /data, install failed
    Any suggestions?
    08-27-2014 09:08 PM
  9. bigsupersquid's Avatar
    TWRP works, beautiful.
    However, it says "can't mount /data, install failed
    Any suggestions?
    if the os2sd version you had installed predates my last changes you'll need to re partition the sdcard in twrp. sorry :/
    eventually I'll put checks in twrp to let users know if their card needs partitioned for os2sd.
    08-28-2014 05:39 AM
  10. Shinkenred's Avatar
    Hmm. Strange. I moved the update binary from the ROM to the skinny_gapps_new, and it STILL won't work. Making matters odder, the 0628 version of os2sd won't flash at all. It says "Failed to open (filename of os2sd cuz i can't remember all that)". Ugh...seems like nothing's playing nice anymore. I switched back to CWM to restore the backup of the other ROM I was using (which said backup was made in CWM), and THAT wouldn't work...it's like nothing wants to work.
    08-28-2014 12:07 PM
  11. syguyice's Avatar
    I'm on the 6/29 os2sd build. Reflashed superuser a few times with different versions, now it seems to work with most of my root apps, except for SU Update Fix, which I have since removed. It's usable for now with working camera, albeit seemingly a bit slower. I went through old posts and it seems that between 6/29 and 7/5+later builds, there were some library speed ups and wallpaper fix (fuzzy on the details). I also noticed some accelerator issues when using compass or racing games that use tilting for steering. Are there other issues in 6/29 os2sd I should watch out for?

    On a side note, I'm liking the os2sd builds much better than internals, which allowed me to install a lot more apps/games, including some old school 2D beat-em-ups that runs very smoothly.
    08-28-2014 12:09 PM
  12. dradzanowski's Avatar
    Oh, I switched over to Internal version (which is what I wanted anyway).
    It installs okay, and it boots, which is nice.
    However, I cannot flash the sprint fix. They come up with error executing updated binary in (zip file address)
    Update: tried the update binary switch, now the md5 is complaining at me. Checked the names of them, they're the same.
    08-28-2014 01:12 PM
  13. bigsupersquid's Avatar
    Oh, I switched over to Internal version (which is what I wanted anyway).
    It installs okay, and it boots, which is nice.
    However, I cannot flash the sprint fix. They come up with error executing updated binary in (zip file address)
    Update: tried the update binary switch, now the md5 is complaining at me. Checked the names of them, they're the same.
    yeah, you'll either have to redo the md5 file or delete it from the card. I'll look at all that, haven't checked it out in a while. Especially internal which has been a real PITA since the system grew 30MB or so unexpectedly.
    I'm on the 6/29 os2sd build. Reflashed superuser a few times with different versions, now it seems to work with most of my root apps, except for SU Update Fix, which I have since removed. It's usable for now with working camera, albeit seemingly a bit slower. I went through old posts and it seems that between 6/29 and 7/5+later builds, there were some library speed ups and wallpaper fix (fuzzy on the details). I also noticed some accelerator issues when using compass or racing games that use tilting for steering. Are there other issues in 6/29 os2sd I should watch out for?

    On a side note, I'm liking the os2sd builds much better than internals, which allowed me to install a lot more apps/games, including some old school 2D beat-em-ups that runs very smoothly.
    the last kernel release should fix your accelerometer problems. But there's no current binary uploaded. And I haven't tested HardLight's aav6 gerrit push of 3.0.101 yet enough to drop it out there immediately. It works ok in recovery but I haven't tried it in a rom yet.

    not to mention whether the tls-enabled kernel with the accel fix will work with the last good internal release. I dunno. Let me look into all of it over the next day or so and I'll see what I can hash out.
    08-28-2014 06:13 PM
  14. bigsupersquid's Avatar
    ugh, it's so hard to get focus and time in on upkeep.
    HardLight pushed kernel upgrade to 3.0.101 and f2fs. It seems clean enough...
    hard to build another release yet. twrp needs stabilized for f2fs.
    still haven't figured out the camera except the thunderc codecs are funny and maybe camera should be built from source again.
    Shinkenred likes this.
    08-30-2014 08:06 AM
  15. Shinkenred's Avatar
    Take your time with it, man. You'll get it all sorted out in due time. Cuz you're a beast like that with the development.

    Eh? Scrap. Tried that new TWRP multi_v4...it refused to install anything. Internal mode had the update binary error with the 0704 internal version, and os2sd mode simply won't touch the 0628 os2sd version. It fails to open. The other TWRP recoveries have the same problem. They won't touch 0628 at all...
    08-30-2014 11:08 AM
  16. badblue1__'s Avatar
    Fun thing to try:

    This hasn't crashed noticeably on me and seems to speed things up.
    Enough testers without obvious negative results and I'll incorporate it into the base ROM.
    Maybe with a backend for the functional, included automagically, CrossBreeder in it.
    Takes maybe 3MB of /system.

    ★ [MOD] ◢ PurePerformances™X ◣ | Siri Edition | Scary performances on your Ace

    It does stuff before the bootanimation so don't freak about the extended black screen booting up.
    Hey bss, sorry, i don't want to get off topic here, but i flashed back to MiRaGe rom to try out this Mod that you posted on the first page. It downloads along with the uninstaller, but when i try to copy and paste to the root of my sd card i keep gettin ( operation failed, file not found ) i've tried this several times to no avail. I tried posting in that thread on XDA but i don't have enough posts on XDA so they won't let me, maybe that's why the download of the files don't work? Dunno any ideas? Thanks in advance!
    08-31-2014 03:50 PM
  17. bigsupersquid's Avatar
    Take your time with it, man. You'll get it all sorted out in due time. Cuz you're a beast like that with the development.

    Eh? Scrap. Tried that new TWRP multi_v4...it refused to install anything. Internal mode had the update binary error with the 0704 internal version, and os2sd mode simply won't touch the 0628 os2sd version. It fails to open. The other TWRP recoveries have the same problem. They won't touch 0628 at all...
    you'll have to use the twrp that's the same age as the 6/28. the link to it is posted.

    Hey bss, sorry, i don't want to get off topic here, but i flashed back to MiRaGe rom to try out this Mod that you posted on the first page. It downloads along with the uninstaller, but when i try to copy and paste to the root of my sd card i keep gettin ( operation failed, file not found ) i've tried this several times to no avail. I tried posting in that thread on XDA but i don't have enough posts on XDA so they won't let me, maybe that's why the download of the files don't work? Dunno any ideas? Thanks in advance!
    xda doesn't require membership at all for downloading... they say it's to cut spamming.
    here, I grabbed this from that thread some time back.
    PurePerformances™X_CM.1.4(1).zip
    badblue1__ likes this.
    08-31-2014 04:03 PM
  18. badblue1__'s Avatar
    Thanks, still can't copy and paste to the root of my sd card, says operation failed? Never had a problem like this.
    08-31-2014 04:28 PM
  19. bigsupersquid's Avatar
    Thanks, still can't copy and paste to the root of my sd card, says operation failed? Never had a problem like this.
    do you have an external reader? or maybe try mounting the card in recovery instead of the ROM (or vice versa).
    badblue1__ likes this.
    08-31-2014 06:46 PM
  20. badblue1__'s Avatar
    do you have an external reader? or maybe try mounting the card in recovery instead of the ROM (or vice versa).
    No card reader, maybe i'll try tomorrow, 3g slower than a herd of turtles, or its this rom, anyway i'm done fartin around with this thing tonight...time to kick back,drink some beer and watch the nascar race!!! too aggrevated with how slow everything is
    08-31-2014 08:15 PM
  21. badblue1__'s Avatar
    do you have an external reader? or maybe try mounting the card in recovery instead of the ROM (or vice versa).
    Thanks bigsupersquid, i mounted in recovery and it installed. I got a little scared, it took awhile to reboot, but then i remembered you saying that it would. I looked in the system files and seen a default.prop right below build.prop, then under system/etc there is a new crossbreeder folder, also some extra files in init.d. I read on xda that this will work with the Fly-On mod, i hope so cause i had that already installed?

    Thanks for sharing this [MOD] i'll let you know if there are any noticeable improvements or ill effects. I have to read that thread again on xda, i have adfree adblocker, but this mod is supposed to have adblocker built in, i guess that could cause conflict i dunno.
    09-01-2014 11:22 AM
  22. bigsupersquid's Avatar
    Thanks bigsupersquid, i mounted in recovery and it installed. I got a little scared, it took awhile to reboot, but then i remembered you saying that it would. I looked in the system files and seen a default.prop right below build.prop, then under system/etc there is a new crossbreeder folder, also some extra files in init.d. I read on xda that this will work with the Fly-On mod, i hope so cause i had that already installed?

    Thanks for sharing this [MOD] i'll let you know if there are any noticeable improvements or ill effects. I have to read that thread again on xda, i have adfree adblocker, but this mod is supposed to have adblocker built in, i guess that could cause conflict i dunno.
    another goodie is that fivefour published his CrossBreeder control app... allows switching some functions on and off. I suspect it should work with other mods including CB like pureperformances.
    badblue1__ likes this.
    09-01-2014 03:16 PM
  23. bigsupersquid's Avatar
    for the camera, a test build has yielded the logcat info of bad autofocus.
    try in camera settings -> more settings -> focus mode -> infinity.
    then fc the camera in apps.
    09-01-2014 08:42 PM
  24. Shinkenred's Avatar
    you'll have to use the twrp that's the same age as the 6/28. the link to it is posted.
    Yeah...the "TWRP2.7.1.0_os2sd_v4.zip", right? That isn't playing nicely with the 06/28 os2sd OR the Skinny_gapps_new. The ROM simply refuses to flash, and I've downloaded it several different times, all with the same result - "unable to open" error. The gapps behaves oddly, usually, it gives the updater binary error, and sometimes, it fails to flash, thinking that the ROM isn't a 4.4.x one...for whatever odd reason.
    09-02-2014 06:00 PM
  25. bigsupersquid's Avatar
    Yeah...the "TWRP2.7.1.0_os2sd_v4.zip", right? That isn't playing nicely with the 06/28 os2sd OR the Skinny_gapps_new. The ROM simply refuses to flash, and I've downloaded it several different times, all with the same result - "unable to open" error. The gapps behaves oddly, usually, it gives the updater binary error, and sometimes, it fails to flash, thinking that the ROM isn't a 4.4.x one...for whatever odd reason.
    eww.
    well, the big breakage on the recent release is the camera... it can be mostly fixed by opening the settings in camera and changing the focus mode to infinity or macro, which works fine unless you try to take a picture first..., then you have to set the focus mode and then switch to videocam and back to still camera.
    as long as it's not set to autofocus it works fine without any messing with it, and it'll remember that setting between boots even.
    you might try that recent twrp and os2sd in case nothing else is beyond usability in the last release... otherwise, I'm still trying to sort out segfaults with older binaries that worked fine on previous recoveries like in the anykernel zips.
    when the gapps fail to flash while they complain about it, there's nothing in /system.... or at least no build.prop.
    Shinkenred likes this.
    09-02-2014 08:08 PM
1,625 ... 4445464748 ...

Similar Threads

  1. Is moto x camera good for a vacation?
    By AImbriano in forum Moto X (2013)
    Replies: 19
    Last Post: 02-09-2014, 08:21 AM
  2. Case for Note 3 with the wireless charging battery/back cover
    By DocGo in forum Samsung Galaxy Note 3
    Replies: 1
    Last Post: 01-31-2014, 07:45 AM
LINK TO POST COPIED TO CLIPBOARD