08-07-2017 10:49 PM
1,625 ... 4849505152 ...
tools
  1. bigsupersquid's Avatar
    if you can use adb, you can
    adb pull /data/app wherever_youre_putting_it
    or a root explorer in the rom can also do it. just copy /data/app to the sdcard (make a folder to drop it in for ease of use.)
    to restore it after a clean flash, use the file explorer and copy the contents of that back into /data/app. it should be some .apk's

    no need to apologize, all questions are valid though I ignore some.
    omgitsMATT likes this.
    09-27-2014 08:15 PM
  2. omgitsMATT's Avatar
    It worked, you're a rock star. Thanks, this is way better because now I was able to take Titanium with me along with it's license from the Play Store instead of having to resorting to dubious and mostly tedious forms just to use an app I Paid for

    edit, (a day or so later)

    No, I spoke to soon. For f' sakes it needs Google Play because it keeps wanting to verify the license is genuine every-time it opens up. Either way, your method is still way better and I don't even need to take TiBu with me (for the moment or at least on this device) because without it I can finally count the software I want on one hand and your tip made it happen
    bigsupersquid likes this.
    09-27-2014 08:44 PM
  3. syguyice's Avatar
    Hi Bigsupersquid, got a strange one for ya: my phone won't keep the settings under Settings -> Performance anymore, and keeps reverting back to settings from a week ago after reboot. Developer Options and other items inside Settings appears to stick, just not Performance. I've made sure "modify settings" under app ops (aka Privacy Guard) are not "denied" for android/play processes/apps. Before this happened, I had been changing Performance parameters repeatedly to try to resolve the freezing issues (zRam didn't completely fix it). Can you suggest the next step of troubleshooting, or let me know if I can manually modify the settings file for performance?

    Also, can I remove the swap partition if I don't want to use SD Swap?

    Another minor thing I've observed is that the memory usage under Running/Cached processes are usually 0B, which did not happen with the 0629 builds (internal or os2sd). I often check this for identifying runaway processes. I got a separate app for this purpose now so not a major issue.

    As a reminder, my current setup: 0906 os2sd on Optimus S. Thanks in advance.
    09-30-2014 10:02 AM
  4. bigsupersquid's Avatar
    Hi Bigsupersquid, got a strange one for ya: my phone won't keep the settings under Settings -> Performance anymore, and keeps reverting back to settings from a week ago after reboot. Developer Options and other items inside Settings appears to stick, just not Performance. I've made sure "modify settings" under app ops (aka Privacy Guard) are not "denied" for android/play processes/apps. Before this happened, I had been changing Performance parameters repeatedly to try to resolve the freezing issues (zRam didn't completely fix it). Can you suggest the next step of troubleshooting, or let me know if I can manually modify the settings file for performance?

    Also, can I remove the swap partition if I don't want to use SD Swap?

    Another minor thing I've observed is that the memory usage under Running/Cached processes are usually 0B, which did not happen with the 0629 builds (internal or os2sd). I often check this for identifying runaway processes. I got a separate app for this purpose now so not a major issue.

    As a reminder, my current setup: 0906 os2sd on Optimus S. Thanks in advance.
    the settings not sticking is odd.
    but for the reboots/freezes..
    Here, give this a shot. flash in recovery.
    I've been experimenting with dalvik settings and kernel minfree tweaks.
    it's for f2fs version, else you need to remove /system/etc/init.d/01fsck_f2fs from the zip.
    It's specifically for 0906 f2fs os2sd version, may break others.
    too bad the oom killer settings are embedded in framework, will need next release to tune those as well. but the dalvik and kernel minfree settings help some.

    you can turn swap partition size down to anything above zero. It needs to be there even if 1MB for the partition numbering scheme in the fstab.
    Attached Files
    syguyice likes this.
    09-30-2014 11:03 AM
  5. syguyice's Avatar
    Thanks Bigsupersquid, will try tonight. Should I wipe dalvik before flashing this? What would I lose if I wipe? Am also going to try Fix Permission in recovery as some other posts suggested; is there a specific file I should fix permission for for performance settings?

    I should probably google for a tutorial on what files are used for what in an android system...
    09-30-2014 01:08 PM
  6. bigsupersquid's Avatar
    Thanks Bigsupersquid, will try tonight. Should I wipe dalvik before flashing this? What would I lose if I wipe? Am also going to try Fix Permission in recovery as some other posts suggested; is there a specific file I should fix permission for for performance settings?

    I should probably google for a tutorial on what files are used for what in an android system...
    wiping dalvik loses some settings. that's all though. it'll boot slowly while it rebuilds.
    fix permissions, if it's even there in twrp, isn't supposed to work in kitkat cause of the selinux etc.

    I'd suggest wiping /system and dalvik, reflashing the rom etc. that'll leave your apps and most app settings. but fix any perms issues in system.
    09-30-2014 01:14 PM
  7. siryoink's Avatar
    Not sure where I've went wrong here, but I have a LG Optimus S with the ZVJ radio. Installed TWRP 2.8 and flashed the internal rom. Flashed the Sprint patch to it, then rebooted. OS seems to be running, but no cellular service. Wifi does work. Reflashed and still have the same issue. Any suggestions?

    Flashing back to my old rom until I can figure out what went wrong.
    10-01-2014 01:52 AM
  8. bigsupersquid's Avatar
    Not sure where I've went wrong here, but I have a LG Optimus S with the ZVJ radio. Installed TWRP 2.8 and flashed the internal rom. Flashed the Sprint patch to it, then rebooted. OS seems to be running, but no cellular service. Wifi does work. Reflashed and still have the same issue. Any suggestions?

    Flashing back to my old rom until I can figure out what went wrong.
    sprint patch is messed up, but it should only mess up messaging.
    Can you post a logcat to pastebin.com?
    oh, and thewraith420 would know better, but maybe you need the zvd-zvj patch:
    http://forums.androidcentral.com/lg-...ight=zvj+patch
    nitestalkr likes this.
    10-01-2014 06:22 AM
  9. omgitsMATT's Avatar
    I'm going to piggy back off the clock and wifi lag. I didn't notice until I got a new phone the other day and stopped paying my bill and only used the wifi. It's just a cheap Dollar Store TrakPhone but I don't plan to renew my bill, I'll just use the new phone to set my alarm
    10-02-2014 08:51 AM
  10. bigsupersquid's Avatar
    I'm going to piggy back off the clock and wifi lag. I didn't notice until I got a new phone the other day and stopped paying my bill and only used the wifi. It's just a cheap Dollar Store TrakPhone but I don't plan to renew my bill, I'll just use the new phone to set my alarm
    I get clock lag on mobile network now that it's a daily driver again.
    oddly, I didn't get that running solely on wifi.
    10-02-2014 11:09 AM
  11. Redchigh's Avatar
    Also Ive notoced that the sd card partitioner in the recovery makes three partitions, while the instructions mention 4, and "whats left" for sd card storage. Am I reading something wrong, or is one option missing?

    Also the recovery makes two of them ext4. The only menu for changing from ext4 to f2fs is in the wipe menu, above the slider.

    I'm assuming I go to wipe in os2sd mode and change system and data to f2fs. Correct?
    Will that wipe the sd card again?

    Whats the mechanical benefit to f2fs vs ext4?
    From my limited reading, i assume f2fs is faster, but a bit riskier?

    Ive also noticed that the internal version boots when the os2sd flash fails, which is great.

    I had a suggestion.. What would be really awesome, is if int2ext or link2sd could load apps in /os2sddata or os2sd/internal on an internal boot (if os2sd boot fails), so you'd have your apps either way...

    Posted via the Android Central App
    10-02-2014 11:42 AM
  12. omgitsMATT's Avatar
    Perhaps its a problem that behaves different for every device? How true is it that not all our phones, even though they're the same models, are not created equal? That may be why it's behaving oddly for everyone
    10-02-2014 11:45 AM
  13. bigsupersquid's Avatar
    Also Ive notoced that the sd card partitioner in the recovery makes three partitions, while the instructions mention 4, and "whats left" for sd card storage. Am I reading something wrong, or is one option missing?

    Also the recovery makes two of them ext4. The only menu for changing from ext4 to f2fs is in the wipe menu, above the slider.

    I'm assuming I go to wipe in os2sd mode and change system and data to f2fs. Correct?
    Will that wipe the sd card again?

    Whats the mechanical benefit to f2fs vs ext4?
    From my limited reading, i assume f2fs is faster, but a bit riskier?

    Ive also noticed that the internal version boots when the os2sd flash fails, which is great.

    I had a suggestion.. What would be really awesome, is if int2ext or link2sd could load apps in /os2sddata or os2sd/internal on an internal boot (if os2sd boot fails), so you'd have your apps either way...

    Posted via the Android Central App
    3 extra partitions, plus the regular sdcard partition. typo probably.
    f2fs supposed to be nicer to the card. uses a lot of space on there just to exist, though.
    if the flash succeeds, and os2sd fails because the card is bad or missing, it just won't boot. not until I fix all that up.
    can't really deal with int2/link2 things.
    Perhaps its a problem that behaves different for every device? How true is it that not all our phones, even though they're the same models, are not created equal? That may be why it's behaving oddly for everyone
    cards can cause a lot of issues too. went thru 4 different ones to find one that behaved nicely. the others, lots of fc's, slow operation, slow to wake.
    finally got an internal build at about 130MB. usable. only had to remove-project a hundred or so projects from the repo in roomservice.xml
    Shinkenred likes this.
    10-02-2014 12:55 PM
  14. Shinkenred's Avatar
    I get clock lag on mobile network now that it's a daily driver again.
    oddly, I didn't get that running solely on wifi.
    Yup. I mentioned plenty of times how the clock lags like mad for me when connected to Wi-Fi (I don't have phone service anyway, plus with Juice Defender I have "Tablet Mode", disabling the cell radio). Airplane mode, the clock works okay, but it misses alarm settings often.
    10-02-2014 09:12 PM
  15. BradN2's Avatar
    Yup. I mentioned plenty of times how the clock lags like mad for me when connected to Wi-Fi (I don't have phone service anyway, plus with Juice Defender I have "Tablet Mode", disabling the cell radio). Airplane mode, the clock works okay, but it misses alarm settings often.
    That's funny, I thought I got worse clock lag problems with the wifi turned off, almost like the wifi was keeping it from going to sleep or something, killing battery but keeping the clock correct.
    Shinkenred likes this.
    10-03-2014 01:28 PM
  16. omgitsMATT's Avatar
    For what it's worth Shinkenred, we have the same symptoms exactly. I'm going to have to try that tablet mode thing though, it sounds nice
    Shinkenred likes this.
    10-03-2014 02:30 PM
  17. Shinkenred's Avatar
    That's funny, I thought I got worse clock lag problems with the wifi turned off, almost like the wifi was keeping it from going to sleep or something, killing battery but keeping the clock correct.
    Just goes to show that devices really ain't created equal. If I have Airplane Mode enabled, the clock seems to work just fine...but like I said, it somehow *still* misses alarms. No idea why that is.
    10-03-2014 03:31 PM
  18. syguyice's Avatar
    An observation about WiFi: only 1 is allowed. I previously reported the phone doesn't search for wifi access points; in fact, it doesn't search for *anything* when there's already 1 wifi network configured. To search for other wifi access points, I have to remove that wifi network, or manually add another. If a wifi is manually added, only the 1st (aka newest, top) entry in the wifi list will be attempted; all others are ignored and not even scanned. In a way, the phone is almost treating WiFi like cell tower. This may also (partially) explain why I keep getting "cell standby" as the highest battery user on my phone, even when it's in airplane mode.

    Bigsupersquid: can you share which sd cards you tried failed, and which one works fine? I'm still getting those slowdown symptoms, and maybe I'll just have to shell out for that wonder card you have...
    10-03-2014 09:40 PM
  19. bigsupersquid's Avatar
    I have no wifi issues. Kick off one remembered network, it grabs another, and it scans like 10 in my neighborhood too.
    weird.

    Currently a lexar 16Gb, but two of those stunk, and I suspect off-brand knockoff copies.

    Advise buy new at reputable source. Supposedly wall-e-world (the wonderful wal of mart, as much as I hate to send any money their way) has decent cards.
    Class 4 suposed to be better than the fancy high-write-speed 10s and such. I have used decent HS and regular cards. Sandisk ok too.

    Maybe try ext4 version, f2fs is an unknown variable at this point.

    Soon I will drop an updated micro-internal build (dumbphone with everything else in extras folder) and new os2sd builds all with hopefully ram-hogging reduced and minor fixes.
    Shinkenred likes this.
    10-04-2014 09:47 AM
  20. BradN2's Avatar
    Probably F2FS has less problems from higher speed cards.

    I'd recommend, buy some SD card from walmart, buying them online is almost sure to get you something fake/not working if you go for a good price.
    10-04-2014 11:12 AM
  21. bigsupersquid's Avatar
    Probably F2FS has less problems from higher speed cards.

    I'd recommend, buy some SD card from walmart, buying them online is almost sure to get you something fake/not working if you go for a good price.
    bought a couple cruddy 16GB 'lexar' cards at BigLots. slow, glitchy, with f2fs, seemed ok on ext4. you may be onto something there.
    10-04-2014 11:53 AM
  22. Shinkenred's Avatar
    Big Lots is still around out there? WOW...the one near me went out of business earlier this year, got replaced with a furniture store this week.

    Walmart...ugh...they don't seem to like having *sales* on their memory cards...I can never find a decent one for cheap in-store. They have SanDisk cards for fairly cheap on their website, but in-store? No dice. Sucks because I'd really like to get my paws on a nice 32GB one...without breaking the bank for it.
    10-04-2014 01:17 PM
  23. lgrootnoob's Avatar
    I just ended up picking a samsung 32gb pro minisd from amazon for 21 bucks.
    Performance is amazing now.
    10-04-2014 03:51 PM
  24. omgitsMATT's Avatar
    I think Pittsburgh has 2 or 3 Big Lots, at least 2. I used to buy my blank DVDs from there, until I found out they're cheaper on Amazon and I can cherry pick the factory they were made from, meaning I can get better quality discs

    The day after I bought my TrakPhone and loaded a year's worth of minutes on it I fell into a Samsung Galaxy Note II, it just needed a screen replacement but after I fixed that it looks and runs like new. With so much development going on with this phone I think it's time for me to retire my LG Optimus V VM670

    I wanna say a quick thanks to you guys in this thread here in particular before I say good bye , with your help and even past discussions (because I've been lurking months prior to even posting) I was able to grasp things I never would have figured out anywhere else because you're so damned polite and patient, so thank you.
    bigsupersquid likes this.
    10-04-2014 06:03 PM
  25. Casey Campanile's Avatar
    Does anyone know why Google+ keeps force closing?
    10-04-2014 08:18 PM
1,625 ... 4849505152 ...

Similar Threads

  1. Is moto x camera good for a vacation?
    By AImbriano in forum Moto X (2013)
    Replies: 19
    Last Post: 02-09-2014, 09:21 AM
  2. Case for Note 3 with the wireless charging battery/back cover
    By DocGo in forum Samsung Galaxy Note 3
    Replies: 1
    Last Post: 01-31-2014, 08:45 AM
LINK TO POST COPIED TO CLIPBOARD