08-07-2017 09:49 PM
1,625 ... 5455565758 ...
tools
  1. Casey Campanile's Avatar
    Squiddie, Tkrusse updated the gapps to 11-3 can you please update the facilitator?
    11-03-2014 01:41 PM
  2. bigsupersquid's Avatar
    Squiddie, Tkrusse updated the gapps to 11-3 can you please update the facilitator?
    well, the gms core, play services, and vending are all still current... google hasn't pushed anything newer to my phone. Those are mostly what the facilitator is, aside from removing the worst offending armv7 stuff that regular gapps have by default.
    I'd say if anything is updated, it's newer apps, and you could flash a bigger package than pico then the facilitator to get those.
    nitestalkr likes this.
    11-03-2014 03:18 PM
  3. Casey Campanile's Avatar
    Actually, Play Store is up to 5.0.37 now. The one in the facilitator is 5.0.31. The apk is here. http://www.apkmirror.com/apk/google-...re-5-0-37-apk/
    Can you please put it in the facilitator?
    bigsupersquid likes this.
    11-04-2014 08:05 AM
  4. Shinkenred's Avatar
    when you say wipe, you mean system, data, and cache? gotta clean it all sometimes.
    otherwise, in the next version, I could maybe get a startup script in there that'd dump logcat to sdcard to pull in recovery.
    When wiping, I wipe everything but SD card. Gonna try the ROM itself and see what happens.

    I noticed something odd, however: I had a backup of an older OS2SD (I think the one that was alongside the 09/04 internal version), but even that wouldn't work, whereas a backup of a JB ROM that I had worked kinda fine.

    Going into folders to check the numbers on file sizes, it seems that TWRP didn't properly backup "system.ext4.win" in that case: the JB one had a size of 96.91MB, where the KK one was just 1KB (and I *had* sufficient space at the time I made that backup; I wouldn't have done it otherwise)...so when that KK backup kept sayin' "No OS installed" when I wanted to reboot, I see why. Not sure if there's a connection...
    bigsupersquid likes this.
    11-04-2014 12:17 PM
  5. bigsupersquid's Avatar
    Actually, Play Store is up to 5.0.37 now. The one in the facilitator is 5.0.31. The apk is here. Google Play Store 5.0.37 APK Download - APKMirror
    Can you please put it in the facilitator?
    links make all the difference when it's stuff I don't already have.
    upload in process.

    funny, it wouldn't sideload, said it was already installed. but mine was definitely .31
    11-04-2014 01:09 PM
  6. QuinnSF's Avatar
    Google Maps is very laggy for me, the phone runs hot a lot, and yelp doesn't work for me. Widgets seem to make the phone laggy, but I could be wrong about this. Do you guys experience any of this or did I turn on some settings I shouldn't have? Also, I loaded a different theme and then deleted it a day later, I can't access Performance and Developer Settings in the Settings now.
    11-04-2014 08:23 PM
  7. bigsupersquid's Avatar
    Google Maps is very laggy for me, the phone runs hot a lot, and yelp doesn't work for me. Widgets seem to make the phone laggy, but I could be wrong about this. Do you guys experience any of this or did I turn on some settings I shouldn't have? Also, I loaded a different theme and then deleted it a day later, I can't access Performance and Developer Settings in the Settings now.
    you should be able to open the dev settings back up with about phone>tap build number until it says it's activated.

    there's a 'last version' of maps that runs clean because of our gpu
    it's buried in this thread somewhere.

    gapps make the phone laggier, and any apps that run on boot will too.
    use widgets>settings>app ops to turn off start on boot and any 'wake up' 'prevent sleep' perms for downloaded apps.
    11-05-2014 05:36 AM
  8. Shinkenred's Avatar
    Update on the ROM situation:

    ...nope. Tried the 10/30 os2sd by itself, NO Sprint fix, gapps, or facilitator. Bloody thing STILL installs absolutely perfectly, and yet it STILL refuses to boot. At this point, I'm about ready to give up...I dunno what to do anymore.
    11-05-2014 11:17 AM
  9. bigsupersquid's Avatar
    Update on the ROM situation:

    ...nope. Tried the 10/30 os2sd by itself, NO Sprint fix, gapps, or facilitator. Bloody thing STILL installs absolutely perfectly, and yet it STILL refuses to boot. At this point, I'm about ready to give up...I dunno what to do anymore.
    ok, last-ditch effort to see what's going on.

    in recovery, mount /system, open advanced>file manager
    see if /system has a bunch of subdirectories.

    if it does, that's a good start, it means something is going wrong with the boot.img

    You can try to flash one in recovery with a zip. For the 10/30 only.
    This uses flash_image where the recovery updater_script uses write_raw_image, and I don't know if it handles those differently or not.
    A bad boot.img flash would cause the wifi and some other problems I've seen as well as some of yours.
    boottest.zip
    Shinkenred likes this.
    11-05-2014 01:15 PM
  10. Shinkenred's Avatar
    ok, last-ditch effort to see what's going on.

    in recovery, mount /system, open advanced>file manager
    see if /system has a bunch of subdirectories.

    if it does, that's a good start, it means something is going wrong with the boot.img

    You can try to flash one in recovery with a zip. For the 10/30 only.
    This uses flash_image where the recovery updater_script uses write_raw_image, and I don't know if it handles those differently or not.
    A bad boot.img flash would cause the wifi and some other problems I've seen as well as some of yours.
    boottest.zip
    Okay, so where in the order of flashing would this go? I tried it after the ROM, and it didn't work.

    New odd thing: with this thing connected to the computer earlier (at library), I tried to delete one file from the Download section of my SD card...only for it to mysteriously nuke the ENTIRE FOLDER...and "cancel" COULDN'T STOP IT. All those apks downloaded (and a video and a couple songs), GONE. How that happened, I have no clue, but I am NOT a happy camper...
    11-05-2014 05:56 PM
  11. bigsupersquid's Avatar
    I meant flash ROM, check mounted /system, flash boottest, reboot.
    Wonder if your card is failing? I'm waffling towards ext2 to avoid journaling since the f2fs seemed buggy.

    Your phone is weird. I'd trade it to keep on hand for stress tests if I had an S laying around.
    Shinkenred likes this.
    11-06-2014 01:07 PM
  12. nitestalkr's Avatar
    I meant flash ROM, check mounted /system, flash boottest, reboot.
    Wonder if your card is failing? I'm waffling towards ext2 to avoid journaling since the f2fs seemed buggy.

    Your phone is weird. I'd trade it to keep on hand for stress tests if I had an S laying around.
    I was about to say more or less the same thing. I was starting to think that maybe the SD card locked itself in RO mode, till I figured that wouldn't be the case, due to having the newest zips on the SD card. Possibly bad partitioning? Try repartitioning through squid's twrp recovery if you haven't that already.

    Also, after extended use of the last ext4 rom update, it seems to start slowing down and locking up more than usual. Having to take some extended time to complete a few simple tasks gets a lil exhausting sometimes.

    Sent from my LG-VM670 using Tapatalk 2
    11-06-2014 02:26 PM
  13. Shinkenred's Avatar
    I meant flash ROM, check mounted /system, flash boottest, reboot.
    Wonder if your card is failing? I'm waffling towards ext2 to avoid journaling since the f2fs seemed buggy.

    Your phone is weird. I'd trade it to keep on hand for stress tests if I had an S laying around.
    Flash ROM...done.
    Mount & check /system...done, subdirectories are present.
    Flash boottest...done.
    Reboot System...done...and...so far, it seems to be working! At the CM11 logo now...

    ...it worked! But after adjusting some settings and rebooting to recovery to flash the Sprint Fix & gapps...it's back to not booting at all.

    Back to JUST ROM&boottest, and it works. Not sure if it's the Sprint Fix or either of the new gapps that's the problem...
    11-06-2014 03:00 PM
  14. bigsupersquid's Avatar
    ...
    Also, after extended use of the last ext4 rom update, it seems to start slowing down and locking up more than usual. Having to take some extended time to complete a few simple tasks gets a lil exhausting sometimes.

    Sent from my LG-VM670 using Tapatalk 2
    that is the same as the f2fs acted. just fine at first then the cards didn't like it anymore.
    Another reason to try ext2. Plus ext2 (and vfat) can be resized in recovery rather than completely repartitioned, which would be nice.

    Flash ROM...done.
    Mount & check /system...done, subdirectories are present.
    Flash boottest...done.
    Reboot System...done...and...so far, it seems to be working! At the CM11 logo now...

    ...it worked! But after adjusting some settings and rebooting to recovery to flash the Sprint Fix & gapps...it's back to not booting at all.

    Back to JUST ROM&boottest, and it works. Not sure if it's the Sprint Fix or either of the new gapps that's the problem...
    I did test the sprint fix and gapps... neither bootlooped me. no other feedback on sprint test.
    you could try 2nd newest gapps (the androidfilehost set, I'm not maintaining the google drive stuff at this time.)
    I suggest first try rom, boottest, gapps, reboot. the sprint fix is most likely to bork it since perms on build.prop will bootloop if wrong.
    Shinkenred and nitestalkr like this.
    11-06-2014 04:54 PM
  15. nitestalkr's Avatar
    Hey Squid, could you possibly make a flashable zip to remap the button above the camera button to act as the power button? My power button isn't as reliable as it used to be, especially when it comes to bringing up the power menu.
    I know some users could benefit from it as well who may be experiencing the same issue.
    It'd be greatly appreciated. Thanks in advance!

    Sent from my LG-VM670 using Tapatalk 2
    11-07-2014 05:33 AM
  16. bigsupersquid's Avatar
    Hey Squid, could you possibly make a flashable zip to remap the button above the camera button to act as the power button? My power button isn't as reliable as it used to be, especially when it comes to bringing up the power menu.
    I know some users could benefit from it as well who may be experiencing the same issue.
    It'd be greatly appreciated. Thanks in advance!

    Sent from my LG-VM670 using Tapatalk 2
    I can look into it, but it'd only work after the rom boots.
    even if I put it in the kernel itself. The bootloader has its own kernel and keymap...

    the o1 guys use a mod that substitutes a taskbar tap for power button I think.
    nitestalkr likes this.
    11-07-2014 05:48 AM
  17. nitestalkr's Avatar
    I can look into it, but it'd only work after the rom boots.
    even if I put it in the kernel itself. The bootloader has its own kernel and keymap...

    the o1 guys use a mod that substitutes a taskbar tap for power button I think.
    I don't have an issue turning the phone on with the power button, just locking the phone and getting to the power menu. I have to press it pretty hard just right and in a certain way, making accessing the power menu pretty difficult sometimes by locking the phone instead.
    I did a bit of digging into gravity box from xposed, and found that i can edit the actions of the front buttons. It has a few more options than in the ROMs system settings that are pretty helpful.
    I changed the menu button long press to power menu, and double tap menu to turn off screen/lock phone.
    This should work for me for now but it'd be better to have the side button to be my power button substitute.

    Sent from my LG-VM670
    11-07-2014 09:13 AM
  18. bigsupersquid's Avatar
    I don't have an issue turning the phone on with the power button, just locking the phone and getting to the power menu. I have to press it pretty hard just right and in a certain way, making accessing the power menu pretty difficult sometimes by locking the phone instead.
    I did a bit of digging into gravity box from xposed, and found that i can edit the actions of the front buttons. It has a few more options than in the ROMs system settings that are pretty helpful.
    I changed the menu button long press to power menu, and double tap menu to turn off screen/lock phone.
    This should work for me for now but it'd be better to have the side button to be my power button substitute.

    Sent from my LG-VM670
    Ok, I got it. it's the old voice search button. Not even in the thunder-keypad.kl
    key 216.

    This should add that key as a second power button.
    It shouldn't interfere with the Sprint keyswap either. I still need to redo that with awk, it's cool.

    here, in the new tweaks folder
    adding to OPs. Y'all ask for interesting things.
    nitestalkr likes this.
    11-07-2014 10:56 AM
  19. dradzanowski's Avatar
    Hey, I'm thinking of getting a new phone for Christmas. toying with the idea.
    Before I leave, I gotta know, does anyone have news on fresh install space, ease of install, reliability? Also toying with reinstalling the ROM.
    11-07-2014 05:55 PM
  20. BradN2's Avatar
    If google wants to update gapps itself and store in /data, maybe a different approach might be: What is the smallest gapps (or parts of it) that can be put in /system and still allow the update function to succeed?
    11-08-2014 02:29 PM
  21. bigsupersquid's Avatar
    If google wants to update gapps itself nmiand store in /data, maybe a different approach might be: What is the smallest gapps (or parts of it) that can be put in /system and still allow the update function to succeed?
    that would be the oldest 4.4 ones.
    problem is /data space also limited.
    current gms and vending way over 50mB once they've synced themselves.
    if gapps gonna take one third of user app storage, then there's not much room without using card storage anyway. can't even fit the /extras apps with that.
    spoils the point of internal if you can only have a small handful of apps...
    11-08-2014 02:56 PM
  22. Shinkenred's Avatar
    you could try 2nd newest gapps (the androidfilehost set, I'm not maintaining the google drive stuff at this time.)
    I suggest first try rom, boottest, gapps, reboot. the sprint fix is most likely to bork it since perms on build.prop will bootloop if wrong.
    Second newest is the 10/28 one, right? That's the one I've had anyway - didn't even know about the 11/04 one until just now, lol. Hopefully, this works...having to rely on that JB ROM when my memory card ain't formatted specifically for it (and then again, even if it were) is getting to be a pain in the nuts. I mean it's technology acting stupid to the point that it makes me want to BREAK IT...and I mean hurl this mofo into a smurfin' wall or something equally violent.
    11-08-2014 03:02 PM
  23. BradN2's Avatar
    I made some more tests with those two optimus S's I had that wouldn't run the OS2SD.

    I loaded on the internal ROM, and the one that FC'd phone still does so, and the one that FC'd acore fails to execute the updater binary near the end of installation. Didn't try booting it. Tried swapping SD cards and same behavior for that one. I also noticed a lot of soft restarting inside the recovery for that second phone.

    I'm thinking these two are just bad phones, but it's strange that all the 2.2/2.3 roms I tried were happy with them.
    bigsupersquid likes this.
    11-09-2014 09:22 AM
  24. bigsupersquid's Avatar
    I made some more tests with those two optimus S's I had that wouldn't run the OS2SD.

    I loaded on the internal ROM, and the one that FC'd phone still does so, and the one that FC'd acore fails to execute the updater binary near the end of installation. Didn't try booting it. Tried swapping SD cards and same behavior for that one. I also noticed a lot of soft restarting inside the recovery for that second phone.

    I'm thinking these two are just bad phones, but it's strange that all the 2.2/2.3 roms I tried were happy with them.
    I'd suspect they'd be ok with most roms and recoveries using 2.6.32 kernel(froyo)

    touchy hardware like those and shinkenred's phone may just be stuck with stock-based kernel, froyo or gingerbread.
    they're pretty cheap these days... so am I though, so I understand not buying a replacement just to run newer software.
    11-09-2014 10:42 AM
  25. Shinkenred's Avatar
    Okay, so I tried ROM>boottest>11/04 gapps. It works, but not without a bit of oddity: I used TB to get rid of certain safe-to-ditch system apps...only for them to mysteriously come right back upon reboot.

    Also had to bump it down from my now-usual 480/729 to 480/600 because it would randomly reboot itself for no reason. A lot. (Never seen that happen with the CPU Max set to 729, this was usually 787 and up!)

    Otherwise, it seems to work fine. I'll be more comfortable when a Sprint fix that's nice with the ROM>boottest>gapps combo comes along...still haven't got accustomed to the reversed buttons.

    And my Optimus S hardly ever had problems with ICS ROMs...it's JB and up where she doesn't seem to play nice. (Example: BobZhome CM10 seemed fine, but would have wakelock when I listened to music. I thought all that came from the Rocket Player music player app...nope, that happens with the stock music player, too.)
    11-10-2014 02:14 PM
1,625 ... 5455565758 ...

Similar Threads

  1. Is moto x camera good for a vacation?
    By AImbriano in forum Moto X (2013)
    Replies: 19
    Last Post: 02-09-2014, 08:21 AM
  2. Case for Note 3 with the wireless charging battery/back cover
    By DocGo in forum Samsung Galaxy Note 3
    Replies: 1
    Last Post: 01-31-2014, 07:45 AM
LINK TO POST COPIED TO CLIPBOARD