08-07-2017 09:49 PM
1,625 ... 6061626364 ...
tools
  1. bigsupersquid's Avatar
    The only issue not covered there,
    the setupwizard.
    the internal boot.img isn't flashing and needs extracted to /sdcard then in twrp
    Advanced - terminal command
    navigate to sdcard and select
    Then type
    flash_image boot boot.img

    Bad updater-script. Would fix and reupload if I had working pc.
    02-05-2015 04:52 PM
  2. dradzanowski's Avatar
    Alright, got to play with the audio policy file in etc. it worked to change the default to "audio_out_earpiece" then reboot. I'm going to further experiment, and see if I can get a wired headset to work as well. (headset itself is wrong connection-3conductor, though if you have a 4 conductor headset, should work).

    UPDATE:
    Well, played with the GPS, it seems like between the Google Setting and the normal phone settings both are "on" and if you turn one of them on, it switches the other on as well. So, Gsetting and phone setting agree, it's on. It's just none of my apps say that the GPS is on "go to settings to turn them on"-I go to setting, it says it's on. Though the "assisted" gps working through wifi works, doesn't help a lot for excercise running or driving though. Updated the GPs.config file, using various files, some from online general north america, southwest America (Arizona included), and the config file listed previously. Nothing will really take. Seems like the apps aren't correctly communicating with the GPS. If anyone has some direction or thoughts, I'll play in that direction.
    bigsupersquid likes this.
    02-06-2015 11:06 PM
  3. skinbark's Avatar
    I just came back to kit kat after running CAI ICS for a while, and I'm very happy that I did! Many thanks squiddie for the awesome work you've done with this rom. The 10-25 build is running smoothly for me. It lagged a bit until I switched from a class 10 sdcard to a class 4, that made a big difference. I'm getting FCs when I select Settings>Storage, and I haven't been able to get tethering to work, but other than that everything seems fine. I'm just amazed that this old phone could still be running so well after all these years. It's truly better then ever thanks to you and everyone else who's contributed (and participated).
    bigsupersquid likes this.
    02-16-2015 02:00 PM
  4. skinbark's Avatar
    Also, I never used to be able to get videos to play worth a **** on this phone. I installed MX Player with the armv6 vfp codec and videos are working great!
    bigsupersquid likes this.
    02-16-2015 06:39 PM
  5. rockinmusicgv's Avatar
    First, let me say THANKS to everyone who has worked so hard on continuing to update a device that until yesterday I thought was hopelessly out of date.

    I'm in a situation where my Optinmus V might become my daily driver. Is this CM11 ready for life in the primetime? I saw in the thread there are a few things that don't quite work (like the camera). I'm sure I missed a few things that might have been fixed (mms?). Is the phone actually responsive using KitKat?
    02-18-2015 06:47 PM
  6. dradzanowski's Avatar
    This ROM I would say is a comfortable daily driver. I think of it like a car analogy. This ROM takes a Ford Pinto (The Opti s/v) and makes it feel like a 08 Fusion. It's still not a Mustang GT, but it's pretty nice.
    Or if you don't like domestic, it takes a 89 Toyota Camry and makes it feel like a 14 Corolla. Still not a Lexus, but a lot better.

    There is a "native copy" Camera app available in the Play store, that works just fine (I've used it). I don't think the video camera works though, haven't tried lately. MMS hasn't worked really ever for me. Across a lot of ROMs.

    Aside from that, this ROM is sweet. The 10-25 build runs really well, you have to get OS2SD, you have to get a good SD card. But if you do, the setup makes me feel like I'm on almost equal footing with the new Galaxy S4. Aside from the physical limits (CPU being single), this ROM is great.
    bigsupersquid and Shinkenred like this.
    02-20-2015 09:44 AM
  7. skinbark's Avatar
    bigsupersquid, do you know what cluster size twrp is using when it partitions sd cards?
    02-26-2015 03:49 AM
  8. bigsupersquid's Avatar
    nope , all i got is
    "parted -s " + Device + " mklabel msdos"
    so i guess whatever parted uses by default.
    skinbark likes this.
    02-26-2015 06:12 AM
  9. kameron c's Avatar
    I tried to have Llama cycle the mobile data connection periodically per syguyice's suggestion but it did not work reliably because Llama relies on the clock. Sometimes, the clock lags a lot when the screen is off so Llama doesn't think that the next schedule cycle time has been reached. When I turn on the screen, the three clocks (lock screen, status bar top right, drawer bar top left) jump to three new times so Llama never triggers.

    Installing Voice Search from Google Play allows Waze's voice command to work but the mic icon from the Android AOSP keyboard does not launch the Google voice input. I am using paid Swype's Dragon Dictation for voice input at the moment.

    Video related:
    MX Player with the armv6 vfp codec also work well on my phone. Video camera is still broken. I tried Google Camera app from Google Play a couple weeks ago. It was totally broken. I had to do a nandroid restore to get back the Gapps camera which at least took still photos.

    Chromecast related:
    Working: casting from YouTube app, changing backdrop from Chromecast app
    Not working: registering new Chromecast device (fails but no crash), cast screen from the phone (crash)

    Recently, I get two to three "Unfortunately, Google Play services has stopped" pop-up messages when I boot up the phone and a random one every now and then when I am not running any app actively. I am not sure what has changed to cause this problem, and I am not aware of any app not working because of this. Is there a way to find out what is causing these pop-up messages?

    What are the main differences between the 20141025 build and the 20141030 build?
    03-04-2015 02:22 PM
  10. dradzanowski's Avatar
    Hey Kameron,
    I test like, 15 different camera apps.
    This is the only one that worked.
    https://play.google.com/store/apps/d...d.camera&hl=en
    Got to take a panoramic shot with it. Pretty fun.

    I have the free Touchpal keyboard, and it does connect to the voice correctly, but the voice app is broken. I want to get in sometime and see about other apks for the voice input.

    I've gotten the play services message as well. I uninstalled GPservices, and I'm going to try a different apk for it. I found this one:
    com.google.android.gms-6.7.76_(1745988-012)-6776012-minAPI9
    It's coded correct for my phone (012), I did a little research on it. It's more updated, I think. I'd be interested as well in figuring out why Google play services isn't working.

    BIG UPDATE ON GPS:
    This is bizzaro. When I was fiddling with the keyboard calling for the voice input app, a box popped up and said "In a previous version of Android, you disabled app permission to use GPS. Would you like to enable it now?" Stunning. It apparently remembered at some point denying permission to apps. That may have been what broke my GPS. Going to test once I get Play services back up.
    bigsupersquid likes this.
    03-10-2015 11:07 AM
  11. bigsupersquid's Avatar
    oh, looky there. I fried my Evo with dd.
    gotta unsolder the internal sd or something and get mmcblk0p1 back together (/boot is at mmcblk0p21) dang terminal.

    so it's back to the Optimus for me again. will encourage me to sort out glitches.

    those google persistent permissions are beastly sometimes. and xda usually has the latest/greatest play services, just pull the 160dpi armeabi version (or generic armeabi if they're too fresh for that -012, but never ever armeabi-v7a.)
    //those gservices fcd at me too. multiple reboots seem to have fixed it.
    03-10-2015 05:45 PM
  12. omgitsMATT's Avatar
    Sorry about your Evo.

    I left my phone in my pocket while working and a brick crushed the glass and lcd making it to expensive for me to fix so I'm back too
    bigsupersquid likes this.
    03-11-2015 02:31 PM
  13. bigsupersquid's Avatar
    It's always the expensive hardware, right?

    my bad lexar 16Gb card runs dog-nasty on any os2sd.
    my nice sandisk evo 64Gb media card runs great on the same backups from either my 10-25 or 9-06.
    01cache.zip
    Note: Shinkenred verified with terminal that the 10-25 build doesn't mount /cache which causes some of the fc's.
    unpack attached zip (not flashable,) put content in /etc/init.d and chmod 755 (rwxr-xr-x) and it'll be ok on reboot and after.
    Shinkenred likes this.
    03-12-2015 01:08 PM
  14. syguyice's Avatar
    Hi Kameron,

    I also had a lot of popups from googleplay stopping for about 3 months, and had put up with it until 2 weeks ago, when I inadvertently uninstalled all updates to googleplay store & googleplay services (from Settings -> Apps). Afterwards, not only did the popups go away, but I found that the phone sped up a bit as I can have more than 140mb free memory now, when before I never got above 70mb (usually hovering around 28mb free). The factory googleplay store still works, however each time I run it, the auto-self-update would reinstall the bloated latest version again, causing all the popups all over (possibly due to low free mem). So my workaround is to get everything I want from google store, uninstall updates, then disable googleplay store from Settings -> Apps. Since I don't update my apps nor browse around the store often, this leaves my phone speedy in between app installs. If I ever have to launch play store again, then I would re-enable store, and repeat the same procedure after I'm done installing.

    Sorry about the Llama issues; it's my fault for not realizing that could be a problem, without experiencing clock lag myself. I haven't had to use this as a result, but within Llama settings there's a Cell Polling Mode, which you can enable to have Llama actively wake the phone up to check time and cell towers, instead of passively waiting for timer to hit (which could be never when phone goes into deep sleep, until you wake it). It will use a bit more battery power like it says, although perhaps the tradeoff would be worth it for you to consider the phone usable. You can control the exact behavior of Cell Polling under Cell polling settings, for which I recommend you to have it wake and turn on screen every minute for 1 second. If that works for a day, then try again after scaling back the frequency and disabling screen-on, until you find an acceptable level of battery consumption that still works.

    Hope this helps.
    bigsupersquid likes this.
    03-12-2015 02:03 PM
  15. bigsupersquid's Avatar
    I've been experimenting with clock lag today.
    was pretty bad until I tried a new gimmick.
    since network time protocol seems to have something to do with the problem...

    after commenting out all the beginning NTP lines in the US gps.conf, I have gone since about noon (8.5 hours //edit over 19 //23 Hours, Lockscreen Clock Wrong Once But Everything Corrected When UnlockEd, ) without a single time glitch. before editing that file the statusbar clock and others were nearly constantly out of sync.
    testers? see attachment. unzip, put file in /etc, chmod 644 (rw-r--r--) and reboot.
    gps.conf.zip
    03-12-2015 08:37 PM
  16. kameron c's Avatar
    bigsupersquid, I'll try the gps.conf clock lag fix next weekend when I have time to backup.

    syguyice, I can confirm that reverting Google Play Store to "factory" version fixes the pop-up problem. I was unable to revert Google Play Services. The button is greyed out although Google Play Services is listed under downloaded apps (see screenshot). Does that mean 6.7.76(1745988-012) is my stock version, or does that mean Google Play Services is somehow preventing me from reverting it? In either case, the pop-ups went away with only Google Play Store reverted. Later, Google Play Store self-updated on mobile data although I enabled "update on Wi-Fi only." I'd rather not disable it because I like auto updates for my other apps. Is it safe to try something like this (can't post link yet, search for "trick how to disable google play store t2951378" on xda) on os2sd?
    I'll try the cell polling mode in llama if the gps.conf fix doesn't work.
    You have no clock lag and a working video camera? What doesn't work on your build? [ROM+Kernel][CM-11.0][4.4.4][OS2SD/internal][f2fs]bigsuperROM-thunderc-4.4.4-screenshot_2015-03-14-04-25-28.png
    03-16-2015 01:19 AM
  17. bigsupersquid's Avatar
    if you disable the downloaded gservices it'll uninstall.
    the link you reference, [TRICK] How to stop Google Play Store self u… | Samsung Galaxy Y GT-S5360 | XDA Forums
    is gorgeous.and should work on any autoupdating nasties buried in /system if more do it.

    I'm getting minute-long freezes and reboots from low ram specifically. monitor for that and use fast reboot (off play) and also long-press home>swipe away unused apps.
    03-16-2015 06:37 AM
  18. syguyice's Avatar
    Hi Kameron,

    Thanks, that link was ingenious and a great trick; I'm gonna try it when I get home. For uninstalling updates, I imagine some of your apps (and/or system components) are using features from the newer googleplay services, thus OS prevented you from uninstalling. I wish I could offer something as clever as the post you found, although the only thing I could think of is a (dangerous) suggestion to rename your android gms.apk file under /data/app and restart. Be sure to have a nand backup ready before the rename just in case the phone fails to boot. For your reference, my current googleplay services is 5.0.89, and no longer exists under the "Downloaded" section.

    My build is 0906 (1.5 months before 1025) that mostly works (including vid cam). The main complaints are missing camera focus and not enough root for some apps. There are occasional freezes that's likely due to my sd card, and a few speed and powersave enhancements in later builds. Other than that, the big difference is I don't use mine as a phone, but a mp4 player / backup camera. As such, I don't connect to cell towers (only occasional WiFi) thus haven't observed clock lag. I would prefer to hold on to this old build until there is a better one with working camera.
    03-16-2015 03:56 PM
  19. kameron c's Avatar
    How do you know the reboots are caused by low ram? I do get random reboots occasionally. I use an 8GB SanDisk Extreme Pro microSD card with 768MB for system, 2GB for data, 864MB for swap, and about 3.8GB left for VFAT. I disabled zRAM. The "free" command in the terminal shows that swap is used but only in the single digit MBs.

    I used to get minute-long freezes, especially when the phone is ringing. I find setting the I/O scheduler to noop makes the phone much more responsive, regardless of clock speed. However, noop does not work well with Waze or Opera Mobile browser (it spends too much time loading things in the back and too little time responding to my scrolling). Maps does not have this problem. I use SetCPU to change the I/O scheduler to cfq for Waze and Opera when the screen is on, and change the min frequency to 600 when the Phone app is open. My phone seems to be stable at even 864MHz but I set the max frequency at 806MHz.
    03-16-2015 06:28 PM
  20. bigsupersquid's Avatar
    I use device info live wallpaper to watch ram.
    the reboots and freezes happen with over 80-90% ram used.
    I'll try the noop
    03-17-2015 06:43 AM
  21. syguyice's Avatar
    Interesting... The little-response behavior you mentioned sounds like the phone is busy swapping (due to low RAM). Was zRAM giving you trouble? If not, try turning zRAM back on (and also Allow purging of assets, Kernel samepage merging, and SD swap), run Fast Reboot, then try Opera again, see if there is any improvement.

    Opera aside, I would expect Waze and most GPS apps to slow to a crawl very quickly on this phone no matter what, due their larger ram/cpu requirements.
    03-17-2015 05:17 PM
  22. kameron c's Avatar
    Update on Google Play Store and Google Play Services autoupdating nasties: I applied the trick on Google Play Store by adding the "com.android.vending-1.apk" folder a few days ago. It worked and took care of the problem (multiple-at-a-time pop-ups). Google Play Services updated itself to 7.0.97(1791429-012) today, and I got single-at-a-time pop-ups. As bigsupersquid suggested, I was able to extend the trick to Google Play Services by adding a "com.google.android.gms-1.apk" folder. I am now back to 6.1.88(1557022-012), and pop-ups free. By the way, I had to apply the trick in airplane mode because the autoupdating nasties reinstalled themselves immediately after I uninstalled them.
    mister_zero likes this.
    03-20-2015 03:55 PM
  23. mister_zero's Avatar
    Hi folks; long time OV root user, first time poster.

    I'm running the 10/30/2014 OS2SD ext4 bigsuperROM. I've had a couple issues I haven't seen discussed, so I thought I'd ask.

    1. Video in Youtube and Facebook is flaky, in much the same way in both apps. Sometimes videos play just fine, sometimes I only get audio, sometimes I just get the loading/buffering circle endlessly. Rebooting and clearing data and cache in application settings doesn't seem to help, and it's just as likely to work over 3G as it is over a solid wifi connection.

    2. In Google Settings -> Search and Now -> Phone Search, there should be a list of apps that the Google app will search, but my list is blank. So, the Google app will only search the web. I've found threads about this problem, for other devices, but haven't seen a solution that works. Not a huge deal, but it would be nice if I could actually search my phone.

    3. The Google Text-to-speech (TTS) Engine seems very unhappy. When I try to use navigation in Maps, the TTS engine force closes, usually followed by Maps. With the Google TTS Engine disabled, Maps seems reasonably stable, even though I'm running a current version from Play (7.7.0). Navigation will work, but it provides less voice guidance (instead of "turn right on Elm Street," it just says "turn right"). I guess it must be using Pico TTS now that I've disabled the Google TTS Engine. Anyway, does anyone know of a good alternative to the Google TTS Engine, that runs on our older-than-Jesus devices?

    Overall, I'm stoked that I can run KitKat on this phone without having to worry about space for apps. Very grateful to Bigsupersquid and others.
    bigsupersquid likes this.
    03-21-2015 12:29 AM
  24. bigsupersquid's Avatar
    as far as maps goes, you can use 6.12 from somewhere (like here) which still supports the icecreamsandwich graphics drivers that Qualcomm abandoned our chipset at, so no screen glitches. plus I don't have tts installed, but navigation still talks with pico disabled, and sounds cleaner (no evidence of any other tts installed except maybe in google translate.)
    videos, are hard to debug.
    which version of Now? haven't tested that in months.
    03-21-2015 10:04 AM
  25. mister_zero's Avatar
    which version of Now? haven't tested that in months.
    Now Launcher 1.1.0.1167994
    Google App 4.2.16.87075793.arm

    Thanks for the Maps link. I'll install that version if I find the graphics to be too glitchy. Haven't played with Maps much yet, but so far the graphics quirks have been tolerable.
    03-21-2015 10:58 AM
1,625 ... 6061626364 ...

Similar Threads

  1. Is moto x camera good for a vacation?
    By AImbriano in forum Moto X (2013)
    Replies: 19
    Last Post: 02-09-2014, 08:21 AM
  2. Case for Note 3 with the wireless charging battery/back cover
    By DocGo in forum Samsung Galaxy Note 3
    Replies: 1
    Last Post: 01-31-2014, 07:45 AM
LINK TO POST COPIED TO CLIPBOARD