1. gener21839's Avatar
    I'm frustrated with this issue of being unable to mount the SD-EXT partition using link2sd using the very same methods that have been so reliable for me for years. I've done the same reset many times, and they've always worked well until very recently. Do note that this problem came up once and went away with the same reset I've done before, but since I reset after that, the inability to mount the sd-ext has returned.

    I'm using ClockworkMod Recovery v3.2.0.1, and I'm focusing on MiRaGe as the ROM I want to work.

    I've tried all the "format" commands in "Mounts and Storage". I've tried "wipe data/factory reset", and I've tried the "wipe cache partition". I've tried reinstalling the ROM (this worked once). I've tried wiping the "Dalvik Cache". I've also tried partitioning the SD card through recovery.

    This issue is new to me even though I've used the very same methods for years for over 10 factory resets with the same device.
    02-14-2015 09:01 PM
  2. Rukbat's Avatar
    "Mount" as in

    mount [-fnrsvw] [-t vfstype] [-o options] device dir

    Or something else?
    02-14-2015 09:42 PM
  3. gener21839's Avatar
    mount as in creating mount scripts in Link2SD, and also mounting in recovery.
    02-14-2015 10:04 PM
  4. gener21839's Avatar
    I'm trying to work with an App from the Play Store called Aparted. I don't have an adapter to connect the SD card to my PC. Besides, I've had issues getting my PC to recognize that the whole drive (of 2GB) isn't just 1.5GB of FAT32 (regardless if I use Linux or Windows 7).

    I'm thinking maybe I ought to just get another SD card. I'm just not sure this really is a hardware issue though.


    EDIT: I'm having a hard time with AParted. What's the latest recommended Recovery Image?
    02-14-2015 10:29 PM
  5. BradN2's Avatar
    Honestly I'd just pick up a cheap SD -> USB adapter on ebay, it's probably like a dollar or two shipped and it'll put an end to that problem.
    02-14-2015 11:51 PM
  6. gener21839's Avatar
    Honestly I'd just pick up a cheap SD -> USB adapter on ebay, it's probably like a dollar or two shipped and it'll put an end to that problem.
    Yeah, I ordered another microSD card, and I ordered a usb <-> microsd adapter. I hope that the reason the PCs I've worked with had trouble detecting the ext(2-4) partition on the microSD was because of the particular microSD.
    02-15-2015 05:36 PM
  7. tli's Avatar
    Which version of Link2SD are you using? I encountered the same problem with the latest update of Link2SD (version 4.0). SD-EXT was able to remount after a few reboots of the OV. The latest version also currently no longer able to recreate mount scripts. There's obviously issues and bugs with this latest update version. Thus, might wait for the next release update which may correct some of these issues--hopefully. FYI.

    [Edit] Just updated to version 4.0.1, problems still exist... [/Edit]

    [Edit #2] Reported the problems to the Link2SD app developer, and he responded within an hour with a 4.0.2beta version for me to test, and the problems seem to have been resolved for me. Version 4.0.2 should be release shortly, FYI. [/Edit #2]
    badblue1__ likes this.
    02-16-2015 08:35 AM

Similar Threads

  1. Replies: 2
    Last Post: 04-09-2017, 11:48 PM
  2. Unable to install game
    By 3neekimmy in forum Samsung Galaxy S5
    Replies: 17
    Last Post: 02-22-2015, 10:12 AM
  3. Replies: 1
    Last Post: 02-14-2015, 08:39 PM
  4. Possible to use Galaxy s5 in asia and europe?
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 02-14-2015, 08:32 PM
  5. Is there a way to set the phone to sleep automatically?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 02-14-2015, 07:49 PM
LINK TO POST COPIED TO CLIPBOARD