04-25-2012 04:12 PM
133 12345 ...
tools
  1. Prenominal's Avatar
    These are the only buttons I see in the handset file to edit buttons:

    key 226 HEADSETHOOK WAKE
    key 116 POWER WAKE
    key 107 ENDCALL WAKE_DROPPED
    There is nothing else... how can I swap the Home and Menu button? I've tried ButtonRemapper, but it just gives me this:
    04-07-2011 01:03 AM
  2. mmarz's Avatar
    These are the only buttons I see in the handset file to edit buttons:



    There is nothing else... how can I swap the Home and Menu button? I've tried ButtonRemapper, but it just gives me this:
    I really don't understand why this happens to you guys but not me, but here are the relevant keys from my thunder_keypad.kl:

    key 230 HOME WAKE_DROPPED
    key 229 MENU WAKE_DROPPED
    key 59 MENU WAKE_DROPPED
    key 139 HOME WAKE_DROPPED
    key 102 MENU WAKE_DROPPED
    I'm not sure which two are the two that you need, but there is no harm in using them all.
    04-07-2011 01:19 AM
  3. Prenominal's Avatar
    It's weird, I edited my thunder_keypad with those and the buttons are still switched.

    EDIT: Once I changed the thunder_keypad manually, ButtonRemapper was able to recognize the keys and I was able to change it from there. I'm using aospCMod 4032011 with Xiona Kernel 005.
    04-07-2011 01:41 AM
  4. drezliok's Avatar
    I restored my 005, the 013 was I believe the one with a boot image. I had 2 total freeze ups.
    I will try a different one later.

    Got home and checked my files. I had the other 013 Kernel.
    04-07-2011 02:00 AM
  5. mmarz's Avatar
    I posted another anykernel version (010) that should work also work with the aosp rom. I don't know if it will cause the keys to be switched.

    drezliok, try using the bootimg version of 013. Also make sure to pick the governor "interactive" in SetCPU. 005 and 013 have different governor options. "interactive" is one that they both share.
    04-07-2011 04:40 AM
  6. sdxben's Avatar
    What kernel does the current aosp rom have? Is it outdated compared to these? What is the benefit of flashing 013 ontop of aosp's rom?
    04-07-2011 10:24 AM
  7. munkyvirus's Avatar
    Running 013

    USB works fine, confirmed activated and showing up on my computer. But it's pretty unstable and has trouble unlocking with the CPU downrevved with SetCPU. Everything lags for about 20 seconds until it revs back up to speed. Gonna try 010, will report back
    04-08-2011 12:27 AM
  8. mmarz's Avatar
    What governor did you have it set to? "Conservative" can cause problems on all kernels. You should set it to interactive, or better yet, you should try not underclocking. It only wastes battery: http://forum.androidcentral.com/opti...-part-2-a.html

    Thanks for testing it though and reporting back!
    04-08-2011 01:07 AM
  9. drezliok's Avatar
    Now using 013 booting, runs smoother, doesn't have the lag from changing frequencies, feels better than the nonbootimg one.

    Set up setcpu to 768 min and Max. Set up a profile for charging set to the stock settings. Works great with Rodimus.
    04-08-2011 04:33 AM
  10. munkyvirus's Avatar
    What governor did you have it set to? "Conservative" can cause problems on all kernels. You should set it to interactive, or better yet, you should try not underclocking. It only wastes battery: http://forum.androidcentral.com/opti...-part-2-a.html

    Thanks for testing it though and reporting back!
    Always have my governors at on demand. But 010 runs much smoother and more stable.
    04-08-2011 09:54 AM
  11. davidh44's Avatar
    Now using 013 booting, runs smoother, doesn't have the lag from changing frequencies, feels better than the nonbootimg one.

    Set up setcpu to 768 min and Max. Set up a profile for charging set to the stock settings. Works great with Rodimus.
    If you're going to set your min and max speeds to be the same, you're better off setting it to Performance mode and save yourself some CPU cycles from not having to do the scaling calculations.
    04-09-2011 04:45 AM
  12. thexxoffspring's Avatar
    What kernal would you guys suggest to use?

    Sent from my VM670 using Tapatalk
    04-09-2011 03:54 PM
  13. scootincivic's Avatar
    What kernal would you guys suggest to
    I've been using 0010 and loving it.
    I haven't had a single issue with it.
    Plus the battery seems to charge faster then any other version (2Hrs from 0%)..
    0013 is about the same but as others said it has an sd mounting issue.


    Sent from my Optimus V vai Tapatalk
    04-09-2011 11:28 PM
  14. drezliok's Avatar
    If you're going to set your min and max speeds to be the same, you're better off setting it to Performance mode and save yourself some CPU cycles from not having to do the scaling calculations.
    This Kernel doesn't have a performance mode. It's not available in setcpu.
    04-09-2011 11:31 PM
  15. mmarz's Avatar
    This Kernel doesn't have a performance mode. It's not available in setcpu.

    I think it is 11-13 that don't have the extra modes. The others should. Either way, set the min max clock speed to the same value then set the min sampling rate to a really big number for the same effect as picking the "performance" governor.
    04-09-2011 11:46 PM
  16. liquidmass's Avatar
    So am I reading the OP correct, applying these kernels over a ROM made for the Optimus S will fix any incompatibilities it may have when used on a V? Has anyone tried any of the S ROMs and found any ones better than what's offered for the V at the moment?
    04-10-2011 09:36 PM
  17. mmarz's Avatar
    So am I reading the OP correct, applying these kernels over a ROM made for the Optimus S will fix any incompatibilities it may have when used on a V? Has anyone tried any of the S ROMs and found any ones better than what's offered for the V at the moment?
    Here, go nuts: http://forum.androidcentral.com/lg-o...tml#post634305

    I can't test them all. Zefie's CM7 Updated worked fine for me using 010 anykernel. You may want to try ThundeROM. It looks promising. I would try the bootimg version on it first, either 8, 10 or 13. You'll need the keyboard switching zip posted in the first post.

    It will fix the incompatibilities as far as drivers and hardware go. The roms themselves might have bugs.
    04-10-2011 09:48 PM
  18. BlackBerryBoy8530's Avatar
    The v10 kernel switches the home and menu keys too
    04-12-2011 01:45 PM
  19. mmarz's Avatar
    The v10 kernel switches the home and menu keys too
    Added to first post. Thank you!
    04-12-2011 02:34 PM
  20. Delphis's Avatar
    I am using kernel version 10 (boot.img version) tried to install OpenVPN and got an error that the /system/lib/modules/tun.ko kernel module could not be executed/loaded. Has anyone else tried using OpenVPN with the Xionia kernel?
    04-12-2011 03:13 PM
  21. mmarz's Avatar
    I am using kernel version 10 (boot.img version) tried to install OpenVPN and got an error that the /system/lib/modules/tun.ko kernel module could not be executed/loaded. Has anyone else tried using OpenVPN with the Xionia kernel?
    See if this fixes the issue: xionia_kernel_010_mod_bootimg_OptimusV_signed.zip
    04-12-2011 03:27 PM
  22. Eollie's Avatar
    Im using the v14 included with Zefies S rom of awesomeness.
    Is there anything I would gain by loading one of these?
    04-12-2011 11:33 PM
  23. mmarz's Avatar
    Im using the v14 included with Zefies S rom of awesomeness.
    Is there anything I would gain by loading one of these?
    I wasn't aware of a v14. It is not listed in the change log. Does everything work? Wifi, accelerometer, USB mount/dismount, 3G, overclocking, charging normal/slow...etc?

    These versions of the kernel try to fix what the S version breaks, usually one of the items I just listed.
    04-12-2011 11:51 PM
  24. Delphis's Avatar
    That did the trick. OpenVPN fired right up once some config issues were fixed.

    What was it that you changed?
    04-13-2011 02:28 AM
  25. mmarz's Avatar
    That did the trick. OpenVPN fired right up once some config issues were fixed.

    What was it that you changed?
    That was my bad. I put the wrong copy of tun.ko in that release. I linked the fixed copy in the main post. Thanks for reporting it!
    04-13-2011 04:02 AM
133 12345 ...
LINK TO POST COPIED TO CLIPBOARD