1. rlcbm's Avatar
    my tablet wont show the light when I plug it in unless I push it hard
    04-11-2012 10:01 PM
  2. souky's Avatar
    doyou know what to do mine wont charge at all
    10-28-2012 02:00 PM
  3. Sidney Lapinksi's Avatar
    thats what she said
    12-21-2012 04:52 PM
  4. Lisa_jia's Avatar
    it's the interface too loose?
    12-24-2012 01:06 AM
  5. Brooke Brooke's Avatar
    OMG MINES TOO! Mines does the EXACT same thing! And i can't get a new charger unless its online.And it costs 50 dollars!
    02-24-2013 03:27 PM
  6. pb5525's Avatar
    I just went thru the same problem with the Nexus 7. Everyone thought it was a software issue, it turned out to be that the USB mini port had become wide because of repeated insertions of the power/data cord. If you have a USB mini port, it could be your problem.

    sent from my Filemate Clear T720
    02-28-2013 02:14 AM
  7. HNNNNNGHHH's Avatar
    Interesting how it's always the budget tablets that have this issue with charging ports.

    I've had an Impression 10 i10-80 tablet for a while and the thing just won't charge without having to completely power it down. Nowadays, it won't even charge at all!
    04-10-2013 11:07 PM
  8. digginmain's Avatar
    My sero pro did that and I found that using my phone charger instead of the seros charger solved the problem
    02-28-2014 12:49 PM
  9. fedekpo91's Avatar
    Hi there! I am having the same problem with my iRulu AX107, I know it is chinease but it works fine. My problem is the battery charges but when it reaches 10-20% it makes a jump to 40-50%. You will see in the images below. It does the same when I am using it, for example I put a youtube video when 80% of charge and let it be until 4%. It took just 90 minutes to go through... What happens to my battery? My tablet was bought only 3 month ago!! I tried using both chargers, the real one that comes with it (1.8A) and the USB cable from my samsung (1A).
    I put my problem to avoid opening a new topic, I think it is more or less the same

    Here the screenshots:
    Tablet won't charge when plugged in-2180577screenshot2014030110.png
    Tablet won't charge when plugged in-2180576screenshot2014030110.png


    03-01-2014 05:27 AM
  10. cm8263's Avatar
    I have a Galaxy Tab 2 8.0 and i have the problem that it wont charge, so i had the battery replaced and that did not work then the cable and that worked for a while but now it wont charge again. SOME ONE HELP please
    03-24-2014 01:53 PM
  11. Gillian Stone's Avatar
    my irulu tablet wont charge either.....
    11-23-2014 04:27 PM