1. Robot one's Avatar
    Hi, folks.

    I'm very new here so a big hello to all, and as I'm very very new to Android I add a somewhat nervous grovelling grin as I beg your assistance with what appears to be a common problem with a device from the Allwinner A13 series of tablets.

    I was given a Q88 A13 that has the curious problem of starting to boot only to get stuck on a sweeping Android logo. The first thing you get when you press the power button is a small logo of a planet (I guess this is the eqiv of a bios screen) which disappears after a few seconds, then there is a temporary green Android logo (I guess this is a preboot screen), but this is quickly replaced by the sweeping Android logo which is where it stays.

    Oh, and if you turn it off it immediately powers itself on again, it was on when it was given to me, and will continue to do this as many times as you turn it off. The only sure way to power it off completely is to disconnect the battery, which means opening the case and unsoldering the connections.

    I got a charger, some cables, a small user guide all of which came in a generic Android tablet box which, along with the user manual, had no name, branding or other useful markings on it at all.

    However, some things I'm pretty sure I know for certain :

    - That it is in fact a Q88 A13. Just like this one - Pic
    - USB debugging is NOT enabled.
    - Erm! That's about all I know, really.

    Things I don't know:

    - What version of Android is on it.
    - If it has any non-self evident hardware or technology faults
    - How on Earth you get those reams and reams of details that people post when requested.
    - Basically everything else.

    OK. So I've been reading the forums here and abouts and have come to the conclusion that some data, or a whole partition, may be corrupt and it will need to be re-imaged. So with that in mind and many a year of Windows based repair complacency under my belt, I jumped right in with complete confidence that I could fix it and - Whoa! Some waters are murkier than they appear with many a monster waiting to frustrate. How you folks navigate this sinister web of uncertain ROMS, generic unmarked hardware and frustration inducing demons is beyond me, but my hat is off to you.

    The first thing I did was to try and connect it to my W7/X64 laptop via USB. No driver - no dice! OK, so some surfing revealed I could use the generic Google>Android USB ADB driver. Nothing happened. I rebooted the device and my laptop many times, deleted and reinstalled multiple USB drivers again and again, but no dice.

    I then considered the buttons trick and held the power button until it turned off, quickly pressed the volume up and then the power button until it started and I was presented with a boot menu with four options. :Erase user data partition :enter ADFU mode : Boot from image on SD card :Exit

    I chose ADFU mode as I figured the 'A' meant advanced and would give more options. Boy was I wrong! The screen went grey and pixelated as if it was some sort of low res test screen. I felt a little uncertain until a sneaking suspicion told me to try the USB cable again and I was rewarded by the double tone confirmation of windows detecting a new device. I had to install the driver manually, but it did show up in device manager as a generic Android device even if it failed to appear in Explorer.

    Here's how it look's in device manager with the generic Google USB driver I pulled from ADBDriver_v3_Google.zip. - Pic

    Here's how it look's in SuperDeview - Pic

    And it's properties in SuperDeview - Pic

    As you can see it has no serial number, product name or computer name.

    I then decided to try some of the software I had heard people use, so I installed the Java -> jdk-7u21-windows-x64 app and the android-sdk_r20.0.1-windows.zip. I followed the commands for the Android SDK but the Q88 would not appear in the device list as expected; in fact the area under devices was completely blank!

    I then tried AdbDriverInstaller.exe and again the tablet won't appear in the recognized devices list which remains blank. I also tried various versions of Livesuite again with the same problem of no device detected. (I downloaded what I assume is the correct Q88 image from a link on another web site.)

    I also downloaded Uberizer but gave it a miss as it seemed somewhat complicated to use and I was not confident it would be any more successful than the others.

    *Edit* I tried Uberizer and it couldn't see the device either.

    I then tried the boot menu option of loading an image from an SD card. I used Pheonixcard to burn the image on the micro sd card, inserted it into the tablet and selected the option to boot from SD card but when I pressed the button to initiate the rebuild it just returned to the four option boot menu.

    I then moved on to hardware problems as some places had mentioned disconnecting the battery for a while to reset the BIOS memory. So I opened the unit up ... here's a pic of what it looks like inside - Guts ... and wasn't surprised to find that someone had been there before. The sharp eye'd of you may notice a red circle where the power wires connect. These had been resoldered at some point, and not very well either. The yellow circle is where I snipped the batteries negative wire to shut it down once and for all. I left the battery disconnected for a day or so but it made no difference. Oh, and just for info, I connected the mains power with the battery disconnected and it behaved exactly the same as on battery power. The yellow arrow at the top of the pic is where the hole for the reset button is, and surprise surprise, there's nothing beneath it, which kind of explains my failed attempts at a hardware reset. The actual mic is about 1cm to the left of the arrow and has no corresponding hole in the front bezel to allow sound to enter.

    I'm beginning to think the unit may have suffered some sort of static or other electrical trauma,that had damaged the power circuit or BIOS(?) as I've seen this reboot problem caused by static shock many times in computers.

    So to sum up!

    I have a Q88 that cannot be turned off, hangs on a sweeping Android logo, has usb debugging deactivated, will only be recognized via USB when in ADFU mode and then can only be seen in Windows device manager as a device and not as a form of mass storage, and it cannot be seen in explorer or any re-imaging apps and behaves the same on either mains or battery power.

    As this technology is new to me I'm a little stuck for ideas of how to proceed. I guess I really need to find a way to force disable usb debugging from ADFU mode as I believe this may assist a great deal.

    If anyone had any ideas on what I can try next then I'd appreciate them being shared as I think if we can crack this problem it may solve a bunch of similar queries.

    I appreciate all considerations and apologise for the lengthy post.

    04-21-2013 12:59 AM
  2. Robot one's Avatar
    I posted a video on Youtube that may help explain the problem -

    Thanks for taking the time.
    04-22-2013 05:31 PM
  3. Hamza Ahmed2's Avatar
    I have a problem with my
    Q88 7 inch A13 Allwinner Android 4.0 Capacitive Screen 512M RAM 4GB

    Android version: 4.0.4
    Baseband version: 1.4rc3
    Kernel version: 3.0.8
    Build number: 713B2.V1.20.TZX.R01.eng.360.79.1030.AU

    Its wifi rage is verry small because i have to sit
    right next to the router to get any connectivity. but some one
    I know has good wifi connectivity with the same tablet but his
    specs are slightly different.

    Android version: 4.0.4
    Baseband version: 1.5
    Kernel version: 3.0.8+
    Build number: nuclear_evb-eng 4.0.4 IMM76D 2012115 test-keys

    Is thre any way I could upgrade to this? or can you upgrade the tablet to the latest firmware you have developed? or how I could do it?
    It would be really great if you can help,

    Thank you.
    Hamza (H-Digital Media)
    tacoking16 likes this.
    06-22-2013 03:25 PM
  4. Gourock47's Avatar
    This should work for your tablet too, I had the same issue.

    For the past couple of months, I have been searching for the firmware for my 7 inch A13 tablet (CE0127X from Focalprice). I have been communicating almost daily with Focalprice's support group and they were unable to obtain the firmware from their supplier.
    I have downloaded and tried over 90 images...I finally struck gold and found the one that makes the tablet fully functional again, everything works...even better than the original firmware.

    The image can be obtained from this link: https://www.dropbox.com/s/7vb7evm1fo...are.rar?v=0rc-

    The process that I used to install it as follows:
    1) Download and extract the image file.
    2) Connect a MicroSD card to the PC.
    3) Use PhoenixCard to write the image to the SD card.
    4) Place the SD card into tablet.
    5) Hold the Volume + button and while holding it depressed, press the Power button for a few seconds.
    6) The image will now be written to the tablet.
    7) Remove the SD card and start the tablet.

    Good luck
    07-08-2013 01:47 PM
  5. Samuel Duclos's Avatar
    your link is dead
    07-23-2013 09:23 PM
  6. leahyjp3's Avatar
    This image saved my tablet. Thanks!
    07-25-2013 01:01 AM
  7. Samuel Duclos's Avatar
    which link you use????
    08-19-2013 07:45 PM
  8. lovblealien's Avatar
    I was hoping to have an answer to my problem with your help BUT your link for "https://www.dropbox.com/s/7vb7evm1fo...are.rar?v=0rc-" states this everytime......

    "Error (509)
    This account's public links are generating too much traffic and have been temporarily disabled!"


    08-23-2013 12:34 PM
  9. Taajan3000's Avatar
    Yes I would like to get a hold of this img myself. Please repost.
    08-29-2013 01:02 PM
  10. frza21's Avatar
    can anyone re-upload this image?
    09-20-2013 07:47 PM
  11. Jeff G NJ's Avatar
    The image can be obtained from this link: https://www.dropbox.com/s/7vb7evm1fo...are.rar?v=0rc-
    Thank you, but the image cannot be obtained from that link any more, see posts 5-10 in this thread. I PMd you requesting a reupload or a better link.
    10-05-2013 10:38 PM
  12. Logan Christensen's Avatar
    Has anyone gotten a new link to this rom? If so could you pass it along to me?
    10-09-2013 05:38 PM
  13. Tariq Curtis's Avatar
    yes please send a new link with the file please. I can confirm that the original link is not working at all ! ?.
    I have the same problem with the same Tab.
    10-18-2013 01:32 PM
  14. 90Ninety's Avatar
    CAn someone PM or repost the link

    I need this !!!
    10-27-2013 04:32 PM
  15. Josiah Christian de Bien's Avatar
    Send me a link please, i have same problems as well as wifi and camera issues.. I think this will fix it.. Thank you.. Please send it here [email address removed]
    11-22-2013 07:50 AM
  16. Nathaniel Kreeger's Avatar
    are there any more links to the firmware img ? the link is dead and an easy fix like this would be super helpful. any help would go a long way. thanks.
    12-07-2013 06:59 PM
  17. Carolyn Boyle's Avatar
    Yes, please, it seemed as if I had finally found the solution to my problem, and after finally getting to the link that saved the tablet ... aaargh error 509

    If there is another place to find this image, please please please post it
    12-09-2013 03:51 PM
  18. Shehan Kannangara's Avatar
    it can,t download . pleas give me anther link..
    12-10-2013 02:30 PM
  19. Joycelyn Willock's Avatar
    can someone help me that link is down and I also need that image to get my tablet back working for school.
    thank you
    01-09-2014 02:49 PM
  20. PraetorianGuard's Avatar
    Which version is this firmware. Because I just got one of these free tablets but it doesn't seem to be able to connect to wifi.....
    03-24-2014 12:35 PM
  21. PraetorianGuard's Avatar
    I tried updating with this and now my touch screen doesn't work :/
    03-25-2014 06:13 AM
  22. Josh Miller7's Avatar
    Could I get an image link? thanks!
    04-16-2014 08:28 PM

Similar Threads

  1. Strange problem while trying to update. NEED HELP!
    By nismo300zx96 in forum Verizon Droid Incredible
    Replies: 12
    Last Post: 09-07-2010, 12:33 PM
  2. Help with Vonage and EVO - Strange Problem
    By jgladstone in forum HTC EVO 4G
    Replies: 8
    Last Post: 09-03-2010, 01:44 PM
  3. Strange problem with Google contacts
    By breugel in forum Verizon Droid Incredible
    Replies: 6
    Last Post: 08-21-2010, 11:38 PM
  4. Strange Problem
    By rtlsnke in forum HTC EVO 4G
    Replies: 1
    Last Post: 06-08-2010, 02:25 PM
  5. Strange Twitter problem - syncing removes contacts
    By TerryMasters in forum Android Apps
    Replies: 1
    Last Post: 05-29-2010, 02:51 PM