1. CillaC's Avatar
    I got my son a Visual Land Prestige Pro 7d tablet for Christmas. I love it. I recently got an 8gb sd card and put movies on it. Some were .avi files and others were .mp4 files. The ones I put on the internal storage work great. When I first mounted the sd card I noticed that some of the apps stored in the internal sd quit working. Restarted it, everything was fine. (any idea why that is?) Put movies on the sd card and noticed some I could fast forward and others I couldn't. Shortly after I realized those that wouldn't allow me to fast forward would only play 10 min of the movie then a msg would pop up "Unable to play Video". After playing with it for a while i re-converted some movies, wiped the sd card, mounted it, restarted the tablet (due to the apps stored on internal sd not reading), then added the movies. Viola! Everything worked great. All movies worked. I could fast forward. At the end of the day my son comes to me because his movie quit playing after 10 min. I messed with it for a bit and realized I was back at square 1. All videos quit playing the exact spot they did before. Any suggestions please. I've tried other video players and nothing works. Any feedback is appreciated.
    01-06-2014 12:19 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! Unfortunately, it may be a limitation related to how Android interfaces with external SD cards. Android actually doesn't provide native support for SD cards--devices that support them need code that kind of fools the device into thinking the external SD is part of its internal storage. If the code isn't very good, then there can be problems--this is one of the reasons Samsung devices seem to have an inordinate number of problems with external SD cards, and one of the main reasons why many manufacturers are no longer supporting external SD cards.

    So there might not be anything you can do. The main thing I would suggest at this time is to try a different external SD card, to see if it's a problem with that first SD card. SD cards can be faulty or counterfeit, which can contribute to poor performance.
    01-06-2014 10:22 PM
  3. scarhart's Avatar
    I had the same problem on an Akaso W100 tablet, and have it on my Asus ME-302C. Akaso tech support said it had something to do with the external SD card not having the proper RAM caching. Of course, the Akaso only had 2.5 GB of internal storage accessible to the user.
    08-05-2014 06:22 PM
  4. JT Peters's Avatar
    It might be the app you are using. I play MP4 movies from my external SD card using MoviePlayer.
    10-12-2014 04:57 PM

Similar Threads

  1. Very Strange S voice issue, on NOTE 3 Please Please try this and reply back with help.
    By Charlie Barton in forum T-Mobile Samsung Galaxy Note 3
    Replies: 67
    Last Post: 09-28-2015, 05:54 PM
  2. OBB file installation on Galaxy note 8
    By naungnow in forum Samsung Galaxy Note 8.0 Tablet
    Replies: 1
    Last Post: 01-07-2014, 01:24 AM
  3. New to Tablets...Plz Help w/Storage Issue
    By dranoel76 in forum General Help and How To
    Replies: 5
    Last Post: 01-06-2014, 10:47 PM
  4. Google Play error and "Unfortunately com.google.proess.gapps has stopped"
    By Delta122 in forum Android 4.1 / 4.2 / 4.3 Jelly Bean
    Replies: 6
    Last Post: 01-06-2014, 08:05 AM