03-22-2018 05:42 AM
103 ... 2345
tools
  1. Ryan8972's Avatar
    Ready for fix go into safe mode clear cache factory reset turn off plug charger into a usb on a computer connected to the internet after tablet is turned off then simply turn it on it will dowload all nessesary updates and place you at lag start screen lik brand new your welcome
    04-07-2016 01:21 AM
  2. IasosexyB's Avatar
    Yes!!!! Thank you, this did work on my child's tablet!
    05-15-2016 08:26 PM
  3. joanna 188's Avatar
    I have the Voyager. I set it down for a bit and when I came back it had the RCA logo. It sat there for at least 20 minutes before it turned off. It then turned back on and repeated the process. I left it upside down for the night because it was a huge distraction. When I woke up the battery had finally died. I plugged it in and left for school. When I got home it hadn't charged AT ALL. I got it from Walmart and didn't pay the extra $20 for a warenty. What should I do?
    05-17-2016 10:11 PM
  4. LADYB1268's Avatar
    It's happening to me too and I like you got it for Christmas they are trying to screw us over cause they told me at Walmart it's been longer than 90 days...............we want justice!!!!!!! And it is really sad cause I bought mine from walmart.com....................I thought that THEY HAD TO HELP US,THE WAY AMAZON.COM DOES!!!!
    05-22-2016 06:36 PM
  5. FuzzedMuffle's Avatar
    just bought the 10 inch pro from walmart hopfully i dont run into this anyone root the rca tablet?
    I have rooted mine, although this reply might be just a little late. I used kingroot then, switched out kingroot "super user" for the better alternative of "SuperSU". Know how to use recovery as it is posted step by step above and works almost as well as my Galaxy Tab3!
    05-26-2016 12:33 PM
  6. jmstepanek's Avatar
    Thank you for posting this. I bought a Voyager Pro for my husband and it was stuck on the RCA Android screen. I used the method you posted and it worked out just fine. Thanks again.
    05-29-2016 12:13 AM
  7. b3nt4h377's Avatar
    Thank you!!!
    07-24-2016 12:01 PM
  8. McmartaMcfly's Avatar
    This is not what comes up when you google what to do. THIS actually works. I couldn't get my tablet to reboot with the directions from Google. I did exactly what it said and then I got a screen that said Voyeur and after a few minutes, I was back to factory settings. This works.
    08-01-2016 02:16 PM
  9. robertpickard76's Avatar
    Um I was looking into the boot loop and maybe try to erase the cashe partition while doing a factory reset
    I had a Coolpad phone do the same alot if my friends phones did the same they returned them. I fooled around with volume and power. Like I was trying to get to the boot screen and it works fine.
    08-26-2016 10:15 PM
  10. DaNeshia Tennyson's Avatar
    Hello,
    I have a 7" RCA Tablet Dual core. Model RCT6378W2. The Tablet started getting slow with loading web pages and apps. So I turned it off and restarted it. It started up and stopped at the RCA logo screen. It will not progress past that screen. I have gone into the Android system recovery screen, performed a factory reset, and wiped the cache, but still no luck. I have searched on the internet to see if I could find either a stock ROM or a custom ROM to try and reload the OS, but am having no luck with that either.

    I have also attempted to root it using Kingo, but it won't recognize it since I can't turn on the USB debugging mode (This tablet was not previously rooted BTW). I'm not really sure where to go with this. Is there any hope for getting it working again, or is a just a paper weight now?





    I have the same problem and all you do is hold the ON\OFF button and the VOLUME UP button at the same time.
    Then you hold it down until you see a menu screen
    Use the VOLUME UP\DOWN buttons to move the cursor up and down and Select 'Factory reset'
    This should take one to two minutes time and all you lose is your pictures and the apps you downloaded but those can be reloaded again no worries! Hope you didn't throw the tablet away already
    08-30-2016 08:29 PM
  11. Nicholas Cannon's Avatar
    my RCA tablet keeps resetting every once in a while. I dont know why it keeps doing that.
    09-13-2016 09:51 AM
  12. Texas Red's Avatar
    The above solution fixed my granddaughters tablet. Hold the power button while at the same time holding the volume button up. When the screen changes let go of the volume . Release the power botton, then press it again and tap the volume up a few times. My screen restarted

    Good luck i hope this helps someone
    09-14-2016 03:00 PM
  13. Robt0753's Avatar
    push volume button twice
    11-24-2016 10:33 AM
  14. kattail9x's Avatar
    I fixed My Grandsons last night .We have been trying for almost a year to find a solution with no luck.I removed both screws from bottom of tablet then snapped the case off and unplugged every cable I could find connected inside the tablet.Let it sit over night then re-assembled the tablet this morning.Connected the charging cord and waited til it said 5% charged after that pressed the power button and the tablet started right up just like new.So glad I fixed it as he was only able to use it a few times after he got it for Christmas last year new when he had this problem.Hope this helps You and all the others fix Your tablets.Thanks
    12-31-2016 08:40 AM
  15. eightbiscuit400 thomas's Avatar
    I have an rca maven pro model # rct6213w87m I' ve been trying to get it unstuck from the maven pro logo. I've reset it and tried to hard reset it. Can someone please help me with this problem. And also can someone tell me if u put too many apps on the computer will that freeze it up.
    01-17-2017 10:15 AM
  16. Tyler Rumer's Avatar
    hold the volume and then the power button at the same time until the screen turns black then turn it back on and then it'll work
    01-25-2017 02:34 PM
  17. s offenza's Avatar
    Not likely. RCA is just poorly assembled. Then all kinds security features to prevent you from revealing its potential.
    02-04-2017 04:55 PM
  18. B. Diddy's Avatar
    I have an rca maven pro model # rct6213w87m I' ve been trying to get it unstuck from the maven pro logo. I've reset it and tried to hard reset it. Can someone please help me with this problem. And also can someone tell me if u put too many apps on the computer will that freeze it up.
    Welcome to Android Central! It doesn't have to do with the number of apps you've installed. This kind of behavior is usually due to a fault with the device's hardware (like the motherboard) or the firmware (i.e., the system software). It's usually not easily fixable.
    02-04-2017 09:26 PM
  19. TheGoldenCreeperGaming's Avatar
    This happened to both my Voyager RCA and Viking Pro 10.
    02-18-2017 10:32 AM
  20. SugarCat's Avatar
    I have problems with one too. Ours the settings.pak keeps crashing so I can't manage storage at all. Can't find original rom anywhere nor a replacement settings.apk.
    Will I was on my rca tablet it said that it was overheating and needed to be cut off, and then it automatically shut down. When the tablet cooled down (about 30 minutes later) I tried to cut it back on. It got past the dog screen and went to the logo screen. After waiting a couple of minutes staring at the logo it went back to the dog screen. This continued to happen until the tablet died and completely shut down. I tried plugging in 3 different rca chargers, 2 phone chargers, and I plugged it into the computer. After waiting a couple of days for each charger it was still on 0%. While "charging" the battery screen kept flashing on and off either saying 0% or 1%. I tried cutting it on from their but it would automatically shut back down. I also tried pushing the reset button but it didn't work and still won't charge, and removing the battery was no help. The dog screen won't even pop up any more. I tried fixing it many different ways but nothing works.

    This all makes me sad because I use my tablet for everything, and it is basically my life, so if anyone has the solution or any advice I would greatly appreciate having help.
    03-01-2017 08:20 PM
  21. Snatchbrat_meh's Avatar
    I guess I'm the only one with this problem.... No one has any ideas?
    Guess what guys? My rca tablet is crap like yours. However, I did find this post and from what he says you need the keyboard attached to the tablet to perform the reboot. here is what i found. also there is a post following this one that where he says he tried it and it worked.

    Sain_1 September 28, 2016 7:41:22 PM
    Click the power icon in the lower right corner of the login screen. Hold the shift key while clicking the power reset option. Make sure to hold the shift key until the blue screen appears. Select troubleshoot. And just follow the process options for factory reset. The "Full reset" option takes longer than the "Just my files" option. You will lose all saved files, such as, photos, music, and documents. Hopefully this is helpful to anyone who may run into a problem which requires the resetting of a Windows 10 Tablet. ALSO YOU WILL NEED A KEYBOARD TO COMPLETE THIS TASK SO YOU CAN USE THE SHIFT KEY. TO CONNECT A KEYBOARD TO YOUR TABLET SOME MAY NEED AN OTG (ON THE GO) ADAPTER CABLE IF YOUR TABLET IS NOT EQUIPPED WITH A PROPRIETARY KEYBOARD DOCK. ENJOY. H. Muhammad

    im gona go get the keyboard to see if it works. doesnt hurt to try.
    03-02-2017 07:15 PM
  22. ACHIEVEMENT GAMING's Avatar
    My RCA ttablet it is a voyager pro, whenever I turn it on the tablet makes it to the voyager pro logo and stays on it it won't get passed it what do I do I think it has a virus on it
    05-24-2017 08:36 AM
  23. RackelRect's Avatar
    I have an RCA Tablet model w101 v2,, we recently bought it and my husband set it up for our daughter. Needless to say passwords we're forgot and issues arise.. hah,, We attempted a "hard reset" for the longest time. A friend finally got it to work. Turned it off, back on.. and it loads to the white RCA logo and stops.. we don't have the keyboard for it handy we're in the process of moving with no regard of organization. So if there's a way of getting past this issue without it, that would be wonderful!
    05-31-2017 07:24 AM
  24. mrsAF's Avatar
    Hey everyone. One day my son's tablet RCA model RCT6873WA2 stop working properly. It has been running, on voyager logo, then it was stuck on starting android, starting apps screen for almost two months. It would not power off. Today I took a safety pin to the back and reset it. Before it statrted up, I held the power and volume up button. It will take you to factory screen, scroll using volume buttons to clear data and then cache. Press power to select. Scroll to power off and then turn it back on. Tablet is completly reset. It should start the welcome screen. Hope it works for you. Good luck.
    07-05-2017 12:50 PM
  25. mrsAF's Avatar
    See my post below yours. Hope it help.
    07-05-2017 12:57 PM
103 ... 2345

Similar Threads

  1. S4 black screen during call, proximity sensor works fine. Ideas?
    By Huff in forum Sprint Samsung Galaxy S4
    Replies: 3
    Last Post: 05-02-2014, 07:12 AM
  2. Nexus 7: screen protector recommendations?
    By ErnstMach in forum Google Nexus 7 Tablet (2013)
    Replies: 8
    Last Post: 04-13-2014, 06:45 PM
  3. Replies: 1
    Last Post: 04-07-2014, 08:02 PM
  4. POST YOUR HTC M8 Home Screen!!!!!!
    By Alleyviper13 in forum HTC One M8
    Replies: 1
    Last Post: 04-06-2014, 09:54 PM
  5. Unable to write on a small portion of the screen
    By bcfour in forum Samsung Galaxy Note 10.1 (2014)
    Replies: 4
    Last Post: 04-06-2014, 09:05 PM
LINK TO POST COPIED TO CLIPBOARD