1. AC Question's Avatar
    Had to restore my zte z664c phone to factory default. Tried to sign in to Google with my gmail address. Received message 'This can take a few minutes'...16 hours later, rebooted an tried again. Same problem.
    01-14-2016 07:45 AM
  2. FiveOverEight's Avatar
    Do you have two-factor authentication active on your Google account?
    01-14-2016 08:13 AM

Similar Threads

  1. Replies: 3
    Last Post: 12-04-2016, 11:05 AM
  2. How do I turn on background data on my Google Play Store?
    By AC Question in forum Google Play Store
    Replies: 5
    Last Post: 07-29-2016, 01:59 AM
  3. Remitting sales tax for Google Play paid apps and in-app purchases
    By richard_walters in forum Software Development and Hacking
    Replies: 1
    Last Post: 02-18-2016, 04:59 AM
  4. Google play services data usage and push notification, can I get some help?
    By AC Question in forum General Help and How To
    Replies: 1
    Last Post: 01-14-2016, 04:04 AM
  5. Replies: 1
    Last Post: 01-13-2016, 08:22 PM
LINK TO POST COPIED TO CLIPBOARD