1. Zia Tahir's Avatar
    I got this phone couple of days ago and today is the first day I have brought it to work where I usually dont have network signals as it is pretty enclosed area. The problem is that when I get out of that area for coffee breaks and lunch etc, the connection with "FIDO" my service provider does not reconnect automatically while it used to do earlier with previous iphone I had. Every time I get out I have to give my S4 a restart and it will catch the signals then. FIDO provides the LTE connection so the default setting would have been fine in S4 but I even tried to put the network selection setting to a bit lower but it still says the same. My model number is I337.

    I was searching the net and found out that poor connection was complained by lots and lots of Indian people, now I dont know if they had the same model number or in any way there problem is related to me but it definitely raised my eyebrows.

    Can someone help please.

    Thanks

    Zia
    09-03-2013 06:11 PM

Similar Threads

  1. Replies: 6
    Last Post: 07-25-2014, 10:06 AM
  2. Is my Galaxy S4 faulty
    By Edible Walrus in forum Samsung Galaxy S4
    Replies: 10
    Last Post: 10-17-2013, 06:27 AM
  3. problem uploading films to my nexus 7
    By anthonyregan1981 in forum Google Nexus 7 Tablet (2012)
    Replies: 5
    Last Post: 09-03-2013, 05:59 PM
  4. s4 batteries fit the note 2?
    By Shuckster in forum Samsung Galaxy S4
    Replies: 3
    Last Post: 09-03-2013, 04:31 PM
  5. s4 v note 2
    By Shuckster in forum Samsung Galaxy S4
    Replies: 1
    Last Post: 09-03-2013, 04:24 PM
LINK TO POST COPIED TO CLIPBOARD