1. banahank95's Avatar
    I bought the A3 back in September and around December I had a problem with the battery not charging. I would plug it in using the correct charger and it wouldn't increase or go down for an hour while plugged in.

    Then I looked at it again and the battery began to decrease it went rapidly from 7, 6, 5... The battery went down as far as zero. The next day I tried to charge it again and it wouldn't. I tried everything and nothing worked.

    3 days later it did start to charge again but it lost battery quite quickly again. I was told it was faulty so I got the same phone again (stupidly).

    I transferred all of my data over on the new phone again, set everything up which took forever and now I'm faced with the same issue. Again!

    I don't know what to do and I need a solution that as I'm not currently living in the country I bought the phone so I can't return it until April.
    03-18-2017 03:47 AM
  2. jasonandrews25788's Avatar
    It's a hardware issue, maybe the charger or the battery itself try change them.
    03-20-2017 06:58 PM

Similar Threads

  1. Replies: 1
    Last Post: 03-18-2017, 03:19 PM
  2. Replies: 1
    Last Post: 03-18-2017, 05:44 AM
  3. Why can't i sign in bluestacks?
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 03-18-2017, 03:03 AM
  4. Tablet in-car install questions
    By RickJames8 in forum Google Nexus 7 Tablet (2013)
    Replies: 0
    Last Post: 03-17-2017, 11:17 PM
  5. Why do i have a google apps build in my andriod dated 1970?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 03-17-2017, 09:40 PM