1. joebeaven's Avatar
    Hi,

    I've had my Samsung Galaxy Ace 3 for almost a year and the WiFi's worked great until about a month ago. Since then I've only been able to get WiFi at home through my own router. I can't get it anywhere else including Tesco and Asda which I always used to get a strong signal in. Please could someone tell me how to get my WiFi working everywhere again?

    Thanks,
    Joe
    07-09-2015 12:01 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! Moved this to the correct forum. Does the phone even detect those public networks? Does it give you an error message when trying to connect? Have you tried forgetting any of the remembered public networks, then trying to connect again?
    07-09-2015 01:07 PM
  3. joebeaven's Avatar
    Thank you for the welcome. The phone does detect the networks. I tried forgetting all the ones I could and then I went to Asda and Tesco to test them. In Asda I was eventually able to get a connection after I was texted an access code, which I haven't had to do before, but it did work. In Tesco there was clearly Tesco WiFi available which said it was connected, but I couldn't connect to the Internet. There was also another network called BT Openzone which appeared to be active at the same time and whenever I tried to use Google Chrome, it just forwarded to btopenzone.com, so I don't know if that was taking over somehow. Also, the only non-secure WiFi network that I was unable to forget was BTWiFi-with-FON. I think I may have tried to connect to that about the time I started having the problem, but it asked me for money so I ignored it, so that may be the cause.
    07-10-2015 12:32 PM
  4. B. Diddy's Avatar
    When you connect to Tesco, do you also open the browser to see if you have to accept their terms and conditions before being officially connected?
    Laura Knotek likes this.
    07-10-2015 02:31 PM
  5. FiveOverEight's Avatar
    You may find these aren't totally "open" networks like they used to be and you may actually have to login somehow.

    Asda actually has it on their website;

    1. Select Asda Free WiFi from your network list on your phone
    2. Enter your mobile number
    3. Receive a text message with your access code
    4. Enter the access code into the log in screen
    5. Enter your details and click go
    B. Diddy likes this.
    07-10-2015 03:28 PM
  6. joebeaven's Avatar
    I did that stuff in Asda and it now works fine there. I don't get any page like that in Tesco. I've been trying it walking around town, which always used to work, but now whichever network I try to connect to I just get the BT Openzone page. If I try to go anywhere else it says I'm not connected. I don't get any other error message.
    07-11-2015 10:49 AM
  7. B. Diddy's Avatar
    See what happens if you clear your Chrome's browsing history. You can go to the App Manager, select Chrome, and Clear Cache/Clear Data.
    07-11-2015 05:18 PM
  8. joebeaven's Avatar
    I tried clearing the cache, but I still get the same thing when I'm in Tesco or in town. If I open Chrome and try to go to a website, it just forwards to btopenzone.com.
    07-13-2015 10:16 AM
  9. B. Diddy's Avatar
    So you open Chrome, and it automatically goes to btopenzone.com. What happens if you then open a new tab in Chrome, and type in a URL? Does that still force you to go to btopenzone? I'm wondering if your Chrome somehow has btopenzone.com set as a homepage, which is automatically opening whenever you open Chrome (or open a new tab). Chrome usually doesn't have a homepage option, but for some reason, Chrome on some Samsung devices does have the option.
    07-13-2015 06:22 PM
  10. joebeaven's Avatar
    I decided to reset my phone to factory settings and enter my contacts in again and re-download my apps, which I've now done. I went to Tesco and tested my phone. The Amazon app which I like to use in shops told my I wasn't connected. When I tried to use Chrome, it worked when I searched for something in Google, but when I clicked on a result which should have gone to Wikipedia, I got a message saying: "This is probably not the site that you're looking for". There was a lot of text which told me that my phone was trying to go to btwifi.com instead of wikipedia.org. When I checked my WiFi connections it said it was connected to Tesco, but BTWiFi-with-FON is still there too and I can't seem to get rid of it.
    07-15-2015 03:42 AM
  11. B. Diddy's Avatar
    This is quite strange. Is the "Tesco" network the one that customers are supposed to use? Sometimes stores can have multiple different SSIDs, where only one of them is intended for customers, and the others are for internal use only.

    When wi-fi is on, it will show all nearby networks, regardless of whether you've ever connected to them or not. So you can't get rid of BTWiFi-with-FON if it's a nearby network. If you've ever connected to it, you can always long-press it and tap Forget, but it will still be displayed in the list when you're within range.
    07-16-2015 01:38 AM
  12. joebeaven's Avatar
    I've been to Tesco twice in the last couple of days to test. There's only one Tesco WiFi network available. Up to now it's been saying it's connected, even though it seemingly hasn't, but the last couple of days it's been saying there's no signal or it's not strong enough. I asked at customer services and I was told that the WiFi should be working fine and that it was strongest at the coffee shop section. I went to the coffee shop, but my phone still said the Tesco network was too weak to connect.
    07-17-2015 08:50 AM
  13. B. Diddy's Avatar
    I'm really starting to grasp at straws now. Here are some further thoughts:

    1. The network isn't set to connect via Proxy, is it? While connected to Tesco, go to Settings>Wi-Fi, long-press the Tesco network, tap Modify Network, then Advanced Options, and make sure Proxy is set to None.

    2. Perhaps the firmware has become corrupt somehow. Try using Kies to reinstall the firmware. Or you could use Odin and flash the correct firmware: http://forums.androidcentral.com/amb...interface.html . Find the correct firmware here: Firmwares - SamMobile

    3. Maybe it's a hardware issue, in which case I'd have nothing else to offer.
    07-18-2015 01:24 AM
  14. joebeaven's Avatar
    I have no idea why, but yesterday it started working again and now seems to be fine. I don't think I've done anything to it to make that happen, but I'm very pleased about it. Thank you very much for your help. I'll certainly try your suggestions if it happens again.
    B. Diddy likes this.
    07-20-2015 12:08 PM

Similar Threads

  1. Can't download some apps when using wifi
    By Ilijas Sahinovic in forum Samsung Galaxy S6
    Replies: 6
    Last Post: 07-09-2015, 04:53 PM
  2. How to take off the safe mode on my cell and how to repare the software
    By Nefertiti78 in forum Samsung Galaxy Mega 6.3
    Replies: 1
    Last Post: 07-09-2015, 01:13 PM
  3. How do I turn off all the notifications on my screen
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 07-09-2015, 12:27 PM
  4. Replies: 2
    Last Post: 07-09-2015, 12:25 PM
  5. how do I get the digital clock to show on the home page
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 07-09-2015, 11:14 AM
LINK TO POST COPIED TO CLIPBOARD