1. AngelicVanguard's Avatar
    Yeah just tried to root my galaxy alpha g850w and its stuck on the firmware upgrade encountered screen and i cant get into DL mode nor connect it to keis. PLEASE HELP.
    12-28-2014 04:21 PM
  2. CosmicDogshit's Avatar
    Hey, I've done the same thing and Kies doesnt seem to work for the Alpha! Any suggestions? Did you get it sorted out? Thanks
    01-05-2015 10:17 AM
  3. kgr's Avatar
    Hey guys I think I found a solution to this. LMK if you're still in need, and I'll try to do up a document or something (with proper credits of course!).
    I tried to link the solution here and got an infraction

    Regards
    Ken
    02-07-2015 07:59 AM
  4. foxbat121's Avatar
    For Samsung devices, ODIN is your best friends in cases like this. Kies is quite useless and only good for applying OTA updates.
    02-07-2015 08:14 AM

Similar Threads

  1. Why is my nexus 7 not updating to lollipop?
    By maxxmitch14 in forum Legacy Android & Other OS's
    Replies: 29
    Last Post: 01-24-2015, 08:27 AM
  2. Turn Note 3 to Note Pro 12.2''
    By ioannisgk in forum Samsung Galaxy Note 3
    Replies: 3
    Last Post: 01-01-2015, 09:23 AM
  3. l39c bumped wrong button when asked to ok connect to laptop
    By ILoveMinecraftMaggie in forum LG Optimus L
    Replies: 1
    Last Post: 12-29-2014, 04:50 AM
  4. How to Remove Word Suggestions?
    By Schildklierafwijking in forum General Help and How To
    Replies: 1
    Last Post: 12-28-2014, 05:55 PM
  5. Remove music from device and not library?
    By michaelcsun in forum Legacy Android & Other OS's
    Replies: 1
    Last Post: 12-28-2014, 05:34 PM
LINK TO POST COPIED TO CLIPBOARD