1. Nathan Ken's Avatar
    Hi! I have a problem and it needs to be fixed ASAP.. because im under time pressure.
    On Early Tuesday morning i am going away for Christmas to my family. I really need my phone
    for the plane flight that is approx 3 hours.. then a 4 hour drive to my home town from the Airport.
    I own Samsung Galaxy Alpha where the battery isn't great... it really easily discharges and all that.. i didn't
    do a hard reset ever since i picked up the phone i used it for like 2 and a half - 3 years. So i've decided to hard
    reset (note that my device was rooted for a good few months).

    Everything went well after i un-rooted the phone and reseted it. The OS Setup before the phone allows you to do anything in it.. there came the problem. When i got asked for my Google Account i wrote it in.. but i've noticed a strange thing, it was that every other "Just a Sec.." Screen had the little swiping animation and it took a few moments (3-7 seconds). But after i wrote down my google account pass and username, there was no animation for a few brief seconds and then it slightly lagged out and started loading for like ages. I waited for over 30 minutes and i have decided to go back and skip the google account activation. When i came into the phone itself.. i went into Apps/Accounts/ I tried adding a Google Account.. but again, after i tried to add it after entering my creditinals it just went black screen for a moment and threw me off to my setting menu. I've scrolled down to the Accounts Tab and there was no Account added.

    I've tried to Factory Reset again.. same thing.. i've tried clearing all of my Google Cache/Data stopped whatever i could etc. Also, i do have a Power Bank but due to a quick battery discharging my Power Bank is not very effective that way... because it takes all the power from the bank real quickly.
    Hopefully somebody can help!
    Thanks and sorry for writing so much.
    12-18-2016 12:40 PM
  2. Nathan Ken's Avatar
    Would need help ASAP.
    Thanks
    12-18-2016 01:17 PM
  3. havocjl's Avatar
    The same thing just happened to my device.
    Did you find what went wrong?
    12-19-2016 09:52 AM
  4. havocjl's Avatar
    Hi, just fixed the problem.

    I had to downgrade back to kitkat (4.4.4) and then was able to log in to Google.
    After that just upgraded back to lollipop (5.0.2) through the phone's update.

    Hope it works for you
    Cheers
    12-19-2016 02:31 PM

Similar Threads

  1. Netflix but no google play...huh???
    By Richard Servello in forum Google Home
    Replies: 15
    Last Post: 04-11-2017, 01:11 PM
  2. Kodi buggy after nougat?
    By erojas388 in forum HTC 10
    Replies: 3
    Last Post: 01-06-2017, 09:01 AM
  3. Google play services won't work
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 12-18-2016, 02:35 PM
  4. Replies: 1
    Last Post: 12-18-2016, 02:35 PM
  5. Replies: 1
    Last Post: 12-18-2016, 12:09 PM
LINK TO POST COPIED TO CLIPBOARD