1. shlmon's Avatar
    My T-Mobile galaxy light SGH-T399 is stuck in boot loop with the Samsung logo splash screen.

    It looks like it tries to reboot each time but it get stuck in the splash screen.

    I've tried entering 'Recovery Mode' with Volume Up+ Home+ Power but it didn't enter that mode.

    On the other hand Odin Mode does work (with the Volume down instead) and I've tried installing new firmware but still, the phone is stuck.

    Need some help, Please.
    05-31-2014 06:14 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! Did you follow the steps outlined here exactly? That is, did you hold down Vol Up, Home, and Power until you felt it vibrate? Or does that not happen?

    Reset: Samsung Galaxy Light | T-Mobile Support
    05-31-2014 06:18 PM
  3. shlmon's Avatar
    Hey, I followed the steps but the phone doesn't vibrate, it just keeps rebooting
    Andrea Britton likes this.
    06-03-2014 04:32 AM
  4. B. Diddy's Avatar
    Two other things to try:

    1. New battery. Your current one might be failing.
    2. If you have an SD card, unmount it and remove it, then reboot. A corrupt SD card can cause problems.
    06-03-2014 11:26 AM
  5. shlmon's Avatar
    I can enter to Odin mode and the battery doesn't fail so I think the battery is not the issue,
    Secondly I am not using SD card.

    My phone is still stuck! It want pass the boot step..

    Please, help!
    06-06-2014 03:37 AM
  6. B. Diddy's Avatar
    Wish I could help you more, but that's the extent of what I know. Hopefully someone else can weigh in.
    06-06-2014 03:53 AM
  7. Kleajmp's Avatar
    I have the exact same problem, did you find a solution?
    08-10-2014 08:55 AM
  8. 8lackie's Avatar
    These are the threads that drive me crazy. I come looking for a solution too. Come to find this thread has been dropped, no resolution, no explanation. A veritable stinky dead-end.
    10-30-2014 10:45 PM
  9. Mike Torgersen's Avatar
    I have had the same problem with other Samsung phones. I found multiple possible causes listed. But in all my cases the issue was the battery. Three times I cleaned the contacts, discharged then fully charged (using external battery charger) they eventually booted correctly and Two needed battery replacement. I may just have been lucky, but all five were not system problems.
    11-10-2014 03:50 PM
  10. Samir Issa's Avatar
    When you download the new firmware did u stall on the screen where it says your provider (like T-mobile), most likely you have to wait like 20 miniutes or so, then your phone will start up good as new again.
    01-17-2015 08:58 PM
  11. Andrea Britton's Avatar
    Mine to trying to start with master reset and all it says is no comand
    03-10-2015 12:39 AM
  12. Andrea Britton's Avatar
    Mine to trying to start with master reset and all it says is no comand
    03-10-2015 12:47 AM
  13. Shawn Paul1's Avatar
    same issue for me. you fixed your device? if it fixed plz guide me how to fix it
    04-21-2015 11:00 PM
  14. FattyMatty1996's Avatar
    Same issue if someone does fix it let use know
    07-04-2015 11:21 AM

Similar Threads

  1. LED Indicator lights do not turn on
    By upacrick in forum Samsung Galaxy S5
    Replies: 6
    Last Post: 12-09-2014, 06:56 PM
  2. Rooted Samsung Galaxy S3
    By ddiehl in forum Marketplace Archive
    Replies: 3
    Last Post: 06-04-2014, 07:16 PM
  3. LG G3 or Samsung S5 (Sprint)
    By ravensong03 in forum General News & Discussion
    Replies: 2
    Last Post: 06-01-2014, 01:42 AM
  4. Headache with MP3, MP3 tags, and SD cards...
    By zerrisk in forum Samsung Galaxy S5
    Replies: 2
    Last Post: 05-31-2014, 06:31 PM
  5. Galaxy s3 reboots very freqquently plz HELP
    By Saqib Rana in forum Samsung Galaxy SIII I9300
    Replies: 0
    Last Post: 05-31-2014, 03:10 PM